Jump to content
LostInTranslation

Possible bug in Publisher with ligatures

Recommended Posts

I am working on a technical catalogue.
There are a couple of technical drawings that I had to refine in Designer.
From there I exported each one of them as PDF and then imported them into Publisher.

To my surprise, the text was all scrambled up in Publisher.
I investigated and found that I had "Standard Ligatures" on in Designer. If I turn them off, the import into Publisher works.

But it should also work with Ligatures on, shouldn't it?

See here:

publisher_error.thumb.png.00be2077825c5de2f3567c43e48f71a1.png

Share this post


Link to post
Share on other sites

Apart from the bug with the ligatures, why don't you simply place the afdesign files or copy the element? Does this work in your case?

Anyway maybe you can post your .afdesign file here, so that others could have a look at it.

Share this post


Link to post
Share on other sites
3 hours ago, Joachim_L said:

Apart from the bug with the ligatures, why don't you simply place the afdesign files or copy the element? Does this work in your case?

Anyway maybe you can post your .afdesign file here, so that others could have a look at it.

I have multiple of those drawings in one Designer-document, but I need them individually in different places in Publisher, so going over PDF seemed the most convenient way. I worked around it by unchecking Standard Ligatures. Just wanted to report what is most likely a bug.
Can't post the complete file here, since it is the intellectual property of my client, but the detail I posted explains it well.
When I just open the PDF it still looks good, only after importing the "ti" is gone.

Share this post


Link to post
Share on other sites

Ligatures are notorious for being difficult to deal with in PDF's as others have suggested there are much better ways of moving objects between the applications. I would open the designer file in publisher and either copy the objects or make assets from them for use in Publisher.


Living the Dream since 1964 - about 25 years left

Share this post


Link to post
Share on other sites

I have just had an issue with ligatures and pdf export. I exported a 20 page newsletter as a pdf for web using the standard export and all the ff characters appeared as single f, yet when cut and pasted from the pdf showed up as ff.  I was using standard MS fonts as body text, in the main arial and times roman italic. As most of my work is done free for charities and third sector groups who cannot afford to have these printed I have turn off standard ligatures as they do not really enhance the type of work I am doing. How can I change the default to off as it seem to be on each time I open a new document and I cannot seem to find it in preferences

Share this post


Link to post
Share on other sites
25 minutes ago, AlanPickup said:

How can I change the default to off as it seem to be on each time I open a new document and I cannot seem to find it in preferences

You might try:

  1. Creating a new Publisher document.
  2. In the Text Styles studio panel, double-click on the Base style to edit it.
  3. Turn off all the Ligatures under Typography.
  4. Click OK to save your changes.
  5. Use the Text Styles panel's hamburger menu to save the current styles as your defaults.

image.png.0d69df81630df778a0272ac95e3d547a.png 

 

default-styles.png.84da2586365ff6fad05e068af06fe462.png

image.png


-- Walt

Windows 10 Home, version 1903 (18362.239), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.2.471 and 1.7.2.464 Beta   / Affinity Designer 1.7.2.471 and 1.7.2.4464 Beta  / Affinity Publisher 1.7.2.471 and 1.7.2.458 Beta

Share this post


Link to post
Share on other sites

Hi Walt

Thanks for the info, but not sure if I am doing it right. I clicked on the base style and edited it and saved it as default. Closed down and opened a new document clicked on base layer and all ligature boxes are uned, but if I open a new text box and click on the top bar Text>Typography the Ligature box is still ticked and the Text>Ligature is set at default. 

 

image.png.9a866c779185f2ea71b3cef9f29dcd8f.pngCapture2.PNG.a35129053c0b196ab4201f1db06ab53e.PNG1883470512_Capture1.PNG.b8640a9b53cfbd8e80b47860c8cdce38.PNG

Share this post


Link to post
Share on other sites

 


-------------------------------------------------------------------------------------------------------------------------------
Win10(1903)Home / Photo / Designer / Publisher & latest (beta) versions

Share this post


Link to post
Share on other sites
27 minutes ago, AlanPickup said:

but if I open a new text box and click on the top bar Text>Typography the Ligature box is still ticked and the Text>Ligature is set at default. 

You will need to use paragraph styles.


-- Walt

Windows 10 Home, version 1903 (18362.239), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.2.471 and 1.7.2.464 Beta   / Affinity Designer 1.7.2.471 and 1.7.2.4464 Beta  / Affinity Publisher 1.7.2.471 and 1.7.2.458 Beta

Share this post


Link to post
Share on other sites

Again I do not know whether it me or not so I create a new text box select body in the paragraph panel and typography shows Ligatures unticked.  So create a new text box and it is still showing body in paragraph and ligatures is now ticked for this text box, I have to re-select body in paragraph and it goes unticked. Does this mean I am going to have to do this every time I create a text box?

PagePLus 9 all is forgiven baby I am coming home, hope you still love me

Share this post


Link to post
Share on other sites

You can define the default paragraph style for a text frame by first clciking the text frame tool and then clicking the desired paragraph style. If that style has ligatures disabled then you do not have ligatures in the newly created text frame.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×