Jump to content

Recommended Posts

I'm trying to switch from Adobe. I'm hung up on printing. What am I missing?

I've a biggish photo. Document resize shows it as 19" square, 4948 pixels, at 180 DPI. I want to print on 8.5x11 paper with a fair amount of border. My Photoshop workflow for this is to go into document resize, set the view to inches, and with resample OFF change the DPI to see what I get. Then I decide from there what to do - let LR handle it, or resample the document.

In Affinity Photo, Document resize *won't change the view* when I change the DPI. I see a post here that changing the DPI won't change anything in the dialog, just change a metadata setting. Well, changing the DPI won't change the pixel count, but it sure will change the inches. Phooey. However, thinks I, maybe I can let the print dialog handle it. Having changed the DPI to 360 dpi, I would expect my 13x13" document to be half its size in inches and fit handily on 8.5x11 paper. Nope, it still shows red in the print dialog. Well, thinks I, maybe I can change the scaling. Remember, I don't want to fit to printable, I want to have some border. So I select "Scale" and set to 50%. Nothing happens. When I click out of the number window, it goes back to 100%.

Please help. Will I be reduced to exporting into something Photoshop and Lightroom can handle? That's a real clumsy workaround.

  - newbie susan

Share this post


Link to post
Share on other sites

What I do (and I was surprised I had to do this in multiple steps originally but it's fallen into the "eh" category) is this:

  1. Modify the DPI by Document > Resize Document 
    1. Change the DPI
    2. Uncheck Resample checkbox
    3. Click "Resize"
  2. Modify the size of the document by Document > Resize Document
    1. Change the Units value as desired
    2. Change the size to desired size in the selected units
    3. Change the resample method as needed
    4. Click "Resize"
  3. Print...

You probably mention elsewhere, but not here: what platform? When I try this on macOS, I get visual changes to the preview as expected (and large borders) when I change the scale factor to, for example, 50%. Maybe post some screenshots or a screen capture video of your failure case?

Screen Shot 2019-07-11 at 11.20.01 AM.png

Screen Shot 2019-07-11 at 11.20.11 AM.png


https://bmb.photos Focus: The unexpected, the abstract, the extreme, including paper outputTools: macOS (Primary: Mojave, MBP2018), Canon (Primary: 5D3), iPhone (Primary: X), Epson

Share this post


Link to post
Share on other sites
Posted (edited)

Thank you, Brad. That set of steps seems to work. Clumsy, but we make allowances for very young software. Hopefully they will simplify it in another release. Meanwhile it is a good candidate for a macro.

I still have a problem with the "scale" function in the printer dialog. I got it to work a couple of times, but then no, it kept jumping back to 100% no matter how I tried to click away from the % dialog box. This is all without closing the print dialog. MacOS 10.14.5.

  - newbie susan

Edited by slchapin41
forgot to specify OS

Share this post


Link to post
Share on other sites
2 minutes ago, slchapin41 said:

I still have a problem with the "scale" function in the printer dialog. I got it to work a couple of times, but then no, it kept jumping back to 100% no matter how I tried to click away from the % dialog box. This is all without closing the print dialog. 

That one is a bit baffling; maybe someone else will have some input? The only thing that comes to mind is maybe something with the printer driver -- that's where those options come from under macOS. Are you using a current/common printer or something a little more esoteric?


https://bmb.photos Focus: The unexpected, the abstract, the extreme, including paper outputTools: macOS (Primary: Mojave, MBP2018), Canon (Primary: 5D3), iPhone (Primary: X), Epson

Share this post


Link to post
Share on other sites

It's an Epson P600. Good thought to update the driver. I don't use the app store version, which is more limited than the Epson.com version, and I may not have done it since I upgraded to Mohave. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×