Jump to content
Sign in to follow this  
Davis

Huge CPU usage

Recommended Posts

I was just doing some basic UI design (moving vector and text layers around and resizing them) on Affinity Designer latest Mac AppStore release and heard that fans are going quite fast, so I opened Activity Monitor and saw that Affinity Designer was using like over 100% of CPU:

post-1285-0-05207500-1433845490_thumb.png

 

Not sure if this is bug or not, but I guess it's not normal to have this huge CPU usage during simple tasks.

 

P.S. I'm using Retina Macbook Pro 13" Mid-2014. Maybe it has something to do with the fact I have few rasterized pictures used in file, because I have seen that using Pixel tools in AD heats my Mac quite a bit, but at that moment when fans went wild I wasn't doing anything with those rasterized layers.

 

Thanks! :)

Share this post


Link to post
Share on other sites

Thanks for the file, I've been moving objects around and reordering layers. However so far I haven't had any high CPU usage, highest so far is around 20%. I'll continue to test and see if I can get the usage any higher.

Share this post


Link to post
Share on other sites

Just a few minutes ago, I noticed my MacBook Pro was getting really hot in my lap, and was quite surprised to see in Activity Monitor that Affinity Designer was at 100% CPU usage... in the background!  :o

 

The entire document was just two bitmap images that I had pasted in from the clipboard, one set to 50% opacity. Out of curiosity, I deleted them both, and Designer dropped its CPU usage back down. 

Share this post


Link to post
Share on other sites

same here. Very high CPU usage (over 700%, Fans starts blowing).

This occurs in normal RAW Conversion (ARW) when I change some settings (sharpness, lighting, etc.)

After completion the job, CPU goes back to normal conditions.

 

Is it possible to configure something to prevent this CPU usage?

 

Best regards

Horst

 

iMac 5K, 32GB, 512 SSD

Share this post


Link to post
Share on other sites

And me in AD. Thought my macbook, mid 2014 retina, was getting toasty, fan going and 400%+ cpu. Screen grabbed the activity monitor but it was "only" 284% by the time I did (and not much use anyway). Wonder if it's when the doc has a lot of blurs etc, even though I was zoomed in? No raster layers in mine.

Screenshot at Aug 24 21-44-17.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×