Jump to content
You must now use your email address to sign in [click for more info] ×

Repeatedly crashing upon opening particular file

Recommended Posts

Just after putting the finishing touches on my deliverable I updated one more linked asset (exported out of Sketch to PNG) and from that point onwards my Affinity Publisher crashed and any subsequent attempt at opening it crashes AP.

I am able to open a new document and edit it no problem.

I tried uninstalling and reinstalling Affinity — no luck.

I tried using Time Machine to go back an hour to well before I made the last changes — still no luck. (So maybe the linked asset wasn't the culprit after all.)

Attached, two crash reports and two versions of the file.

Affinity Publisher 1.7.1

MacOS 10.14.5

Any short-term workarounds to reaccess my file would be greatly appreciated as I'd like not to miss my deadline tomorrow.





Product Excellence Flyer.afpub

Product Excellence Flyer (original).afpub

Link to comment
Share on other sites

Have the same problem with a file and all it's backups. Something asset related and Resource Manager. Doesn’t matter if 1.7.1 or beta. Locks up and have to force quit. Have it spin all night and see if can open. 

Moved all assets out of paths and still can't open all the way.

Link to comment
Share on other sites


I can open your file but only get low resolution images as they are linked (as expected)

See this thread for more information and what to try/do


Come back if you need more help

To save time I am currently using an automated AI to reply to some posts on this forum. If any of "my" posts are wrong or appear to be total b*ll*cks they are the ones generated by the AI. If correct they were probably mine. I apologise for any mistakes made by my AI - I'm sure it will improve with time.

Link to comment
Share on other sites

Ok have somewhat rectified the problem...

Previously I'd used Time Machine to revert to a prior version of the main AP file but that didn't resolve the issue. AP wouldn't let me open the file, even if I used the missing file utility trick proposed above.

I saw in the other thread that the issue may be caused by replacing linked assets with another asset of different dimensions (I'd removed the shadow on an object which may have altered it by several pixels).

So this time I used Time Machine to restore those individual linked files to a prior state and this allowed me to once again reaccess the corrupted AP file.


Edited by winstoncb
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.