Jump to content
Jeroen

Live denoise shows strange artifacts, also with export

Recommended Posts

In attached project, the following shows artifacts appearing when applying a live denoise filter, even after resetting the filter:

792010949_denoisewithartifacts.thumb.jpg.09784e47352f30598139bdc8c268858b.jpg

With the denoise filter deactivated the artifacts disappear:

14980848_artifactswithoutdenoise.thumb.jpg.669987d4b647318582c10882884b26c9.jpg

Exporting to jpg of the project with the filter active also shows artifacts, although different ones:

1963914410_artifactswithdenoiseexported.thumb.jpg.eeda2ae2c7475c8aca3da92d37bea490.jpg

Exporting with the filter deactivated gives a clean picture.

The project can be closed and reopened, and the behaviour remains.

Jeroen.

IMG_2333_Golf.afphoto

Share this post


Link to post
Share on other sites

Hey Jeroen,

Unfortunately the file you attached is corrupt for me. Perhaps attaching such a big file to the forum caused this...

I cannot reproduce it on my own file which I have set up like yours in the screenshot.

Does disabling Metal compute fix it? (Preferences > Performance.)

You can try uploading the file again to this Dropbox folder if you'd like. 

Share this post


Link to post
Share on other sites
34 minutes ago, Chris B said:

Does disabling Metal compute fix it? (Preferences > Performance.)

You can try uploading the file again to this Dropbox folder if you'd like. 

Disabling Metal compute does indeed fix the issue.

I have uploaded the file to the link you sent me.

Share this post


Link to post
Share on other sites
7 minutes ago, Jeroen said:

Disabling Metal compute does indeed fix the issue.

 

Thanks for letting me know. There are a few instances where we have had to suggest disabling Metal compute for now. This does not mean that there is necessarily anything wrong, your system just works better without it. In the update to 1.7 I believe we switched it on by default.

Share this post


Link to post
Share on other sites
3 minutes ago, Chris B said:

Thanks for letting me know. There are a few instances where we have had to suggest disabling Metal compute for now. This does not mean that there is necessarily anything wrong, your system just works better without it. In the update to 1.7 I believe we switched it on by default.

Thanks for the encouragement. I now have a workaround.

Yet, I may misunderstand you here... but it seems to me there is definitely something wrong at the moment. I have a 2019 Mac with all software up to date. You are certainly not suggesting that Metal support is fine as it is, and thus needs no fixing? Then, why is it not working as expected?

Share this post


Link to post
Share on other sites

Hey Jeroen,

I meant nothing wrong with your system. Once we have the file from the Dropbox link I provided we can look into why the glitch is happening with this file. Turning off Metal compute in the meantime will be your workaround until we can figure out why this is happening.

Please provide a screenshot of your 'About this Mac' screen so we can get the specs.

Share this post


Link to post
Share on other sites
24 minutes ago, Chris B said:
3 minutes ago, Chris B said:

Hey Jeroen,

I meant nothing wrong with your system. Once we have the file from the Dropbox link I provided we can look into why the glitch is happening with this file. Turning off Metal compute in the meantime will be your workaround until we can figure out why this is happening.

Please provide a screenshot of your 'About this Mac' screen so we can get the specs.

Uploaded. Please let me know if I can be of further help.

Share this post


Link to post
Share on other sites
6 minutes ago, Chris B said:

Hey Jeroen,

I meant nothing wrong with your system. Once we have the file from the Dropbox link I provided we can look into why the glitch is happening with this file. Turning off Metal compute in the meantime will be your workaround until we can figure out why this is happening.

Please provide a screenshot of your 'About this Mac' screen so we can get the specs.

Uploaded. Please let me know if I can be of further help.

Share this post


Link to post
Share on other sites

Hi Jeroen

There are a few isolated pixels in your file that have red channel values of NaN (not a number). The live denoise filter is getting confused by these and producing black squares centred on the corrupt pixels. I'm guessing the image comes from a RAW file via the Develop persona. Do you remember what adjustments you applied in Develop?

Thanks

Justin

Share this post


Link to post
Share on other sites
4 hours ago, Justin said:

Hi Jeroen

There are a few isolated pixels in your file that have red channel values of NaN (not a number). The live denoise filter is getting confused by these and producing black squares centred on the corrupt pixels. I'm guessing the image comes from a RAW file via the Develop persona. Do you remember what adjustments you applied in Develop?

Thanks

Justin

Hi Justin,

Interesting.I can see that NaN values might certainly cause erratic behaviour. The question of course is where they come from.

You are correct in that I developed from a raw file, and I did it in AP. I do not keep records of develop adjustments. Normally I tend to keep development settings simple and leave most of the work to the Photo persona, but I do not remember exactly what I did here.

I can provide the raw file though, if that might be of use. It is a Canon .CR2 file. Let me know if you would like me to.

Best regards,

Jeroen.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.