Jump to content
Stokestack

Snapping randomly fails with some objects

Recommended Posts

Screen grab attached. The behavior appears to be nearly arbitrary. Sometimes an object won't snap to anything. Other times it'll snap to some and not others. In the attached screen grab, it won't snap into alignment with the top rectangle in the stack, but it'll snap to the others. Today I switched back to the same file with the same settings, and now it'll snap to the top two rectangles in the stack but not the bottom. Before that, it wouldn't snap to any; I had to click on one of the rectangles in the stack and then re-select the one I'm moving... then snapping worked to some objects.

I tried activating "snap to object geometry," but that made it worse.

snapSettings.thumb.png.9008b9c5a72a7e257a09e95c41844ed1.png

Share this post


Link to post
Share on other sites

Hi Stokestack,

It sounds as though they're not part of the snapping candidates. If your Candidates are set to 'Candidate list' it will only let you snap to the last 6 selected objects (can be changed by the Maximum value in the snapping dialog). If you enable 'Show snapping candidates' you can also see which objects it will snap to via a purple highlight around the object.

Alternatively changing your Candidates to 'All Layers' will allow you to snap to everything!

Share this post


Link to post
Share on other sites

Thanks! That's interesting functionality. I tried activating "show snapping candidates," and its usefulness is limited because the purple highlight exactly overlays the shapes; that's not really visible on black paths.

But I can see where candidate-selection is potentially useful for limiting snap-happy behavior, so thanks for pointing it out.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×