Jump to content
Wolf Wallis

Beta Build 1.7.2.420 Crashing Consistently

Recommended Posts

Had consistent crashes with Publisher 1.7.1 official release, so I downloaded and installed this 1.7.2.420 beta build release. Crashing still happens.

Crashing occurs when creating new paragraph style within Text Style panel. Purposely did not undock the panels, but left them in their locations; still crashes. Dropping in the system crash report, as well as the document (two graphics, two text frames with text, two text frames with page number fields). One note, this is the same document as was used in the official release. Certainly, the program is bugging out, but perhaps the document itself is the culprit?

Running MacOS X Mojave, 10.14.5, iMac (late 2013), 3.2 GHz intel core i5, 32 GB memory, Nvidia GEForce.

Affinity Publisher Beta_2019-07-06-114526_iMacUp.crash

Bios and Farewells.afpub


iMac (late 2013), 3.2 GHz Intel Core i5, 32GB Ram, Mac OS Mojave 10.14.5, Running Affinity Photo, Publisher. Running Adobe CS5.5 on external disk with Mavericks...when the bugs abate in Publisher, last line not needed.

Share this post


Link to post
Share on other sites

Hi @Wolf Wallis,

Do you do anything other than click "Create Paragraph Style" in the text styles panel, does the crash happen you actually create a style and click "OK"?

I've created a pretty basic text style in that document without issue.


Serif Europe Ltd. - www.serif.com

Share this post


Link to post
Share on other sites

Jon, thanks for posting. I was able to move around in the Paragraph Style Panel, selecting a few of the attributes in the left pane (font, spacing, etc.). After repeated crashing of the 1.7.1 release and seeing the checklist of fixes for the 1.7.2.420 customer beta, thought things would calm down. 

First thing I wanted to do to set up my document is to create the styles I want to work with (history: tons of old InDesign files were used to create three books. I'm beginning work on the fourth, hopefully being able to use Publisher.

Crashing appears indiscriminate in that clicking the tab title sometimes does it, more often when going into the attributes and selecting a preference, then clicking okay for that attribute change. Not able to proceed much further than that.

Crash report and affected document posted on 6 July were my latest attempts. Walked away to study the forums, maybe glean an error I'm doing wrong or anything to help understand the crashing problem. Will try any method or procedure necessary if anyone can guide me.

Thanks again for the help.


iMac (late 2013), 3.2 GHz Intel Core i5, 32GB Ram, Mac OS Mojave 10.14.5, Running Affinity Photo, Publisher. Running Adobe CS5.5 on external disk with Mavericks...when the bugs abate in Publisher, last line not needed.

Share this post


Link to post
Share on other sites

Trying to remain in the proper forum. Posted my latest crash using the beta build mistakenly on the official 1.7.1 Publisher Bugs forum.

At the risk of missing out on some help, am reposting my latest crash report here. It was using the beta build.

Re-describing the crash, successfully created a preset for a new document (Half Ltr, 140mm x 216mm), created five pages, then went to the master pages. Turned off 'Show Samples' in the Text Styles panel options, then created a new para style, modifying font, font size, as well as selected to show in both panels. Clicked okay and hooray, the new para style 'Folio' was created. About 3-5 seconds after clicking okay, the Publisher Beta crashed.

Mac OS X, Mojave, 10.14.5, iMac (Late 2013), 3.2GHz Intel core i5, 32GB memory, NVidia GE Force

Affinity Publisher Beta_2019-07-09-115225_iMacUp.crash


iMac (late 2013), 3.2 GHz Intel Core i5, 32GB Ram, Mac OS Mojave 10.14.5, Running Affinity Photo, Publisher. Running Adobe CS5.5 on external disk with Mavericks...when the bugs abate in Publisher, last line not needed.

Share this post


Link to post
Share on other sites

I believe a colleague is looking at this with you in another thread, so I'll leave the troubleshooting to that thread for now :)


Serif Europe Ltd. - www.serif.com

Share this post


Link to post
Share on other sites

Don't think anyone else is helping at this point. Pauls had replied to a few of the posts, but haven't heard from him. I've also exclusively gone to the 422 beta build and have another post in this forum.

Still experiencing crashes when creating a para style. Happens if I modify Body style as well as creating a new style. Purchased the 1.7.1 on release day and still really want to roll the sleeves up with Publisher. At this point, it's not running.

Very impressed with everyone and no complaints. Just issues with Publisher.

Any recommendations on what I should do? 


iMac (late 2013), 3.2 GHz Intel Core i5, 32GB Ram, Mac OS Mojave 10.14.5, Running Affinity Photo, Publisher. Running Adobe CS5.5 on external disk with Mavericks...when the bugs abate in Publisher, last line not needed.

Share this post


Link to post
Share on other sites

We've logged the crash reports you've sent. We can't reproduce it at the moment which makes it quite hard for us to troubleshoot and fix, but we are hoping the developers can attempt a fix based on the crash reports that we've seen.

Bit of a random question, do you have a tablet plugged in and with drivers installed?


Serif Europe Ltd. - www.serif.com

Share this post


Link to post
Share on other sites

Thanks. Agree what I'm facing is unique. As it's logged with the developers, we can hope a solution will reveal itself while working the more common issues showing.

No tablets plugged in, only a few external drives, an Elgato dock and an Apple Superdrive.

My thinking is there is definitely some element of my desktop setup that's creating the issues. Fonts have been aggressively cleaned up, OS is running sharply. There are still 32-bit apps running, yet I've had no other bumps, glitches or issues except with Publisher. Here's hoping other platforms are doing better and the desktop platform for Publisher will turn around.

Will continue following the forums and watching for breaking news.


iMac (late 2013), 3.2 GHz Intel Core i5, 32GB Ram, Mac OS Mojave 10.14.5, Running Affinity Photo, Publisher. Running Adobe CS5.5 on external disk with Mavericks...when the bugs abate in Publisher, last line not needed.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×