Jump to content
Patrick Connor

Report issues using Designer on iPadOS 13 Beta HERE

Recommended Posts

11 hours ago, SageBlue said:

An issue I’m having with the latest Designer 1.7.2 beta and latest iPadOS Public beta (5?), is opening documents from Designer’s welcome screen. When the Open window appears, the Recent tab works fine, the Browse tab is always blank. Been like this for over a day, including after reboots of iPadOS.

This seems to be a system-wide iPadOS issue. Same thing happens in Safari.


Affinity Designer, Affinity Photo (iPadOS 13 Public Beta, iPad Pro 12.9” - 3rd & 2nd Gen)

Share this post


Link to post
Share on other sites

Hi again team, 

Having an issue with a pixel layer. It was created from an unsaved Afdesign document, that was created by...

  • importing an image from Photos.
  • I selected some of the contents, and refined the selection to another layer.
  • Copied the layer to the document that’s attached here.
  • I cannot select the layer normally, that should allow resizing/repositioning, whether on the canvas or through the Transform studio. 

Pixel layer.afdesign


Affinity Designer, Affinity Photo (iPadOS 13 Public Beta, iPad Pro 12.9” - 3rd & 2nd Gen)

Share this post


Link to post
Share on other sites
On 8/11/2019 at 1:08 AM, Chris A said:

Okay so today I've got iOS 13 public beta 5 and the only problem I found with my Affinity Designer is that when I tap for "redo" (with 3 fingers), it says "nothing to undo" and the 3 tap gesture doesn't work.

 

On 8/11/2019 at 9:59 AM, SageBlue said:

I’ve also had issues With the Undo/Redo gestures in the current iPadOS public beta (version 5 from memory), with the latest Designer beta v1.7.2.

Thanks for letting us know. I've reproduced this and passed it on to development!

Share this post


Link to post
Share on other sites
13 hours ago, SageBlue said:

Hi team, 

Letting you know of a layer bug. File attached. I duplicated a layer of a rectangle that contains a gradient. When the original lower layer to ticked, the newer upper layer is heavily affected by the original lower layer when changing the new layer’s appearance.

Layer bug.afdesign

Would you be able to record a video showing the behaviour you're getting please? Everything seems to be working correctly. I did notice that your layer blend mode is set to Screen on that gradient layer so that will be working in conjunction with the layers below it.

Share this post


Link to post
Share on other sites
3 hours ago, SageBlue said:

Hi again team, 

Having an issue with a pixel layer. It was created from an unsaved Afdesign document, that was created by...

  • importing an image from Photos.
  • I selected some of the contents, and refined the selection to another layer.
  • Copied the layer to the document that’s attached here.
  • I cannot select the layer normally, that should allow resizing/repositioning, whether on the canvas or through the Transform studio. 

Pixel layer.afdesign

You appear to have a single pixel raster selection in your document. Go to the Pixel Persona and do a long press and select 'Deselect' - you should now be able to select your object.

Share this post


Link to post
Share on other sites
10 hours ago, Sean P said:

You appear to have a single pixel raster selection in your document. Go to the Pixel Persona and do a long press and select 'Deselect' - you should now be able to select your object.

Thanks Sean, that fixed it. In case it helps, this layer was fine and able to select it in the original afdesign document. I just copied the layer from the original document, and pasted into the document you have seen.

 

Going to work. I’ll get back to you on the gradient layer bug. 


Affinity Designer, Affinity Photo (iPadOS 13 Public Beta, iPad Pro 12.9” - 3rd & 2nd Gen)

Share this post


Link to post
Share on other sites
34 minutes ago, SageBlue said:

Hi Sean, 

Attached is the video of the gradient layer bug...

 

FullSizeRender.mov

Thanks for the video. That looks to be working correctly. The top layer has a Screen Adjustment which means the pixels will always be made brighter unless the below layer is completely black.

When there are no pixels to blend with (even if you have transparent background disabled), the blend mode will not have any values to calculate with and so treats it as though it was disabled.
 

 

Share this post


Link to post
Share on other sites

Thanks for the feedback Sean. I thought I checked the top layer’s blend and found Normal. Hope I wasn’t seriously tired. I’ll check again and sorry if I was


Affinity Designer, Affinity Photo (iPadOS 13 Public Beta, iPad Pro 12.9” - 3rd & 2nd Gen)

Share this post


Link to post
Share on other sites

Hi team,

Attached is a video showing some Gradient controls being tricky to move. The end/stop points are fine in moving. The controls in between are tricky, hardly moving...

 


Affinity Designer, Affinity Photo (iPadOS 13 Public Beta, iPad Pro 12.9” - 3rd & 2nd Gen)

Share this post


Link to post
Share on other sites
On 8/14/2019 at 7:27 PM, Sean P said:

Thanks for the video. That looks to be working correctly. The top layer has a Screen Adjustment which means the pixels will always be made brighter unless the below layer is completely black.

When there are no pixels to blend with (even if you have transparent background disabled), the blend mode will not have any values to calculate with and so treats it as though it was disabled.
 

 

Hey Sean. I must have checked the blend modes in a previous video, and thought I did it in the Gradient layer vid as well. Getting some rest this weekend :68_sleeping:


Affinity Designer, Affinity Photo (iPadOS 13 Public Beta, iPad Pro 12.9” - 3rd & 2nd Gen)

Share this post


Link to post
Share on other sites
Posted (edited)
On 8/11/2019 at 3:08 AM, Chris A said:

Okay so today I've got iOS 13 public beta 5 and the only problem I found with my Affinity Designer is that when I tap for "redo" (with 3 fingers), it says "nothing to undo" and the 3 tap gesture doesn't work.

Guys I have an update! Apparently in iOS 13 there are new gestures that can't be disabled atm. And these are Copy, Cut, Paste, Redo, Undo using the exact same gestures as in Affinity Designer and not only this program, every other program that supports these type of gestures are affected. Just saw this video, so Affinity Designer is fine, they just need to add a disable button in iOS 13!

 

Edited by Chris A

Share this post


Link to post
Share on other sites
3 hours ago, SageBlue said:

Hi team,

Attached is a video showing some Gradient controls being tricky to move. The end/stop points are fine in moving. The controls in between are tricky, hardly moving...

 

 

Gradient controls.mov

What device are you using to interact? If you pause briefly and then move it will display the colour picker instead of just selecting and moving the node/mid point. See if you is any better by not pausing. Alternatively try a tap and then drag see if that helps you any.

Certainly nothing feels different or out of the ordinary to me.

Share this post


Link to post
Share on other sites
On 8/16/2019 at 10:02 PM, Sean P said:

What device are you using to interact? If you pause briefly and then move it will display the colour picker instead of just selecting and moving the node/mid point. See if you is any better by not pausing. Alternatively try a tap and then drag see if that helps you any.

Certainly nothing feels different or out of the ordinary to me.

Thanks for the ideas Sean. Using 3rd Gen iPad Pro 12.9”. I find having to drag almost immediately when tapping on the midpoint, otherwise the colour picker comes up like you said. I remember it used to be easier to move the midpoint. Will see if I can find another way, like the tap and then drag.


Affinity Designer, Affinity Photo (iPadOS 13 Public Beta, iPad Pro 12.9” - 3rd & 2nd Gen)

Share this post


Link to post
Share on other sites
On 7/29/2019 at 4:55 PM, ErrkaPetti said:

Why can’t you use it as in current status?

It works like a charm since Apple allowed us change mouse pointer size (10 diff sizes)... 

Strange... When I tested this now it’s like you said, it don’t work in the canvas area...

But I have other drawing apps that works in latest beta 4 of iPadOS13...?

I’m not sure if this has an own thread, but, with latest iPadOS13 beta and the new retail versions of Affinity Photo/Designer the MOUSE SUPPORT seems to work (even drawing on document with the mouse...

But, a small bug/system iPadOS13 bug: You can’t point on a object and select it, you must click with mouse and make a small move with pointer for Designer/Photo to register an selection...

The same occur with Pen Tool... But, we are on our way to a full 100% mouse control of our graphical tools on our iPad! 

Share this post


Link to post
Share on other sites
On 8/17/2019 at 6:02 AM, SageBlue said:

Thanks for the ideas Sean. Using 3rd Gen iPad Pro 12.9”. I find having to drag almost immediately when tapping on the midpoint, otherwise the colour picker comes up like you said. I remember it used to be easier to move the midpoint. Will see if I can find another way, like the tap and then drag.

Hi Team, 

Good news. Letting you know the midpoint movement issue has worked every time for something I worked on in iPadOS Public Beta 7!


Affinity Designer, Affinity Photo (iPadOS 13 Public Beta, iPad Pro 12.9” - 3rd & 2nd Gen)

Share this post


Link to post
Share on other sites
21 hours ago, Chris A said:

Does the 3 tap fingers gesture for "REDO" is still working for someone ?

Not me...

Share this post


Link to post
Share on other sites
On 8/24/2019 at 2:05 AM, Chris A said:

Does the 3 tap fingers gesture for "REDO" is still working for someone ?

Not working for me either.


Affinity Designer, Affinity Photo (iPadOS 13 Public Beta, iPad Pro 12.9” - 3rd & 2nd Gen)

Share this post


Link to post
Share on other sites

I just fired up Designer 1.7.2.6 on my 12.9” iPad Pro 2018, public beta 7 (13.0 (17A5572a)). I’m experiencing a showstopper problem with changing tool settings. Any settings “bubble” as you see for the polygon tool in the attachment, cannot be changed from the default values. 
 

If you drag on the bubble, the numbers will change (albeit not smoothly) but when you stop dragging, nothing sticks. If you tap the bubble to use numeric entry, that change doesn’t stick either. 
 

All I wanted was a hexagon. :)

518C07F5-5829-40EB-81A4-1955A903142D.jpeg

Share this post


Link to post
Share on other sites
13 hours ago, Horseflesh said:

I just fired up Designer 1.7.2.6 on my 12.9” iPad Pro 2018, public beta 7 (13.0 (17A5572a)). I’m experiencing a showstopper problem with changing tool settings. Any settings “bubble” as you see for the polygon tool in the attachment, cannot be changed from the default values. 
 

If you drag on the bubble, the numbers will change (albeit not smoothly) but when you stop dragging, nothing sticks. If you tap the bubble to use numeric entry, that change doesn’t stick either. 
 

All I wanted was a hexagon. :)

518C07F5-5829-40EB-81A4-1955A903142D.jpeg

confirmed! Doesnt work on my iPad Pro 12.9" gen2 either...

Share this post


Link to post
Share on other sites
On 8/25/2019 at 3:58 PM, Horseflesh said:

Glad it isn't just me!

I looked at this issue some more and it isn't fair to say any settings bubble, but it is a lot of them. 

Would you be able to grab a screen recording (with Show Touches) enabled that demonstrates this issue please? I've tried it myself on both a 2018 11! iPad Pro nad a 12.9" older iPad Pro both running the same build of iPadOS 13 and cannot reproduce it.

I presume you had an object selected when attempting to change the sides of it? Or was you trying to do it prior to drawing/selecting a shape?

Share this post


Link to post
Share on other sites
11 hours ago, Horseflesh said:

My report was when trying to configure the settings before drawing a shape. 

I'll see if I can grab a video and post it later today. 

Confirmed!

Me too tried to change the polygon settings before drawing, not afterwards... 

So, it’s not a bug, it’s by design that you draw first, then change amount of sides etc etc... 

Now we know! Thanks @Sean P 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×