Jump to content

Recommended Posts

Sorry to report, but I, too, am having crashes occurring with Affinity Publisher 1.7.1. Love the program, going through tutorials and preparing my Publisher palette for future work. 
As another user experiencing these crashes noted, working in Text Styles appears to be the culprit. Selecting the tab in Text Styles panel, selecting OK when creating a new Text Style or even random crashes. The crash happens quickly so sometimes I'm not even sure what I was selecting when it happened, although using Text Style panel is a consistent culprit.

Am running Publisher 1.7.1, downloaded from the store on the initial release day (no beta was installed).
Am running Mac OS Mojave, 10.14.5, iMac, late 2013, 32gb ram, 3.2Ghz Intel Core 5

The document is essentially a blank slate, a few items on the master, document set up for Half Letter size w/spreads. Will attach the document, as well as a PDF of the bug report the system created. Perhaps a fresh install, as described by the other user will remedy the problem. If not, please investigate Support Team, we're counting on you!!

As a sidebar, I am excited and proud to be using Publisher. I have produced three books for print for an old friend using Adobe InDesign; however, I am determined to produce the fourth book using Publisher. Learning curve mainly relates to learning the differences from InDesign, but it is a welcome challenge.

Bios and Farewells.afpub

Affinity Publisher Crash Report.pdf


iMac (late 2013), 3.2 GHz Intel Core i5, 32GB Ram, Mac OS Mojave 10.14.5, Running Affinity Photo, Publisher. Running Adobe CS5.5 on external disk with Mavericks...when the bugs abate in Publisher, last line not needed.

Share this post


Link to post
Share on other sites

Houston, we have a problem. First, went back to original document and the page numbering I inserted on the master pages has disappeared. Fearing a continuance of problems, went ahead and uninstalled Publisher, emptied trash and performed a reinstall from the Affinity site. Installation went smooth. Created a new document and went to master pages to begin setup. Without selecting or creating a text box, I went to Text Styles and first created a new Group (called Book). For the new group, selected font, size, leading, first line indent and other particulars. Guess what? It let me do this. I then went to create a new Paragraph Style, based that on Book. It didn't populate with the particulars I had set for Book, but I selected the same particulars (font, size, etc.). When I was satisfied, I hit Okay and Publisher crashed. Didn't get too far. End result so far is that I've performed two installations of Affinity Publisher and both have crashed repeatedly. My gut tells me I may be doing something wrong, but with other users experiencing unexpected crashes, perhaps a helping hand is needed.

Since this was after a fresh install, I'm stumped. Going to need some help to figure this one out.


iMac (late 2013), 3.2 GHz Intel Core i5, 32GB Ram, Mac OS Mojave 10.14.5, Running Affinity Photo, Publisher. Running Adobe CS5.5 on external disk with Mavericks...when the bugs abate in Publisher, last line not needed.

Share this post


Link to post
Share on other sites

Maybe a full reset will work,the re-installation may have some leftovers that aren't cleared.
So try ctrl+selecting the program icon and hold the ctrl button until a menu appears>select all>clear>restart the computer
Hope this fixes things


-------------------------------------------------------------------------------------------------------------------------------
Win10(1903)Home / Photo / Designer / Publisher & latest (beta) versions

Share this post


Link to post
Share on other sites

haakoo, thanks so much. the other fella having Text Style crashing actually mentioned the full reset...I forgot to do that until you mentioned it. Appreciate your comment. Immediately, I went back and did a full reset.

Uh oh, didn't work. Opened Paragraph Style, undocked the panel, and began to create a new paragraph style. Then, I realized I wanted to make an actual Text Style Group to organize the multiple styles for this document. Never got there. Went to close Paragraph Styles and, you guessed it, Publisher crashes. Never got to save the new document I created. Still stumped. Is it undocking the panels? Memory tells me Publisher crashed without me undocking panels. Creating a new style? Don't know. Still relates to the style panels, but even the crashing is erratic.

Maybe working the bugs on the fourth of July is a mistake.


iMac (late 2013), 3.2 GHz Intel Core i5, 32GB Ram, Mac OS Mojave 10.14.5, Running Affinity Photo, Publisher. Running Adobe CS5.5 on external disk with Mavericks...when the bugs abate in Publisher, last line not needed.

Share this post


Link to post
Share on other sites

The issue may well be the undocking,it was a bug during the beta cycle.

Maybe post a bug report and a dev can help you out.


-------------------------------------------------------------------------------------------------------------------------------
Win10(1903)Home / Photo / Designer / Publisher & latest (beta) versions

Share this post


Link to post
Share on other sites

I'm also having crashes for the first time, and when I say 'having' it's crashing every time I open my main file. It started gradually so i made a copy but both are crashing as soon as opened. Older (much older) files work. Thought it could be a dodgy picture causing it, but have downloaded publisher on a small notebook and the file works fine on that. Copying even bits, never mind the whole thing, onto a dongle and importing it onto the main computer still causes Affinity to crash when I open. Very worrying!

I deleted and redownloaded Affinity but the problem persists, so it should be something to do with the actual computer not the program itself, seeing the file opens on another. New computer then, pronto, unless there's an answer out there.
Update: Sounds mad but it crashes every time I click page 4 on any document! Always page 4 even if it's completely blank.
Update 2: Tried clearing everything with the ctrl click, still crashed, bought another computer.

Share this post


Link to post
Share on other sites

Okay, as haakoo and Old Bruce have so patiently and intelligently noted to do, I am inserting my latest crash report. Yes, I do have more than one of them. This most recent is following a fresh install of the program, plus complete program reset. As haakoo notes, the bug may well be undocking maneuvers. Could well be any number of things related to the Style panels.

Documents I've worked on are blank for all intent and purpose, latest crash occurred before I could even save the document.

Apologize, but was not involved in the beta cycle, so all behavior is new to me.

Running latest version of Publisher, 1.7.1

Running macOS Mohave, 10.14.5

iMac (27-inch, late 2013), 3.2 GHz Intel Core i5, 32 GB 1600 MHz DDR3, NVIDIA GeForce GT 755M 1 GB

Here is the latest crash report. As an added incentive to the support team and to the developers, Please Help!

Affinity Publisher_2019-07-03-185927_iMacUp.crash


iMac (late 2013), 3.2 GHz Intel Core i5, 32GB Ram, Mac OS Mojave 10.14.5, Running Affinity Photo, Publisher. Running Adobe CS5.5 on external disk with Mavericks...when the bugs abate in Publisher, last line not needed.

Share this post


Link to post
Share on other sites

I cant recreate what you are seeing. There is a bug with the show samples option in the text styles panel. You could try turning that off via the option in the menu located in the upper right of the text styles panel.


Living the Dream since 1964 - about 25 years left

Share this post


Link to post
Share on other sites

Will do! I'll post back hopefully with good news. If not, will try to be detailed as best I can. Thanks Pauls.


iMac (late 2013), 3.2 GHz Intel Core i5, 32GB Ram, Mac OS Mojave 10.14.5, Running Affinity Photo, Publisher. Running Adobe CS5.5 on external disk with Mavericks...when the bugs abate in Publisher, last line not needed.

Share this post


Link to post
Share on other sites

Oops. No go.
Used the beta build for the following and created a new document. First things first, created a new document preset called Half Letter (140mm x 216mm) successfully. 

Attaching the crash report. Turned off Show Samples prior to creating anything. Went to Master Pages. Created a new Paragraph Style (selected new para style icon at bottom of Text Style Panel). Created a style called Folio, modified font, font size, selected for style to appear in both panels. Clicked okay and Publisher still up and running! Started to place a text box on the master page and whoosh! it crashed. Wasn't able to save the document, but here is the crash report.

Affinity Publisher Beta_2019-07-09-115225_iMacUp.crash


iMac (late 2013), 3.2 GHz Intel Core i5, 32GB Ram, Mac OS Mojave 10.14.5, Running Affinity Photo, Publisher. Running Adobe CS5.5 on external disk with Mavericks...when the bugs abate in Publisher, last line not needed.

Share this post


Link to post
Share on other sites

Quick note on the crashing mentioned in this thread. Tried something different. Same result, but it may have bearing. Instead of using the panels at the right to access Paragraph Styles, instead, selected the frame text tool and accessed the context menu bar. From there, selected paragraph style and selected new. It let me create the para style when I clicked OK. Three seconds later, whoosh, Publisher went bye bye.

At least for me, the problem isn't accessing and using the main panels, like the Para/Text Styles Panels at the right. It's within the Create New/Edit Paragraph Style and when I've arrived at the end of creating that new style. 

Hope this helps.

Affinity Publisher_2019-07-09-233154_iMacUp.crash


iMac (late 2013), 3.2 GHz Intel Core i5, 32GB Ram, Mac OS Mojave 10.14.5, Running Affinity Photo, Publisher. Running Adobe CS5.5 on external disk with Mavericks...when the bugs abate in Publisher, last line not needed.

Share this post


Link to post
Share on other sites

Anything out of the ordinary with your display or other 3rd party graphics/UI utilities ?

 

also if you could do a quick video of the getting crash that might help us spot something


Living the Dream since 1964 - about 25 years left

Share this post


Link to post
Share on other sites

No odd setups, 3rd party graphics. Only additional utility running is Dr. Cleaner Pro with no negative effects. Will try to post a video here later in the day. 


iMac (late 2013), 3.2 GHz Intel Core i5, 32GB Ram, Mac OS Mojave 10.14.5, Running Affinity Photo, Publisher. Running Adobe CS5.5 on external disk with Mavericks...when the bugs abate in Publisher, last line not needed.

Share this post


Link to post
Share on other sites

Okay, not sure if this reveals much, but below is a quick video.

If there is another operation that might help better, let me know and I'll see what I can recreate.


iMac (late 2013), 3.2 GHz Intel Core i5, 32GB Ram, Mac OS Mojave 10.14.5, Running Affinity Photo, Publisher. Running Adobe CS5.5 on external disk with Mavericks...when the bugs abate in Publisher, last line not needed.

Share this post


Link to post
Share on other sites

Cleared the font cache successfully. Repaired permissions and restarted. Created new document and Publisher did the same crash.

Affinity Publisher_2019-07-10-123632_iMacUp.crash


iMac (late 2013), 3.2 GHz Intel Core i5, 32GB Ram, Mac OS Mojave 10.14.5, Running Affinity Photo, Publisher. Running Adobe CS5.5 on external disk with Mavericks...when the bugs abate in Publisher, last line not needed.

Share this post


Link to post
Share on other sites

Thanks for the advice on fonts. Cleared the cache and checked for dupes and conflicts. Since I have both the 1.7.1.408 and .420 beta, not sure where to post, but, this video recording was using the beta, which is the version I should likely stick to for now. 

Video is interesting in that no actions were taken, no selections changed. Just viewed the Base font attributes.


iMac (late 2013), 3.2 GHz Intel Core i5, 32GB Ram, Mac OS Mojave 10.14.5, Running Affinity Photo, Publisher. Running Adobe CS5.5 on external disk with Mavericks...when the bugs abate in Publisher, last line not needed.

Share this post


Link to post
Share on other sites

I've logged the issue with the developers to see if they have any insight on the crash. The only other thing I can suggest is trying the app with no other applications running and or running a system memory test as well. Your experience is not typical I must add and I'm sorry you're having such problems.


Living the Dream since 1964 - about 25 years left

Share this post


Link to post
Share on other sites

Thanks for the help and words of encouragement. I'll keep exploring system, font, display or other conflicts on my end. No, have not read of the behavior I'm having with others...quite atypical. Hopefully, something will reveal itself, either on my side or the developers. :231_wolf:


iMac (late 2013), 3.2 GHz Intel Core i5, 32GB Ram, Mac OS Mojave 10.14.5, Running Affinity Photo, Publisher. Running Adobe CS5.5 on external disk with Mavericks...when the bugs abate in Publisher, last line not needed.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×