Jump to content
You must now use your email address to sign in [click for more info] ×

Unable to open or save network drive files

Recommended Posts

  • 1 month later...
  • Staff

Hi ErrolvB,

Thanks for getting in contact with us and I also apologise for the delay in responding.

The Errno 13 means that permission is being denied on the network drive. I presume you're able to navigate and save there without problems in Finder and other applications?

Are you able to give us some more information on your network and share setup please?

  1. What kind of hardware is the shared drive, is it a NAS drive or something else?
  2. What is the share type? Is it SMB, AFP, NFS or something else? 
  3. What is your OS and version
  4. If possible have you tried rebooting the device or server (if possible) the shared drive is stored on, as it looks like the server has retained a lock and it is stuck.
  5. Can you save to a new path locally or on the same share? Does this happen when trying to save a new file?
  6. Any more information of both your and your network setup that could be helpful?

Thanks again your patience.

Link to comment
Share on other sites

  • 1 month later...

1. Yes NAS Drives (Netgear) that are accessible through finder etc.

2. SMB

3. macOS Mojave 10.14.6

4. Yes tried complete shut down and start again

5. Yes I can save to new path on the Mac but not on 

6. I can 'see' the files and folders on the network drives in the open/save/save as/ export commands

7. A zero byte file is created then this message comes up. If I export to my Mac a file is created with no problem.


Edited by ErrolvB
additional info
Link to comment
Share on other sites


I have a similar experience with a Netgear ReadyNas 102 device using CIFS/Samba shares.

I cannot open Affinity documents, or  drag and drop a JPG / BMP /TIFF files from this NAS. But! I can open PSD files...

No problem when using AFP shares, or on a Windows 7 share.

Affinity Designer, Photo or Publisher : same behaviour.


Link to comment
Share on other sites

  • 4 weeks later...
  • 6 months later...

Just an update (this problem is still present with Affinity 1.8.3 series), I set up a Raspberry Pi running Raspbian with a Samba share. I can open/save my Affinity documents on this share.

But still unable on the Netgear... Something to inquire there.

Edited by pakunoda
This thread started for the 'pre 1.8' Affiinity release, I precise the problem shows also with 1.8.3
Link to comment
Share on other sites

  • 5 months later...

I'm having the same problem on my Mac. And it is indeed Netgear NAS-specific. I can save documents with Affinity programs to smb shares on other devices. But it is also specific to Affinity programs because I can create, save, and open documents using other Mac software. This kills the workflow when I need to make local copies every time I edit a document. It would be great to understand what's causing it and possibly fix it.

Link to comment
Share on other sites

  • 4 months later...

I have the same problem. I use TrueNAS-12.0-U2.1 I double checked the permissions, and I have all permission activated. Strange is that I have this problem only with affinity software, I tried to open files and save them with other software and there it goes without any problem.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.