Jump to content
henryb

Affinity Photo has stopped saving directly back into Mac OS Photos!!

Recommended Posts

Hi SteveB523,
Thanks for your feedback. Just to clarify, the issues being discussed on this thread are related to sending files from Apple Photos to Affinity Photo and back (roundtrip) through the following ways::

1. Edit With - select an image/thumbnail in Apple Photos, right-click on it and select Edit With > Affinity Photo, or go to menu Image > Edit With > Affinity Photo).

2. Edit in Affinity Photo (the extension) - when seeing a single image in Apple Photos, click the Edit button on the top right of the interface, then the ellipsis icon again on the top right of the interface and select Edit in Affinity Photo.

These are the workflows that are giving trouble which the new Customer Beta should fix.

Thank you for lettings us know about the Share command issue. I will check it now as well.

Share this post


Link to post
Share on other sites
1 hour ago, Andy Duffy said:

Hi Mark

I have both in the top level applications folder and as you can see from the screenshot you can see both applications and the product key request.image.thumb.png.b8d8589acc01847e02228e8f1acbc829.png

Any ideas?

Andy

To be honest I’m not sure why the beta is not launching for you?
One thing I am wondering about though from your screenshot, is the AP splash screen immediately behind the registration window. It says 1.7.2.146. The latest beta version however is 1.8.0.163.
Maybe you could confirm which retail version you have installed, the latest is 1.7.3, and which beta version you are trying to launch.

Share this post


Link to post
Share on other sites
1 hour ago, MEB said:

Hi SteveB523,
Thanks for your feedback. Just to clarify, the issues being discussed on this thread are related to sending files from Apple Photos to Affinity Photo and back (roundtrip) through the following ways::

1. Edit With - select an image/thumbnail in Apple Photos, right-click on it and select Edit With > Affinity Photo, or go to menu Image > Edit With > Affinity Photo).

2. Edit in Affinity Photo (the extension) - when seeing a single image in Apple Photos, click the Edit button on the top right of the interface, then the ellipsis icon again on the top right of the interface and select Edit in Affinity Photo.

These are the workflows that are giving trouble which the new Customer Beta should fix.

Thank you for lettings us know about the Share command issue. I will check it now as well.

I understand better now, I think.  I was partially mislead by the title of the topic ("Affinity Photo has stopped saving directly back into Mac OS Photos!!"), which made it look like Affinity Photo on the Mac couldn't save edited photos to Apple Photos at all, which, of course isn't true at all - the Share menu worked fine.

Edit With

I tested the Edit With function with the new Beta version.  I closed the 1.7.3 version of Affinity, selected a thumbnail in Apple Photos, and clicked "Edit With" and then Affinity Photo Beta.

On the first try, the beta never opened, and the crash window popped up.

I got rid of that and tried again.  This time, the Beta started fine and opened the photo I selected.

I then tried to use File/Place to open a second picture from Media/Photos. The open dialog box opened, and initially it listed both Photos and PhotoBooth at the top and started grinding away on finding the photos - but then it finished, the Photos item at the top disappeared, leaving only PhotoBooth, and no pictures ever showed up - I waited at least 30 seconds, way longer than it usually takes.

I cancelled the open dialog box and tried File/Place again - and exactly the same thing happened. No pictures ever showed up. This appears to be a bug in the Beta.

Giving up on the Place command, I just applied an obnoxious HSL adjustment and tried File/Save. Affinity flattened the file and appeared to replace the original in Apple Photos. However, it was possible to revert back to the original in Apple Photos.

Extension

a. Simple HSL adjustment without flattening

I then tried the extension with Affinity Photo, and got the error message as expected.

I tried the extension with the Beta. The Place command fromMedia/Photos didn't work here, either.

I applied an HSL adjustment, clicked File/Save (didn't get a message about flattening), and then Quit the Beta.

The modified photo showed up in Apple Photos, which was still in the Affinity Edit mode. At the bottom of the Apple Photos screen, it said "Editing Complete - press Save to Keep these changes".  When I clicked "Save Changes", I got an Error Dialog Box that said "Unable to edit with "Edit in Affinity Photo". An unexpected error has occurred". (see image attached). When I clicked "done", I was back in Apple Photos with an unmodified photo.

b. new image placed plus HSL adjustment

But here's where it gets weird. I tried the extension for a second time.

But this time, I tried the File/Place command with an image from iCloud, and that worked fine. That tells me that not being able to Place photos from Apple Photos really is a bug.

I also applied an HSL adjustment, clicked File/Save (no flattening message in Affinity), and Clicked Quit.

This time, because I also placed a new picture in the original, there was a different message at the bottom of the Apple Photos screen: "Editing Complete (16 MB change limit exceeded - Document will be flattened) - press Save to Keep these changes". When I clicked "Save Changes"; the changed document appeared in Edit mode screen. When I clicked "Done"; the photo with my changes appeared in photos as expected.

It could be that the image has to be flattened before saving, so I repeated the first extension experiment:

c. Simple HSL adjustment but flattened before saving

Select the same photo as in (a) above in Apple Photos by double clicking it

Click Edit.

Click the "..." button.

Click "edit with Affinity Photo" (the beta version)

Applied HSL adjustment (no Place command)

Clicked Document/Flatten to reduce file to one layer.

Clicked Save, then Quit the Beta.

 Even though I already flattened the file, I got the "Editing Complete (16 MB change limit exceeded - Document will be flattened) - press Save to Keep these changes" message. When I clicked "Save Changes"; the changed document appeared in Edit mode screen. When I clicked "Done"; the photo with my changes appeared in photos as expected.

So, in summary:

Edit With appears to work in the new Beta.

the Edit Extension Appears to work in the new Beta IF you flatten the image first

The File/Place command from Apple Photos does not work with either method.

 

 

4F44F728-31AA-4F90-849E-BFE9AB81B65D.jpeg

Share this post


Link to post
Share on other sites
2 hours ago, markw said:

To be honest I’m not sure why the beta is not launching for you?
One thing I am wondering about though from your screenshot, is the AP splash screen immediately behind the registration window. It says 1.7.2.146. The latest beta version however is 1.8.0.163.
Maybe you could confirm which retail version you have installed, the latest is 1.7.3, and which beta version you are trying to launch.

Hi Mark

Good spot, somehow I didn't notice I downloaded 1.7!

Does anyone know where I can download 1.8?

Andy

Share this post


Link to post
Share on other sites
1 hour ago, Andy Duffy said:

Hi Mark

Good spot, somehow I didn't notice I downloaded 1.7!

Does anyone know where I can download 1.8?

Andy

The 1.8.0.523 can be found on this announcement page.

 

 

Share this post


Link to post
Share on other sites
On 1/10/2020 at 2:23 AM, markw said:

If you have not already found it the latest Photo beta can be found here: https://forum.affinity.serif.com/index.php?/topic/104964-affinity-photo-customer-beta-180163/

so does this beta work fine (and will save edits back into Photos)? If yes, then should we download this and REPLACE our current AP app? Or should we wait for the official release (whenever that will be)?

Share this post


Link to post
Share on other sites
3 minutes ago, henryb said:

so does this beta work fine (and will save edits back into Photos)? If yes, then should we download this and REPLACE our current AP app? Or should we wait for the official release (whenever that will be)?

To try is your choice; however, as beta it doesn’t replace your AP.  If it works for you, great.

Share this post


Link to post
Share on other sites
1 minute ago, Cecil said:

To try is your choice; however, as beta it doesn’t replace your AP.  If it works for you, great.

what does "it doesn't replace your ap" mean? If I download it, it's a full AP app, isn't it? So I can then trash my current AP (since the beta is a full-app), and work on the beta henceforth (hence, replacing my current ap..). No?

Share this post


Link to post
Share on other sites
6 minutes ago, henryb said:

so does this beta work fine (and will save edits back into Photos)? If yes, then should we download this and REPLACE our current AP app? Or should we wait for the official release (whenever that will be)?

You know, reading is a great skill to have!

 

On 1/9/2020 at 2:27 PM, SteveB523 said:

So, in summary:

 

Edit With appears to work in the new Beta.

the Edit Extension Appears to work in the new Beta IF you flatten the image first

The File/Place command from Apple Photos does not work with either method.

 

Also, the normal beta considerations apply.

Share this post


Link to post
Share on other sites
5 minutes ago, henryb said:

what does "it doesn't replace your ap" mean? If I download it, it's a full AP app, isn't it? So I can then trash my current AP (since the beta is a full-app), and work on the beta henceforth (hence, replacing my current ap..). No?

Absolutely not a full app, tested, tried and released as a replacement of the official AP release.  Beta’s are released to test potential fixes or add features to AP.  Serif will release 1.8 to replace 1.7.3, after all the bugs are fixed.  My suggestion, hang tight on downloading beta version.  Bugs will be fixed and you will have time to download revisions, not replacement of AP.

Share this post


Link to post
Share on other sites
9 minutes ago, henryb said:

this really wasn't necessary :(

@henryb don’t be discourage, keep posting if you have questions,  most will respond will helpful information. 

Share this post


Link to post
Share on other sites
35 minutes ago, henryb said:

what does "it doesn't replace your ap" mean? If I download it, it's a full AP app, isn't it? So I can then trash my current AP (since the beta is a full-app), and work on the beta henceforth (hence, replacing my current ap..). No?

NO.

Do not trash the retail version, the beta won't run without it.

Share this post


Link to post
Share on other sites
31 minutes ago, Old Bruce said:

NO.

Do not trash the retail version, the beta won't run without it.

Thank you! (That was the answer I was looking for!) :) So the idea is to install the beta but launch the regular ap? 

Share this post


Link to post
Share on other sites
21 minutes ago, henryb said:

Thank you! (That was the answer I was looking for!) :) So the idea is to install the beta but launch the regular ap? 

The betas are complete apps in themselves and are totally self contained. So any unresolved or new bugs in the betas can not interfere with the retail versions of the same apps.
But for the beta versions to run,  each time one is launched it will first check to make sure a corresponding retail version of it is installed on your system.
If no such retail version is found then the beta will not launch.

Share this post


Link to post
Share on other sites

I managed to find and install the beta (thanks Markw for posting the link). So far my testing has been unsuccessful. I still cannot save an edited file back in to photos :(

 

1-8beta error.jpg

Share this post


Link to post
Share on other sites
7 minutes ago, Andy Duffy said:

I managed to find and install the beta (thanks Markw for posting the link). So far my testing has been unsuccessful. I still cannot save an edited file back in to photos :(

 

1-8beta error.jpg

!!!!!! UPDATE.!!!!!!

I just thought I should reboot and try again and it works!!!

Just for info, before I rebooted, I set photos to NOT use the retail version of the extensions (leaving only the beta ones) and tested again which did fail. So am not sure if it was just the reboot or the change to extensions and the reboot that fixed it.

 

Share this post


Link to post
Share on other sites
24 minutes ago, Dizzypole said:

Andy, have you removed and re added the extensions in Photos?

Dizzpole

It looks like removing the old extensions and rebooting fixed it for me.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.