Jump to content
Jansson

Issue with Studio Link in Publisher (and Designer upgrade)

Recommended Posts

Hi there

When trying to use the Studio Link feature in Publisher (not beta), a dialogue box opens and tells me I need to purchase Designer and Photo first (se attached image). The problem however is that I already have both apps installed on my computer (not trial versions).

I figured I may need to upgrade the apps to be able to use the Studio Link feature, but when checking my user account on the Affinity website, the Designer and Photo app (and other purchases I've made) aren't registered.

This brings me to my questions:

  • What do I need to do to be able to use the Studio Link feature – do I need the latest upgrades of Designer and Photo?
  • Where do I go to upgrade the apps? (to many of you this is probably a "duh"-question, but I'm not very savvy when it comes to these things)
  • How can I register purchases/downloads that I made before creating an Affinity account?

 

There is probably a simple solution to all this. Help is appreciated though.

 

Cheers from Sweden /Jansson

 

 

Studio Link dialogue box.png

Share this post


Link to post
Share on other sites

Finally I figured it out so I try to help. I think that this might have something to do with previous versions. I had the same info. 

Uninstall everything.

If You did not try find Release.appinfo files. You have Mac so I don't know where they might be (\%ProgramData%\Affinity\Common\1.0\appinfo\Release). Delete them.

Second thing I did was getting rid of Affinity files from AppData/Roaming. 

It worked for me

Good luck

 

Share this post


Link to post
Share on other sites

I experienced this also. What you have to do is start Publisher then open Affinity Photo and Designer and then close them.  This allows the StudioLink to register these applications then close publisher and restart it.  You should NOW have access within Publisher to all three areas.

Share this post


Link to post
Share on other sites
52 minutes ago, Terry44 said:

I experienced this also. What you have to do is start Publisher then open Affinity Photo and Designer and then close them.  This allows the StudioLink to register these applications then close publisher and restart it.  You should NOW have access within Publisher to all three areas.

It didn't work out in my case. 

Share this post


Link to post
Share on other sites

Thanks for your input BlendBloke and Terry44!

I finally got my brain working and managed to upgrade Designer and Photo. I fired both apps up before moving on to Publisher – works like magic!

In other words I didn't have to go through the trouble of uninstalling anything to make things work.

Cheers!

Share this post


Link to post
Share on other sites

Yes, there is mention in the forum's that you have to upgrade to the newest 1.7.1 for this to work. Apparently if you have an older version of any of the applications this method will not work.

I did not know that at the time of my post above.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×