Jump to content
Arceom

Affinity Designer bad performance observations

Recommended Posts

Hello,

I just bought Affinity Designer and Photo because I remember trying them before and really liking them. To my surprise Affinity Designer's performance is no way as good as I remember it (I tried ~v1.5). Toying with the app, I found the following:

1.- The selection tool is smooth and responsive as long as I have no previous selection active, if I do, it is very laggy.
2.- Vectors have very bad performance compared to pixels (both in Designer and Pixel personas).
3.- Pixel persona have a little better response than Designer persona (both for vectors and pixels).

Now the interesting part...
4.- If I put each vector inside a group, the performance gets much much better.

I'll attach a video in case someone wants to see if this behaviour happens to them aswell.



Specs:
OS: Windows 8.1
CPU: i76700k @4ghz
GPU: GTX 1080 Ti
Ram: 16gb
HD: Solid State

Share this post


Link to post
Share on other sites

I have the same problem when moving different objects.

The problem does not occur with Affinity Photo and Affinity Publisher.

Retina-Rendering: Automatic

Share this post


Link to post
Share on other sites
22 minutes ago, 7Box said:

I have the same problem when moving different objects.

The problem does not occur with Affinity Photo and Affinity Publisher.

Retina-Rendering: Automatic

Do the shapes move smoother if you put them inside groups? it is the case for me, moving them inside groups disables the blue outline of the shapes (which I believe has something to do with the bug). Also, try opening a sample file (Help>Welcome...>View Samples), those move super smooth and are much more complicated than my files.

Share this post


Link to post
Share on other sites
21 hours ago, Arceom said:

Do the shapes move smoother if you put them inside groups? it is the case for me, moving them inside groups disables the blue outline of the shapes (which I believe has something to do with the bug). Also, try opening a sample file (Help>Welcome...>View Samples), those move super smooth and are much more complicated than my files.

Yes, they do. The problem only occurred with the current version.

Affinity Publisher (Designer Persona) does not have the problem.

Share this post


Link to post
Share on other sites

Hi Arceom,

Does this problem go away if you hide the Appearance Panel at all? There is a known issue that performance can be slower with this visible (which has now been fixed by development).

Share this post


Link to post
Share on other sites
49 minutes ago, Arceom said:

Yes, the performance is much better if the appearance panel is not visible.

Ahhh that's 'good' to know. This has been fixed in the latest Windows beta, which if you want to try can be found here:

 

Share this post


Link to post
Share on other sites
26 minutes ago, Arceom said:

Can beta and retail be installed at the same time without causing problems?

They can indeed! They install to separate locations, and can be run up at the same time. They also use a separate set of preferences and stored data - so any brushes or assets in the retail will not appear in the beta and vice-versa.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×