Jump to content
Daniel Gibert

Editing styles based on other ones gives blank fields

Recommended Posts

Not sure if this is a bug or if it should be a suggestion for improvement.

I created a new paragraph style based on one already existing. In this case a Bullet paragraph. I want to edit it, but all fields in the edit panel are blank/default with no indication of the current paragraph settings. On the paragraph studio panel the correct settings are shown. 

The error doesn't prevent you to work (You still can make adjustments on the paragraph studio panel and then update the style. It simply prevent to use the editor panel to make the changes.

This happens on all the edit panel sections (spacing, bullets, font…)

905167620_errorenparrafos.thumb.jpg.feafdd4ed7ea1d1d460e9d148947cb88.jpg

Procedure to reproduce the error

1 - Create a paragraph style for bullets and customize the settings.

2 - Apply to some paragraphs to check it.

3 - Create a new paragraph style, based on the former.

4 - Apply and add modifications on the layout, then update the style to preserve the changes made.

5 - Edit the style to make fine adjustments. The fields of the edit panel are all blank

Share this post


Link to post
Share on other sites
36 minutes ago, Old Bruce said:

Just choose the bullet from the top menu, that will retain the bullet and allow you make the changes.

I know, but is not the solution. Selecting bullet on the top menu only activate the default bullet, but don't show the changes already applied. Doing this does not retain the bullet formatting, only activate the basic bullet. Also, not only happens on bullet. All sections of the editor (size, character, spacing, tab stops…) appear as blank/default despite not being the case.

The bug is that all  the style character/paragraph settings appear blank/default on the editor, despite being correctly applied on the layout and showing correctly on the studio panel. I can apply the style perfectly, but the editor shows nothing on it. I cant make changes of the style on the editor, only on the studio panel and later update the style.

Share this post


Link to post
Share on other sites
18 minutes ago, Daniel Gibert said:

All sections of the editor (size, character, spacing, tab stops…) appear as blank/default despite not being the case.

Must be a language/localization because what I see on a new 'Based On' style is not Default or Blank but [No Change] and that is truly different from Default. No Change means the values from the original style will be used, not Default values. 

Share this post


Link to post
Share on other sites
25 minutes ago, Old Bruce said:

Must be a language/localization because what I see on a new 'Based On' style is not Default or Blank but [No Change] and that is truly different from Default. No Change means the values from the original style will be used, not Default values. 

OPS. Yes. You are right. It says it, but this is an horrible option. So if I need to make changes, on the editor, I must reinsert any setting that is supposed already there. Problem (in this case at least) is that I if I select bullet on the menu it replaces automatically all the default bullet settings, destroying the already in use cloned ones, forcing to reconfigure all. Also it force you to remember what the original settings are because it doesn’t show you the on the cloned ones.

on indesign, the “based on” styles inherited all settings and show it on the editor, and if you change the original, it applies on the copied. I prefer to believe this is a bug and publisher is simply having an error on the editor, not showing the “cloned” settings. If not, it will be a nightmare to change copied styles with the editor. Time will tell. Meanwhile I will change settings on the studio and later updating the style.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.