Jump to content
stephenw

Refine selection tool in Affinity Photo is very slow after latest update

Recommended Posts

I am using the refine selection tool and since the newest update to Affinity Photo, it has slowed down considerably. before it would takes maybe 10 to 15 secs to complete it's process, now it is taking 30 to 40 secs to complete the process. Really slowing down the workflow... anybody know what is going on?

Share this post


Link to post
Share on other sites

If you are using Affinity Photo on macOS, open Preferences > Performance and try turning Hardware acceleration off and setting the Display to use OpenGL. If on Windows, does the process time change depending on the size of the image or selection?

Share this post


Link to post
Share on other sites
Posted (edited)

Hi Lee,

Thanks for getting back to me. I am using Affinity Photo on Windows. The process time doesn't really change due to the size of the image or the selection, as all the photos I am working on are essentially the same as each other. Very boring stuff, taking photos of vehicles in inventory for a car dealership and removing the background then inserting (copy and paste) onto another photo with a blurred image of the dealership building so that all the photos of any of the vehicles all look consistent with each other on the website. So I am literally doing EXACTLY the same thing, photo after photo. So speed is key, as I am doing five photos per vehicle for a set, and each set was taking me 20 min to complete. But now, if the refine selection tool is taking an extra minute to complete it's process my time isn't 20 min its 30 min. Multiply that by 8 or 10 sets a day and that's an extra 80 to 100 min per day to complete the work. When I started using Affinity Photo  the refine selection tool would do it's thing in about 15 secs, now it's upwards of 90 secs. ( I said originally in my first post it was taking 40 secs, but then I actually timed it)  Tick tock...

Edited by stephenw
Re read posting

Share this post


Link to post
Share on other sites

Mine is crazy slow too on a brand new HP.  I just bought the Affinty photo and am really frustrated with how slow it is to mask.   There has got to be a fix for this.   There sure doesn't seem to be any delays in the tutorial videos...

Share this post


Link to post
Share on other sites

Anybody else experiencing this issue? Any fixes coming from Affinity Photo? I have been trying to learn more about it an, I agree, in the tutorial videos it shows the refine selection toll as being almost instant. I don't expect it to be instant, cause it wasn't before, but it is certainly crazy slow and it needs to be rectified.

Share this post


Link to post
Share on other sites

Have you tried it in the latest beta

https://forum.affinity.serif.com/index.php?/topic/91357-affinity-photo-windows-customer-beta-172414/

The release notes seem to indicate a change in this area

  • Changed selection refinement to be the same as in version 1.6

Due to the ongoing Brexit negotiations, punctuation, spelling and grammar will be used sparingly until further notice.

Share this post


Link to post
Share on other sites

There is also a problem with Refine Edges tool after using color range selection tools. To recreate the issue, on some photo select background colors with Select > Color Range > Select Blues or Select Sampled Color. Then Invert Pixel Selection and finally Refine Edges. Refine selection calculation will take a long time and matte will be incorrect. I am using AF on Macbook Pro 2017, macOS 10.14.5. I tried switching off Metal support but no avail.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×