Jump to content

Recommended Posts

When entering composite characters, e.g., entering an á using the US International/Extended keyboard layout by pressing first the ' (apostrophe) key, then the a key, both the first and the combined characters are entered in Affinity Publisher.

The correct behaviour should be to temporarily show the first character of a composite, then

  • if a valid character for a composite is entered, e.g., an a after an ', then show only the composite á
  • if an invalid character for a composite is entered, e.g., a b after an ', then show both the first and second characters

 

Share this post


Link to post
Share on other sites

Hi tahy.online,

Welcome to the forums...

I'm not sure if the same procedure is used on a US International/Extended keyboard but on a UK standard keyboard to generate diacritical marks you'd use alt with the appropriate letter, e.g.

  • an acute accent á, é - alt e followed by the appropriate letter
  • a grave accent à, è, ù - alt ` followed by the appropriate letter (I think this is to the left of the number 1 above QWERTY on a US keyboard) 
  • a circumflex â, ê, î, ô, û - alt i followed by the appropriate letter
  • an umlaut ë, ï, ü - alt u followed by the appropriate letter
  • a cedilla ç - just alt c

Are you able to see if any of these work for you?


Affinity Photo 1.7.2, Affinity Designer 1.7.2, Affinity Publisher 1.7.2

MacBook Pro 16GB, macOS Mojave 10.14.6

Share this post


Link to post
Share on other sites
13 minutes ago, Hangman said:

I'm not sure if the same procedure is used on a US International/Extended keyboard but on a UK standard keyboard to generate diacritical marks you'd use alt with the appropriate letter

On Windows with a standard UK keyboard you need to use the Alt Gr key (to the right of the keyboard) or Ctrl+Alt (to the left) to generate vowels with acute accents. I don’t think standard US keyboards make the same distinction between the two Alt keys. Edit: This probably isn’t relevant to Mac users. Sorry!

I like and use TypeIt for easy access to accented characters and other symbols.


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.1.404 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.7.1.143 • Designer for iPad 1.7.1.1 • iOS 12.4 (iPad Air 2)

Share this post


Link to post
Share on other sites

Dear @Hangman, @Alfred,

Thank you for your notes and much appreciate the quick response!

My hope is that Serif would fix this bug in Publisher, as both Affinity Photo and Designer work correctly with US Extended.

Very long ago I had decided to use US International (Windows) and US Extended (MacOS), as those remain the closest relatives and I was stuck with Windows at work. I made a keyboard layout on the Mac that extended the US Extended layout and has worked very well for me.

@Alfred - there are layouts on the Mac that use AltGr, but the Mac and the Windows layouts for some of the alternative keys are different, so is the layout for other localised keyboards. Hence the decision to use a US layout, which is always the same, available on all platforms. Oh, and greetings from the (momentarily) sunny Firth of Clyde!

@Hangman - composite entry with the UK layout does indeed work, so it is clearly a bug with the US Extended layout.

In any case, the point is that Publisher needs fixing! I have been using InDesign and considering Publisher as the long term solution. I understand that it is a younger product, although Serif has a long history. I was wondering what is your view on bugfixes? Is there a good chance?

Share this post


Link to post
Share on other sites
2 hours ago, Alfred said:

Alt Gr or Ctrl+Alt  (...) This probably isn’t relevant to Mac users.

On mac you access additional key assignment with alt (=option). But you also have different and easier ways to access such accents:

1. hold-click a key to make a pop-up appear you may select from:
This works for most but not every character, eg not for μ (opt-m) (maybe it would in a Cyrillic setting)

1862752910_textaccent1-hold-clickakey.jpg.e026005b81525076518c10f9ca2c67c7.jpg

2. enter an accent to get it marked yellow, showing the next fitting key would melt both:
1062840323_textaccent2-typeaccentfirst.jpg.76df8e23703f7b7f60815d135a070fbd.jpg

3. use the virtual keyboard to get previews of possible combinations:
1987964215_textaccent3-virtualkeyboard.jpg.db4170d0f4e029880663496912d05efc.jpg


macOS 10.12.6,  Macbook Pro 15" + Eizo 24"

Share this post


Link to post
Share on other sites
10 minutes ago, thomaso said:

On mac you access additional key assignment with alt (=option). But you also have different and easier ways to access such accents:

1. hold-click a key to make a pop-up appear you may select from:
This works for most but not every character, eg not for μ (opt-m) (maybe it would be in Cyrillic setting)

I have something similar here on iPad when using the on-screen keyboard. I get access to eight alternative characters if I hold down the a on the English (UK) keyboard,  but I need to use the Greek keyboard for μ (or the Russian keyboard for я and other Cyrillic characters).


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.1.404 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.7.1.143 • Designer for iPad 1.7.1.1 • iOS 12.4 (iPad Air 2)

Share this post


Link to post
Share on other sites
2 minutes ago, Pauls said:

Is the input source name set to U.S. International - PC ?

The issue first surfaced with a layout based on that.

To test, I now loaded U.S. International - PC and the issue persists. For example ' + a results in 'á not á.

Share this post


Link to post
Share on other sites

What are your autocorrect settings set to in preferences - screenshot would be best.

 

Also what version of Mac OS are you on ?


Living the Dream since 1964 - about 25 years left

Share this post


Link to post
Share on other sites

I have to let go of the alt+` before pressing the desired character. Will have to check on El capitan


Living the Dream since 1964 - about 25 years left

Share this post


Link to post
Share on other sites

They are on the keyboard... :-) But to get accented characters, there is no need to press alt on the US International layout.

Just pressing the apostrophe, double quote etc. keys, then another key like a, e or o will result in an accented character.

Share this post


Link to post
Share on other sites

I am familiar with using composite characters because I regularly type in French on the French Canadian keyboard layout (incidentally, using a US physical Apple keyboard). I think I understand what tahy is saying, so I thought maybe I could help illustrate with a video.

 

In the video, I start with a window of TextEdit at top, a window of Publisher in the middle, and the Mac built-in Keyboard Viewer below so you can see what is happening in the keyboard layouts.

At first, you will notice that I began with my keyboard layout set to U.S.

Next, I change to Canadian French - CSA. I chose this layout to illustrate how composite characters should work. Notice that one of the keys is now orange on the Keyboard Viewer, indicating that it is a character that expects another character to follow for creating a composite character. In this layout, to get ê, I must first type ^ and then e. So far it works like it should.

Then, I switch to the "U.S. International - PC" keyboard layout, and it too has a couple of orange keys mapped. Here I try to type é, using the composite of apostrophe plus e, but you see it results in ‘é. I try the same thing in TextEdit, and it works as intended.

I have also tested unchecking the Publisher preference "Change straight quotes to typographic quotes," but it does not solve the issue, although I still wouldn't be surprised if it is somehow related.

I was using macOS 10.14.5 in the video.

Share this post


Link to post
Share on other sites

Same issue on a MacBook Pro, 10.12.6, German – when using the "U.S. International - PC" keyboard layout.

(Note: on this reduced macbook keyboard not ´ but ' key is necessary to make é appear in the layout)


macOS 10.12.6,  Macbook Pro 15" + Eizo 24"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×