Jump to content
GaryLearnTech

Affinity Photo: Stock > Search Unsplash > crash

Recommended Posts

I'm using the latest versions (1.7.1) of both Affinity Photo – and Affinity Publisher (1.7.1).

This crash is consistently reproducible.

Steps to reproduce: 

  1. Open Affinity Photo 1.7.1 (or Publisher 1.7.1)
  2. Create new blank document
  3. Go to Stock panel
  4. Search Unsplash - instant crash

Searching the two other Stock sources, Pexels and Pixabay, seems to be robust.

OS: macOS High Sierra (10.13.6)

See this 33 second video in case I'm missing anything from the description:

 

No new software nor hardware installed recently that might explain this.

Curiously, I tried this feature briefly on my office iMac yesterday and all three worked there.  On my roughly similarly specced and configured iMac at home, there are consistent crashes when searching Unsplash in both Photo and Publisher.  Today was the first time I have tried the Stock search at home.

I wondered at first if I might have caused a problem when adding a rule to my 3rd-party firewall, Little Snitch.  But the problem persists even when LS is stopped, so almost certainly not relevant.  You can see I actually turn it off first in the video.

I've attached the two most recent crash logs from Photo and Publisher for your enjoyment.  Let me know if I can add anything that might help…

Affinity Photo_2019-06-21-171012_iMac27.crash

Affinity Publisher_2019-06-21-143220_iMac27.crash


—— Gary ——
macOS: 10.13.6
iOS: current release
Photo/Designer/Publisher: current releases

Share this post


Link to post
Share on other sites

Gary Learn Tech,  I do not yet have Publisher but after watching the Serif presentation video on youtube yesterday I pressed the stock button on Affinity Photo for the first time and on my rather aged MacBook Pro 15" 2010 running High Sierra 10.13.6 I have exactly the same issue with  Upsplash, in fact, that is the reason I am here today looking for a fix.  shall keep my eyes peeled.


MacBookPro 15-inch mid 2010 intel core I7,  NVIDIA GeForce GT 330M 512 MB, Mac OS X Lion 10.7.5.

Share this post


Link to post
Share on other sites

A small but interesting(?) development…  Photo still crashes today when I search via Unsplash.  But if I search for a term not found in their databases - for example, "suydsjbhsdyjugsdhmsdf34876dsjfhg" - it totally fails to crash.  But try searching for a term that will be found and it still  crashes.

Before anyone suggests a reboot, my iMac was shut down yesterday after writing this original post and freshly powered up today - so there's another trouble-shooting box ticked.


—— Gary ——
macOS: 10.13.6
iOS: current release
Photo/Designer/Publisher: current releases

Share this post


Link to post
Share on other sites

Hi Gary, 

How odd! I have shut my system down now and writing this in bed on an eye pad.  I will have a go at that tomorrow

 

regards

 

Sean


MacBookPro 15-inch mid 2010 intel core I7,  NVIDIA GeForce GT 330M 512 MB, Mac OS X Lion 10.7.5.

Share this post


Link to post
Share on other sites

Yes can confirm, no crash if gobbledygook is written but instant crash if a word proper is typed (weird!) I also clicked on the metatext and actually joined Upsplash wondering if that was anything towards the anomaly and typed the same search criteria in their search engine and it all worked, so I await a fix - or just use one of the other two search stations below UpSplash.


MacBookPro 15-inch mid 2010 intel core I7,  NVIDIA GeForce GT 330M 512 MB, Mac OS X Lion 10.7.5.

Share this post


Link to post
Share on other sites

Sorry MEB   I applied the beta patch and to no avail, still doing exactly the same 


MacBookPro 15-inch mid 2010 intel core I7,  NVIDIA GeForce GT 330M 512 MB, Mac OS X Lion 10.7.5.

Share this post


Link to post
Share on other sites

Hi Garry, Seanboy,
I've removed my previous reply since the current Customer Beta is the same version that's available through the Mac App Store and Affinity Store so no differences in behaviour between them. That's why it doesn't recognise the MAS version for you Gary - only the next Customer Beta will do so. For Affinity Store users the Customer Beta does work with the current Affinity Store (retail) version. My apologies for the mistake.

We are still investigating this issue. Any eventual fix will be first implemented in an upcoming Customer Beta for everyone to check if it does solve the issue for once before being added to the retail versions. I will get back to you as soon as there's a customer Beta with a fix available.

Share this post


Link to post
Share on other sites

Hi @MEB

Thanks for your update.  This is a comparatively minor issue, so I am happy to sit back and wait for now. :)

Cheers,
Gary


—— Gary ——
macOS: 10.13.6
iOS: current release
Photo/Designer/Publisher: current releases

Share this post


Link to post
Share on other sites

Ditto that!


MacBookPro 15-inch mid 2010 intel core I7,  NVIDIA GeForce GT 330M 512 MB, Mac OS X Lion 10.7.5.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×