Jump to content
bilboudo

Affinity Photo 1.7.1 still bugged

Recommended Posts

A few days ago I've updated Affinity Photo for iPad to the 1.7.1 crossing fingers that the slowing resolution refresh and stroke delays would be fixed but... unfortunately they're still there! :-((((

I can't figure out how an app that worked almost perfectly in the 1.6 version, it's now so corrupted to become almost unusable with some files that worked perfectly with 1.6.

Please, if it's impossible to fix these issues, is there any way to back to the 1.6 version? It has the erase bug (that works also with finger touch even if settled only for pen), but at least I can use Affinity Photo to work again.

Share this post


Link to post
Share on other sites

Having the same issues here. Incredibly slow saving (usually resulting in a crash), many tools being laggy and crashy.. I'm really disappointed with these 1.7 updates. Could we at least get access to the 1.6 version on Testflight somehow?

I understand if you all don't want to revert on the main app store. Just let us go back to the working build, before we give up and start using some other software again.

Share this post


Link to post
Share on other sites

I am also having the same speed issue. It is slightly better than the 1.7 version. I am using iPad Pro 2nd but the processing of the live filters is so slow or crash.. the 1.6 version didn’t have any issues 

Share this post


Link to post
Share on other sites

Installed the update 1.7.1.143. on a 2017 Ipad Pro. It improved the response of the healing/clone brush and liquify. But the refresh time to show the brush action gradually slows down to about 30 seconds. Also, I tried to export a file, a three layer PSD about 850mb, Affinity was not able to generate the PSD to export and share. So sad cause it works great when it works right :(

Share this post


Link to post
Share on other sites

My work flow has completely stopped since the 1.7 updates, everything is laggy, buggy and crashy.  

 

It's pretty much unusable nowadays.  

 

Affinity Photo used to be my favourite tool on the iPad just two weeks ago, and now I can't even use it.

 

Drawing on a large document, laggy, drawing on a large document with lots of layers, really laggy, try to move an object on a larger document with lots of layers, really crashy.

 

Ugh.

Share this post


Link to post
Share on other sites

Hi all,

I'm updating the developers with the new posts I see regarding the performance of the 1.7 update.

Can you each provide a list of the tools affected. The tool mentioned in the bug report was the Paint Brush Tool however I realise other tools are affected. If you can, also provide a screen recording so we can see exactly what you're seeing.

Thank you very much.

Share this post


Link to post
Share on other sites

I don't find 1.7.1 as buggy as it apparently is to the previous users.   If there is a problem be specific so they can fix it.  

frankthechicken please post the video   

 

Share this post


Link to post
Share on other sites

Hi frankthechicken, I'm on my Mac right now but you can use the Apple Screen Recording.

https://support.apple.com/en-us/HT207935

Don't turn the mic on.  

You will see it in your photos.  After you press stop.  Home that I am not telling you things that you already know.  

I don't know about the steps because I am not quite sure what you are doing.  

Share this post


Link to post
Share on other sites

The only steps I am doing are

 

1.  Create a new document with a size of 8000 x 8000 pixels

2. Try to draw on the canvas using the pencil

3. Notice how laggy it is

 

I've tried using the iPads screen recorder,  but it doesn't seem to identify where the screen has been pressed (i.e with a red dot) which means it is hard to show how laggy it is.

Share this post


Link to post
Share on other sites
1 minute ago, frankthechicken said:

The only steps I am doing are

 

1.  Create a new document with a size of 4000 x 4000 pixels

2. Try to draw on the canvas using the pencil

3. Notice how laggy it is

 

I've tried using the iPads screen recorder,  but it doesn't seem to identify where the screen has been pressed (i.e with a red dot) which means it is hard to show how laggy it is.

You can turn on the "show touches" (or so.. I'm Italian and I'm not sure how it's translated in the English version) option directly in the Affinity Photo preferences, General.

Share this post


Link to post
Share on other sites

Me too I made  a couple of recordings but I can't upload the in my post.

Or better: I can drag and drop but the upload is queued  and nothing more happens.... Probably are they too heavy (they're both about 20 mb)?

How can I shrink them in order to upload them quickly?

 

Share this post


Link to post
Share on other sites

Sorry frankthechicken, for telling you something you already knew, but now I understand what the problem is.  

Yes there is a definite lag.  

To see if this was the pencil, I tried the same thing in Notes and there was no lag.

So yes, you are right, there is a bug here.  

 

Share this post


Link to post
Share on other sites
4 hours ago, bilboudo said:

How can I shrink them in order to upload them quickly?

You can edit them in Apple photo library. Just shorten it to get relevant bit or bits.


IPad Pro 10.5 512GB iOS 12.3.1 Affinity Photo 1.7.2.146 Affinity Design 1.7.1.1 Publisher for iPad ?

Share this post


Link to post
Share on other sites
5 hours ago, frankthechicken said:

Perfect, thank you.

See the difference if you pause briefly before starting to paint. Interesting.... no more delay. File 8000x8000 300dpi for comparison. Seems to be an issue determining brush touch?


IPad Pro 10.5 512GB iOS 12.3.1 Affinity Photo 1.7.2.146 Affinity Design 1.7.1.1 Publisher for iPad ?

Share this post


Link to post
Share on other sites

DM1, I tried what you described on that size of doc, holding the pencil for a moment but for me it still hesitated.   Can you explain why it didn't happened on my photo?   

Share this post


Link to post
Share on other sites

Maybe different hardware? My Pro has 4gb ram. I know people were reporting issues with the bigger/newer iPads that were not apparent on mine. I think the devs still have a lot of fine tuning to do, in addition to fixing some actual bugs. I’m sure they’ll get there eventually. :)


IPad Pro 10.5 512GB iOS 12.3.1 Affinity Photo 1.7.2.146 Affinity Design 1.7.1.1 Publisher for iPad ?

Share this post


Link to post
Share on other sites

My iPad is the 1T 6 gb, but I just tried something.   My image is 16bits, so I opened a doc, just as described but in 16 bits, no lag at all.  Try it to see if has something to do with 8 bits. 

Quite frankly I only seem to have problems if I am trying to do something I know nothing about, then maybe I will get the spinning ball.   But I have created panos with 6 to 14 images, the last one takes a bit longer, the image above was an HDR Focus Merge, which was not shot very well, only 3 images, so I used the 3 one as an embedded image to get that result.  

Exporting to psd is very slow, but tiffs and jpegs are quick.  

Importing from my camera is awesome and fast.  

Share this post


Link to post
Share on other sites

I can post a couple of videos: I use the same file (PSD format, 4800x4800 px, CMYK, 58 layers) on two iPads, one with Affinity Photo 1.7.1, the other with Affinity Photo 1.6.12.86. For this recordings I've turned on the "show touch" option in order to make clear when I touch the screen with fingers and the pen and when the strokes are shown on the screen.

The file is 8bit. I've tried to convert it to 16bit as suggested by p_mac, but nothing changed, maybe even slower....

Let's start with iPad Pro 10,5" 256gb, ram 4gb, Apple Pencil (1st generation), Affinity Photo build 1.6.12.86. We can notice that there are some little delays on the resolution refresh when I pan and zoom, but nothing so really bad. After some initial jamming with the pen, the strokes follow quite smoothly the pen tip on the screen.

 

 

Let’s pass now on iPad Pro 2018 12,9” 1TB, ram6gb, Apple Pencil (2nd generation), Affinity Photo build 1.7.1. Here the resolution refresh panning and zooming is  slower, but what is really bad is the stroke delay, making the app unusable to work on this file. 

 

 

I really hope these recordings could help to let the 1.7.1 build to back to work as well (or even better, if possible) as the 1.6.12.86.

Share this post


Link to post
Share on other sites

Thanks for all the info and videos so far. This thread is linked to the bug report for the iPad performance issues.

I see this delay on a document at 8000 x 8000 px @ 300dpi. I can write a couple of words before they appear on the screen.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×