Jump to content
bilboudo

Affinity Photo 1.7.1 still bugged

Recommended Posts

4 hours ago, p_mac said:

My image is 16bits, so I opened a doc, just as described but in 16 bits, no lag at all.  Try it to see if has something to do with 8 bits. 

I just converted my blank 8000x8000 px 8bit Document (which has delay with brush strokes showing), to a 16 bit doc and amazingly no delay evident at all!!


IPad Pro 10.5/512GB lpadOS 13.1.1  Affinity Photo 1.7.3.155 Affinity Design 1.7.3.1 Publisher for iPad ?

Share this post


Link to post
Share on other sites

Seeing same here, lab colour allowed more layers but it got laggy too. Deleting layers didn’t help either.


IPad Pro 10.5/512GB lpadOS 13.1.1  Affinity Photo 1.7.3.155 Affinity Design 1.7.3.1 Publisher for iPad ?

Share this post


Link to post
Share on other sites

v1.7.1 iPad Pro 2018 w pencil. I’m experiencing similar issues with the inpainting tool - 30 mpix jpegs are impossible to work on even with just a few layers (I get the black screen with “inpainting brush” progress bar even after just a tap at the image... 

Share this post


Link to post
Share on other sites

Hi Chris B. 

I am attaching a video to show that you can’t see the live filter effect ,in this video, it is high pass filter on the 1,7.1 update , I’ve experienced the same problem on the 1.7 version. You can only see it once merging down or export the photo. My first try making the video everything crashed when i’ve tried to merge it.  Everything worked perfect on the 1.69 version. I am using Ipad Pro 2nd and latest ios update

Share this post


Link to post
Share on other sites

Are you setting your blend mode to Overlay?  It is my understanding from tutorials that it should be set to Linear Light.  Try it.

Share this post


Link to post
Share on other sites

I am setting it to overlay, and it is the same method that I am using for the last 18months  on Affinity Photo and it worked perfectly on version 1.69 and earlier versions.  You can use hard light, soft light and linear light. I have just tried it now with linear light and experienced the exact same problem where you can only see the full efect of the filter once merging down or export. 

Share this post


Link to post
Share on other sites

A random problem occurred on my iMac in Affinity Photo.  I was editing a photo and the AP normal app opening screeappeared, the one you get when you open AP, I  selected close and all was normal.  If it occurs again I will screen capture. Posting, just in case, others have experienced same bug.


Cecil - North Carolina

iMac Retina 5K, 27”, 2019. 3.6 GHz Intel Core 9, 40 GB Memory DDR4, Radeon Pro 580X 8 GB. iPad Pro 10.5.

Continuous improvement is better than delayed perfection 

Share this post


Link to post
Share on other sites

This file is 1.77gb and I have been using the paint brush and gradients on it for the past 10 minutes.  I have duplicated, saved, etc.   It is 20659 x 5295 px.  Other then having trouble with the keyboard, won’t disappear. 

 

 

Share this post


Link to post
Share on other sites

Sorry for the many posts but having difficulty with the Apple keyboard as it seems to get stuck and won’t retreat.  But as you can see this is a very large file. It is a pano of 6 - 43 mp images done on this iPad Pro. 

9C18238D-0383-4DFA-B13D-738785AEF1CF.jpeg

Share this post


Link to post
Share on other sites
5 minutes ago, Patrick Connor said:

thanks, this thread is in the Photo iPad section and many problems are unique to the platform, but that may help some here. 

So sorry, just reading unread, did not realize change from desktop to iPad.


Cecil - North Carolina

iMac Retina 5K, 27”, 2019. 3.6 GHz Intel Core 9, 40 GB Memory DDR4, Radeon Pro 580X 8 GB. iPad Pro 10.5.

Continuous improvement is better than delayed perfection 

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Panana said:

I am setting it to overlay, and it is the same method that I am using for the last 18months  on Affinity Photo and it worked perfectly on version 1.69 and earlier versions.  You can use hard light, soft light and linear light. I have just tried it now with linear light and experienced the exact same problem where you can only see the full efect of the filter once merging down or export. 

I am not seeing this issue here using both Overlay and Linear Light. No merge applied as you can see.

Edited by p_mac
Vid didn’t upload properly, please delete vid with thanks

Share this post


Link to post
Share on other sites

Sorry Panana, the vid wouldn’t upload but the high pass filter is working well for me.  My iPad Pro is 1T 6gb 2018.  I don’t know if you should delete and download again.  If you do make sure that you save your photos so they don’t get deleted as well.  I have done that myself as sometimes the download can be corrupted.   Is everything else working as you expect?

Are you using RAW images?  

If this is a problem make sure that the mods know all the information.  

Share this post


Link to post
Share on other sites

I am using raw, do the basic adjustments in development persona. I am doing a lot of sport photography and it is luckily quiet now during school holidays. But I need Affinity to be fully operational for July and August when I have a full schedule of events

Share this post


Link to post
Share on other sites

Is there any E.T.A about the new Affinity Photo iPad update that will fix the problems of the 1.7.1 build?

Is it possible to get it before the iPad OS release?

Or is it plnned for that time?

Share this post


Link to post
Share on other sites

You can get access to latest beta this way: 

 


IPad Pro 10.5/512GB lpadOS 13.1.1  Affinity Photo 1.7.3.155 Affinity Design 1.7.3.1 Publisher for iPad ?

Share this post


Link to post
Share on other sites
5 hours ago, DM1 said:

You can get access to latest beta this way: 

 

Time ago I’ve tried to apply to the beta program but I never was contacted by Serif to get the code to access to the beta version through the TestFlight app.:(

I would more than happy (and totally in my interest) to test the beta version, if only it would be possible.

Share this post


Link to post
Share on other sites
52 minutes ago, bilboudo said:

I would more than happy (and totally in my interest) to test the beta version, if only it would be possible.

Can you drop me a personal message with the following I'll see what I can do:

  1. Your forum handle/username OR firstname + lastname
  2. Your email address.
  3. Which compatible iPad device you own (iPad Pro, iPad Air 2, iPad (2017) iPad (2018))

I certainly appreciate your interest :) 

I'm not too sure when we can expect to see the new update released to the App Store to be honest. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.