Jump to content
SergeyZhdanko

Broken layers behaviour in a group

Recommended Posts

Version 1.7 - 1.7.1.143

  1. Completely broken layers behavior  in a group - everything that below pixel layer is not working. For example add curves, add pixel layer, add curves, then group this three layers. First curves layer (bottom) will not work. Sometimes all adjustment layers in a group will not work (not just below pixel layer). Same order but no grouping - no problem.
  2. Small UI - on 10.5’ it is hard to navigate with fingers, small circles for width/opacity/flow/etc. There is no visible left arrow at the bottom when using any tool (near left circle), but I am constantly triggering it and instead of changing brush size I am about to 'continue last' and 'pick color'. Please, only right arrow is needed at default view.
  3. Please add option to use original filename when exporting.

Share this post


Link to post
Share on other sites
8 hours ago, SergeyZhdanko said:

Completely broken layers behavior  in a group - everything that below pixel layer is not working. For example add curves, add pixel layer, add curves, then group this three layers. First curves layer (bottom) will not work. Sometimes all adjustment layers in a group will not work (not just below pixel layer). Same order but no grouping - no problem

From my understanding, Adjustment layers operate on all the layers beneath them. If you place a curve layer above a pixel layer it will effect that pixel layer and any pixel layer below as well. If you move it below that pixel layer it no longer effects the pixel layer above it (by design). You can nest the curve adjustment by clipping it to the pixel layer. Now it will sit below the pixel layer but be slightly indented. The curve adjustment will now only effect the pixel layer into which it is clipped and none of the lower layers (unless they are also clipped to this pixel layer).  Add another curve layer above the Group and it will effect all pixel layers below it, including grouped pixel layers.

2. Yes, not sure smaller ui is an 'improvement '.

3. Agree.


IPad Pro 10.5/512GB lpadOS 13.1.1  Affinity Photo 1.7.3.155 Affinity Design 1.7.3.1 Publisher for iPad ?

Share this post


Link to post
Share on other sites

Also, adjustment layers in a group affect only the layers in that group, if the group also contains a pixel layer. If you don't want to restrict the adjustments to the pixel layer that is in the group, they should not be in that group.


-- Walt

Windows 10 Home, version 1903 (18362.356), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.3.481 and 1.8.0.486 Beta   / Affinity Designer 1.7.3.481 and 1.8.0.486 Beta  / Affinity Publisher 1.7.3.481 and 1.7.3.475 Beta

Share this post


Link to post
Share on other sites
1 hour ago, walt.farrell said:

Also, adjustment layers in a group affect only the layers in that group, if the group also contains a pixel layer. If you don't want to restrict the adjustments to the pixel layer that is in the group, they should not be in that group.

What to do with organising then?)) Color adjustments, dodge and burn, color grading and so on. It wasn't a thing in 1.6 version. Because I have projects started in 1.6 and after update those edits looks wrong. Also, you can do the same in Adobe Photoshop (group adjustment layers) and it will be correct no matter what. This is not a feature, it is a bug. Try to make this in PS and then open psd file in AF on iPad. You will see that it is wrong. If I want to target adjustments to a specific layer, I am using clipping. But groups is only for organising purposes

Share this post


Link to post
Share on other sites
1 hour ago, DM1 said:

Try to add couple adjustment layers in Adobe Photoshop, then group them. You will see that result is completely different. Then export .psd file and open with AF 1.7 version. Grouping in PS is for organizing purposes (as it should be). Clipping is different. I am talking about grouping layers. If I want to target specific layer with adjustments, I am using clipping, it is basic knowledge. If I want to organize color edits (curves, dodge and burn, color balance) then I am using groups.

Share this post


Link to post
Share on other sites
46 minutes ago, SergeyZhdanko said:

It wasn't a thing in 1.6 version.

I can't be sure about iPad, but as far as I know on the desktop versions this behavior has been consistent in both 1.6 and 1.7 (and perhaps earlier).

So if you're sure that it behaved differently in 1.6 on the iPad I will have to trust that you're right, and simply figure that Serif changed it to be consistent since both the desktop and iPad versions are supposed to work consistently.

Sorry; I can't offer anything more.


-- Walt

Windows 10 Home, version 1903 (18362.356), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.3.481 and 1.8.0.486 Beta   / Affinity Designer 1.7.3.481 and 1.8.0.486 Beta  / Affinity Publisher 1.7.3.481 and 1.7.3.475 Beta

Share this post


Link to post
Share on other sites

To my knowledge it has always behaved this way. I haven't noticed any difference between 1.6 and 1.7 on the iPad in this respect.


IPad Pro 10.5/512GB lpadOS 13.1.1  Affinity Photo 1.7.3.155 Affinity Design 1.7.3.1 Publisher for iPad ?

Share this post


Link to post
Share on other sites
13 hours ago, walt.farrell said:

I can't be sure about iPad, but as far as I know on the desktop versions this behavior has been consistent in both 1.6 and 1.7 (and perhaps earlier).

So if you're sure that it behaved differently in 1.6 on the iPad I will have to trust that you're right, and simply figure that Serif changed it to be consistent since both the desktop and iPad versions are supposed to work consistently.

Sorry; I can't offer anything more.

 

13 hours ago, DM1 said:

To my knowledge it has always behaved this way. I haven't noticed any difference between 1.6 and 1.7 on the iPad in this respect.

So what about Adobe Photoshop? They claimed that compatibility is enhanced in the new version (import/export). Seems like desktop Affinity Photo and iPad versions are compatible, but .psd files are very limited, at least with layers in groups (usually I have very extensive edits with dozens of layers and groups). It's like 2 weeks on a new version and still weird for me to work like that. Ok, thank you guys for your response!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.