Jump to content
miklas0815

StudioLink: Designer not recognized

Recommended Posts

When clicking on Design Persona in Affinity Publisher, the dialogue below appears. All Affinity applications are installed in the latest version and work properly. I have stopped and restarted all of them. Still, the integration of Publisher with Photo works perfectly, not so with Designer.

 

image.png.0f857577e10f7efe688208c1e50d67ce.png

Share this post


Link to post
Share on other sites
Hello @miklas0815,
Welcome to this forum.
 
Try the following.
Start Publishers.
Create a new file. (Insert text or image)
file
Edit in Affinity Desinger
Close file
After that, there should be no error message

I hope it helps.
 

Unbenannt.png


Affinity Photo 1.7.2.471 :   Affinity Photo-Beta  1.7.2.464 :    Affinity Designer 1.7.2.471:  Affinity Designer-Beta 1.7.2.464:

Affinity Publisher-Beta 1.7.2.458:   Affinity Publisher 1.7.2.471:    Windows 10 Pro  (Version  1903 Build 18362.295)

 

Share this post


Link to post
Share on other sites

Struggling with this too. Tried your suggestion. Unfortunately, designer is greyed out in the menu.

image.png.685f69d8beacecfcc4564943c3deb912.png

Tried so far:

  • Re-installing all three apps -> no effect
  • Restarting windows -> nothing
  • Opening closing -> Nope
  • Making/saving files -> none
  • Placing file -> nada
  • Opening apps simultaneously -> nope
  • ..........

All apps are downloads from this morning (1.7.1.404). Oddly enough, Photo (eval copy) works, but Designer (licensed) doesn't.

 

Share this post


Link to post
Share on other sites

I'm having the same issue with both Photo and Designer.
I can open both via the File pulldown menu (Windows user), but the persona buttons just bring up the Studiolink warning message

Both Photo and Designer are up to date.

Share this post


Link to post
Share on other sites

I tried the suggestion of creating a document in Publisher, saving it and opening in both Photo and Designer, re-saving from both, and staring Publisher again.

StudioLink still does not work.

Thanks,

Mike

 

Share this post


Link to post
Share on other sites

Nothing that I have tried make StudioLink work.

Should I buy Photo and Designer again as directed in Publisher and then ask for a refund, since I already own both?

Thanks,

Mike

Share this post


Link to post
Share on other sites
3 hours ago, MMetzger said:

Should I buy Photo and Designer again as directed in Publisher and then ask for a refund, since I already own both?

No, that does not seem advisable.

Since you already have them, getting additional copies should not help.

Please confirm again your version numbers for Publisher, Photo, and Designer using Help > About dialogs. Also, where did you buy each of them?


-- Walt

Windows 10 Home, version 1903 (18362.239), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.2.471 and 1.7.2.464 Beta   / Affinity Designer 1.7.2.471 and 1.7.2.4464 Beta  / Affinity Publisher 1.7.2.471 and 1.7.2.458 Beta

Share this post


Link to post
Share on other sites

StudioLink doesn't work for me too, both Designer and Photo are not recognized. Tried all the tricks from this and the other thread with no success. Also the Modify in Photo from Designer and the Modify in Designer from Photo doesn't work anymore.

Share this post


Link to post
Share on other sites
11 minutes ago, Stefanoc said:

StudioLink doesn't work for me too, both Designer and Photo are not recognized. Tried all the tricks from this and the other thread with no success. Also the Modify in Photo from Designer and the Modify in Designer from Photo doesn't work anymore.

Solved!

After having deleted the .appinfo files it still didn't work but double clicking on a file for each application recreated the right .appinfo files and it worked.

Share this post


Link to post
Share on other sites
Posted (edited)
5 hours ago, Stefanoc said:

@JGA you need to update Designer and Photo to 1.7.1.404

OK, thanks. The applications didn't flag up an update, but will give it a try.

Update - Thanks Stefanoc, your suggestion worked. All software has the same version number and are now playing with each other.

Edited by JGA
Updated software to fix problem

Share this post


Link to post
Share on other sites
19 hours ago, MMetzger said:

Nothing that I have tried make StudioLink work.

Should I buy Photo and Designer again as directed in Publisher and then ask for a refund, since I already own both?

Thanks,

Mike

Using  v1.7.1.404 of all three Apps. I tried everything listed by everybodyIN THIS AND OTHER THREADS with no success. 

I bought Photo & Designer a couple of years ago, using a now-defunct email address and I was wondering if different email addresses had an influence.

Rather than buy, I requested a free trial and downloaded Designer & Photo from the site accessed from within Publisher, using my current email address. That didn't work either.  I thought that maybe downloading another copy of Publisher from a different Serif site might help. There had been some discussion about Beta versions not working and though I had downloaded v1.7.1.404, I had done so from the Beta stream. . I downloaded Publisher v1.7.1.404 from the store rather than from within the forum.

THAT WORKED !!!!!!!!!!!! 

I don't know which steps had the desired effect, and I can't imagine I will use the Persona option too often --- but it's VERY impressive.  

I am hoping that the Finance software can find my Product Keys: if not I'll talk to the nice guys at Serif Support :/

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×