Jump to content

Recommended Posts

Hi,

We have just installed Publisher on our Mac. But Studio Link is sadly not working.

 

I tried all the "fixes" i found in this forum allready, but it still doesn't work.

  • I tried to close and reopen all 3 programms in many different orders.
  • I reinstalled all of them
  • i updated to the latest 1.7.1 Versions off all of the Apps
  • I Checked the firewall options

 

Is there like a config file on mac, where you can specify the path of Photo and Designer?

 

Thanks in advance

Share this post


Link to post
Share on other sites

Hi Golokios,

Welcome to the forums :)

Are all of the apps installed in the root of your applications folder?

Thanks

Callum

Share this post


Link to post
Share on other sites
Just now, Golokios said:

Hi, Yes they are :)

Please could you make sure you have re opened the apps after you reinstalled them then close the apps and open Publisher and try the studio link?

Share this post


Link to post
Share on other sites

I was just reinstalling them like a 4th time. Still no luck. No matter in what order i open or close them. It is still telling me i have to install them and start them

Share this post


Link to post
Share on other sites
47 minutes ago, Callum said:

Please could you make sure you have re opened the apps after you reinstalled them then close the apps and open Publisher and try the studio link?

I had the same issue but this fixed it for me. I was worried it wouldn't work because I had bought from the Mac Store instead of on the website but it's fixed. Thanks

Share this post


Link to post
Share on other sites
2 minutes ago, nikiniki9doors said:
50 minutes ago, Callum said:

Please could you make sure you have re opened the apps after you reinstalled them then close the apps and open Publisher and try the studio link?

I had the same issue but this fixed it for me. I was worried it wouldn't work because I had bought from the Mac Store instead of on the website but it's fixed. Thanks

I dont know what to do anymore. Nothing seems to work for me

Share this post


Link to post
Share on other sites
Just now, Golokios said:

I dont know what to do anymore. Nothing seems to work for me

Please bear with me while I look into this further :)

Share this post


Link to post
Share on other sites
24 minutes ago, SkemGraham said:

Having same problem - Do I really need to reinstall all three programs???

Which operating system do you have the apps installed on?

Share this post


Link to post
Share on other sites

Hi,

I'm getting the same issue. Bought Designer from Mac/App store, Publisher from website and getting no connection, just a request to purchase. On Mojave, MacBook Air.

Share this post


Link to post
Share on other sites
37 minutes ago, Andy Channelle said:

Hi,

I'm getting the same issue. Bought Designer from Mac/App store, Publisher from website and getting no connection, just a request to purchase. On Mojave, MacBook Air.

OK. I've updated and it's working. Stand down.

Share this post


Link to post
Share on other sites
3 hours ago, Callum said:

Which operating system do you have the apps installed on?

Sorry for delay - busy busy! Just updated Designer which now works in Publisher - Photo still refusing.

On old system! -  iMac Mid 20108Gb memory - High Sierra 10.13.6

Share this post


Link to post
Share on other sites

Same here!

Is there a way to...yeah get it to work? : )

Ok saw now in AppStore on my Mac I need to update some stuff will try and get back asap

Share this post


Link to post
Share on other sites

I purchased Affinity Photo last year (thru the Apple Store) and recently updated to 1.7.1. Downloaded Publisher from the Affinity Store yesterday (June 19). Then purchased Designer from the Apple Store as well.

Launched Publisher and noticed that Studio Link would work for Designer, but not Photo (message says I need to install the program).

I found a simple fix. Launch all three programs separately from the icon (I'm on a Mac Pro), then check to see that Studio link is operating properly.

Close everything and relaunch Publisher only. Studio link should now communicate with the other personas.

No re-installing of programs or esoteric terminal mode shenanigans required.

Hope this works for you.

Share this post


Link to post
Share on other sites
3 hours ago, SkemGraham said:

Sorry for delay - busy busy! Just updated Designer which now works in Publisher - Photo still refusing.

On old system! -  iMac Mid 20108Gb memory - High Sierra 10.13.6

Went to App store and found that I could update photo from there (a bit different as no reminder as for Designer) everything working fine now

Share this post


Link to post
Share on other sites

@sergio.1974

Welcome to the Serif Affinity forums :)

First thing to check is that the Mac App Store builds have both

1) updated to 10701.404.0.0 un the Downloads and updates list (this is the MAS internal build number for 1.7.1.404)

2) that you have run both Designer and Photo at least once since updating them


Patrick Connor
Serif (Europe) Ltd.

Latest releases on each platform 

Share this post


Link to post
Share on other sites
  1. Uninstall all the programs and restart your computer.
  2. Visit the affinity website and download the trails for all the three program. (Don't use previous *.exe to reinstall)
  3. You must end up with version No 1.7.1.404 on all programs. install them with your key.
  4. Start both Photo and Designer once and keep it open.
  5. Now open Publisher and click on the Photo and Designer buttons. Might take a few seconds but will get linked.
  6. If, on opening Photo and Designer, you are asked to update, then no problems. Steps 1-5 won't be needed anyways.

Share this post


Link to post
Share on other sites

Hello everyone. I'm struggling with the same issue. All programs purchased at the same time and installed at the same time. I've tried the mentioned fixes, restarted the system multiple times (in between, before, after installation), reinstalled from freshly downloaded files, then followed this procedure:

21 hours ago, Evodes said:
  1. Uninstall all the programs and restart your computer.
  2. Visit the affinity website and download the trails for all the three program. (Don't use previous *.exe to reinstall)
  3. You must end up with version No 1.7.1.404 on all programs. install them with your key.
  4. Start both Photo and Designer once and keep it open.
  5. Now open Publisher and click on the Photo and Designer buttons. Might take a few seconds but will get linked.
  6. If, on opening Photo and Designer, you are asked to update, then no problems. Steps 1-5 won't be needed anyways.

all without success. I'm beginning to think that maybe my issue is that i'm working on a workstation? I'll attach the specs. Is there hope for me?

 

Thank you.

 

JSR*

DxDiag.txt

Share this post


Link to post
Share on other sites

same with me... tried it with reinstalling in diferent sequences ....deleting user files...resetting the Aps while starting...and ..and and...

it still say I should buy the Photo and Designer (wich are open at the same time... ;-) )

win 10

Share this post


Link to post
Share on other sites
Posted (edited)

Windows 10 user here. I have Designer and Photo, latest versions. I cannot see the studio link icons. Only the persona from the same application. 

They are installed in the same c:/program files/Affinity folder. Version 1.7.1.404 . I would love to have this seamless feature.

Edited by jkrah

Share this post


Link to post
Share on other sites

 

and

 


-------------------------------------------------------------------------------------------------------------------------------
Win10(1903)Home / Photo / Designer / Publisher & latest (beta) versions

Share this post


Link to post
Share on other sites

I tried it, unistall, removed %Programdata%\Affinity and all the Serif info in the registry. Reinstalled both 1.7.1.404 versions but still no studio link icons.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×