Jump to content

Recommended Posts

Hey there,

I've just downloaded the new version of Affinity Publisher. So it would be version 1.7.1. I did not have access to beta prior. This is my first experience with the software. Since I opened it up, I've been having crash issues. Can barely get through adding images to one page and the spinning/not responding starts. Sometimes if I wait a while it works it's way out of it and sometimes not. I've been working for over an hour and have only gotten through page 3 of my document. I've been searching for solutions. Here's what I've tried so far.

1. Downloaded High-Logic and uninstalled a few hundred fonts that I wasn't using.

2. Checked the appdata folder for crash reports. Those folders are all empty

3. Held down the CTRL key when I started up Publisher and checked all boxes/ set it all back to defaults. The issue persists.

As I've been typing this message, Publisher finally came out of it's spin, but I'm not going to get very far at this pace. 

Also, for some possibly further useful information, I had this problem sporadically with Designer and since that latest update, all those issues seem to have disappeared. I'm not sure if this is something going on with my PC or ? But I did see a forum thread somewhere that suggested this is not normal for Publisher and it should not be running this way. Any ideas or treasure trails you all can send me down to try and get this handled would be most appreciated. I was so excited to use this program and cut my time in half or more, but so far it's taking me more than twice as long to get anything done. :( Help?  

Share this post


Link to post
Share on other sites

Hi @Jeannie,

This is not expected. It should work regardless of how many fonts you've got installed. There's is a known issue where if you have more than 9999 individual font objects it won't recognise new fonts, but not crash. What windows version are you running? Can you please attach a crash report? It should be in 

%AppData%\Affinity\Publisher\1.0\CrashReports\

Thanks,

Gabe. 

Share this post


Link to post
Share on other sites

Hi Gabe,

I had mentioned that the crash reports folder for Publisher is empty. I just looked again. Still empty. I do have a crash report within the Designer folder but none are in Publisher. It doesn't seem to crash all the way? It just spins and I have to finally shut it down. Could that be why no crash report?

 

Oh also, I'm on Windows 10

Share this post


Link to post
Share on other sites
14 hours ago, DarkClown said:

Final Version of Publisher crashing here as well ... Crash Report attached.
 

Backtrace.zip

Can you please shed more light on this? is it random? Can you replicate it? is it document specific? 

Share this post


Link to post
Share on other sites

Happened while I was scrolling through the pages ... suddenly the app stalled and wasn't responding any more. Looks more like a random thing to happen ...


iCore i7-3770, 3.50GHz, 32GB RAM, SSD, NVIDIA GeForce GTX 1660 Ti, Windows 10 Pro - AP, AD and APublisher latest final & beta
http://www.timobierbaum.com

Share this post


Link to post
Share on other sites

I have the similar problem with the new version of Affinity Publisher 1.7.1.404 on Windows 7 Pro. When I work on page with multiple images (vector logos from Affinity Designer and several jpeg's) Publisher freezes. When I am in page without images on the same document everything is OK. The document is not huge. The file size is only 17.5 MB.

There is no crash report in the appdata folder.

I have observed same behavior at my two computers (Win 7 and Win 10).

 

Share this post


Link to post
Share on other sites

Bures do you mind sending your file here and I'll see if I can reproduce crashing behaviour with your document.

It might be worth embedding all the files or sending them along too.

Thanks


Serif Europe Ltd. - www.serif.com

Share this post


Link to post
Share on other sites

Thanks bures,

I can't reproduce a crash with that file, but I definitely see massive performance decreases when moving the text frame on page 10 compared to others, even after I've cleaned up a few things that I thought would be the cause.

We have an issue in similar to this but I think this might have a different cause, so I've logged it for the developers to investigate.

Thanks for sending over the file.


Serif Europe Ltd. - www.serif.com

Share this post


Link to post
Share on other sites

It seems that the crashes quite often occur, when I'm working on the "Pages" panel ... (moving between pages), changing applications and coming back seeing that Publisher stalled.


iCore i7-3770, 3.50GHz, 32GB RAM, SSD, NVIDIA GeForce GTX 1660 Ti, Windows 10 Pro - AP, AD and APublisher latest final & beta
http://www.timobierbaum.com

Share this post


Link to post
Share on other sites

I have this problem also, sluggish performance, freezes often and on such things as nudging or moving anything.  Sometimes comes back, often i have to use the Task Manager. I will send a crash report if i can get that far lol.  I'm going to attempt to fiddle with my AMD drivers..wouldn't surprise me a bit if that was the culprit.  Also, Publisher is not remembering the layout in each persona.

Share this post


Link to post
Share on other sites

This is my issue too. Crashed after I tried to re-arrange the pages in the pages panel. Now it crashes when I try to re-open that file.

Share this post


Link to post
Share on other sites

Hi Jon,

Thanks for that. Is it ok to remove the link to the file now as I've just realised there's sensitive content in that file?

Barry

 

Share this post


Link to post
Share on other sites

The new beta should address some of these crashing issues (it likely won't address many crash on open since they are document specific, but it hopefully shouldn't be possible to get a document in this state any more).

@DarkClown - I could never reproduce the crashing behaviour you seemed to get, however some fixes have gone in relating to the crash reports we got from you. I would be interested to hear if the new beta we released today is more stable for you.

Thanks


Serif Europe Ltd. - www.serif.com

Share this post


Link to post
Share on other sites
On 7/5/2019 at 5:53 PM, Jon P said:

 

@DarkClown - I could never reproduce the crashing behaviour you seemed to get, however some fixes have gone in relating to the crash reports we got from you. I would be interested to hear if the new beta we released today is more stable for you.

I'll check it out - but I guess we will never be sure, since I completely moved from Windows 7 to 10 (no migration) ... so new tests will be based on a different OS ...

 


iCore i7-3770, 3.50GHz, 32GB RAM, SSD, NVIDIA GeForce GTX 1660 Ti, Windows 10 Pro - AP, AD and APublisher latest final & beta
http://www.timobierbaum.com

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×