Jump to content

Recommended Posts

I do have a question. How can we link our existing Affinity Photo and Designer software from the App store with StudioLink? It currently says that both are not installed on my Macbook Pro, but they are.

Screen Shot 2019-06-19 at 1.18.14 PM.png

Share this post


Link to post
Share on other sites

@AryiaRae

Welcome to the Serif Affinity forums :)

To enable those buttons you MUST be using version 1.7.1 of Affinity Designer and 1.7.1 of Affinity Photo (and each of them run at least once). Now available from whichever store you bought the software from. For the Mac App Store it sometimes takes a few days to roll out new builds to all users. but here is our advice to see if it is ready for you.

Quote

For purchases from the Mac App Store: These are done automatically (next time you run after it is available in the store). In the Mac app store, go to the updates panel and press CMD+R they should appear if rolled out to your region. Apple sometimes phase roll outs around the world sometimes taking up to 72 hours.

 


Patrick Connor

Serif (Europe) Ltd.

Share this post


Link to post
Share on other sites
2 minutes ago, Patrick Connor said:

@AryiaRae

Welcome to the Serif Affinity forums :)

To enable those buttons you MUST be using version 1.7.1 of Affinity Designer and 1.7.1 of Affinity Photo (and each of them run at least once). Now available from whichever store you bought the software from. For the Mac App Store it sometimes takes a few days to roll out new builds to all users. but here is our advice to see if it is ready for you.

 

Thank you so much Patrick! :6_smile:

Share this post


Link to post
Share on other sites

It doesn't work for me either.

I am running Windows 10 and have Publisher, Designer and Photo each at version 1.7.1.404.  Each has been run several times. 

When I click the photo persona I get a StudioLink message that tells me that Photo is not installed.  Designer linked correctly.

image.png.899ca5f8241f8e5a40d61634db06c48a.png

I have uninstalled all the beta versions and uninstalled Publisher and Photo then reinstalled everything. Still the same message.

Share this post


Link to post
Share on other sites
Posted (edited)
28 minutes ago, Frozen Death Knight said:

It's free to update to 1.7.1 if you own any previous versions, which you need to activate the Personas in Publisher. Just download and install them and you're good to go! : D

Thanx – but I don't know how to download, haha.

I try ;)

So great!

Edited by Sabine 108
It works!

Share this post


Link to post
Share on other sites

For me, the following suggesting made in another thread solved the problem:

I'm note sure how to reference other threads so here is the text:

"C:\ProgramData\Affinity\Common\1.0\appinfo\Release delete the .appinfo files there and redo the open and close of the newly installed Photo & Designer apps. "

Thank you @drkanukie

Share this post


Link to post
Share on other sites
7 minutes ago, RobW42 said:

For me, the following suggesting made in another thread solved the problem:

I'm note sure how to reference other threads so here is the text:

"C:\ProgramData\Affinity\Common\1.0\appinfo\Release delete the .appinfo files there and redo the open and close of the newly installed Photo & Designer apps. "

Thank you @drkanukie

IT WORKED!!

Thank you Rob!

 

Share this post


Link to post
Share on other sites

I had the same problem. In my case switching personas out of Photo, then opening the Photo app, and then trying the Photo persona again resolved the issue.

Share this post


Link to post
Share on other sites

Initially, the link to Designer didn't work for me either.  I had purchased both Designer and Photo from the Mac App Store.  So first I closed all apps.  Uninstalled Designer.  And then re-installed it by downloading the latest version from the Mac App Store.  Opened Publisher and created a new document.  Created a shape using Publisher tools.  Then I clicked on the Designer Persona & VOILÀ: Designer!  Switched to Photo Persona and back again.  No muss, no fuss!  Beautiful job, you guys!

Share this post


Link to post
Share on other sites

@makkuro

Welcome to the Serif Affinity forums :) Glad you got it working. Hope you enjoy the software.

Uninstallling and reinstalling in the Mac App Store almost always forces the new build onto the computer even if you are not offered it in the available "Updates".


Patrick Connor

Serif (Europe) Ltd.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×