Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

StudioLink doesn't work (macOS)


Recommended Posts

  • Moderators

Thanks Antony, not sure what changed. Usually running the updated 1.7.1 is sufficient. Restarting is not part of our arsenal of answers for macOS because that should not help, so  I'm confused but pleased for you.

Patrick Connor
Serif Europe Ltd

"There is nothing noble in being superior to your fellow man. True nobility lies in being superior to your previous self."  W. L. Sheldon

 

Link to comment
Share on other sites

22 hours ago, Patrick Connor said:

Are your Mac App Store Designer and Photo installed in the Applications folder? If not can you try moving them ther and running them again. 

That is exactly it! If you want custom folders with your favourite applications, don't move the apps but consider using aliases (drag with Command-Option pressed). Much safer and it avoids automation, linking and updating problems.

-- 
Mark Stoutjesdijk

CLKZ-logo-OB-32.png.98fafb7f7564b4dc900254fd73f18402.png CARELINKZ Healthcare Analytics 

Link to comment
Share on other sites

7 minutes ago, MMetzger said:

Remember, I am using Windows 10.

But ... you’ve posted to a macOS thread! Try here:

 

Alfred spacer.png
Affinity Designer/Photo/Publisher for Windows 1.10 • Windows 10 Home/Pro
Affinity Photo for iPad 1.10 • Designer for iPad 1.10 • iPadOS 15.6.1 (iPad Air 2)

Link to comment
Share on other sites

Hi Everyone, I reported this problem first yesterday. I was also annoyed but there is a simple fix.  If you bought Designer or Photo from the Mac Store then you need to be aware that the store doesn't immediately update the apps.  There is a seven day update cycle (you can change this frequency with a Terminal command - but still you have to wait a day).  Best solution, and what I did, was to delete the apps and then reinstall from the Mac store. A tiny bit of a hassle but then all will work. 

Link to comment
Share on other sites

Finally! 3 programs are now lined! Thanks for the update.

---------------------
Saying with a loud voice, "Fear God, and give glory to Him; for the hour of His judgment is come: and worship Him that made heaven, and earth, and the sea, and the fountains of waters." (Revelation 14:7)

他大聲說:「應當敬畏神,將榮耀歸給祂!因祂施行審判的時候已經到了。應當敬拜那創造天地海和眾水泉源的。」(啟14:7)

---------------------

Link to comment
Share on other sites

I am having this issue as well. I purchased Affinity Designer on the mac store and I have recently purchased Affinity Photo and Publisher on the Affinity Serif site (as this way I have the product keys so I can use future beta versions). Affinity photo shows up in the studio link pop-up menu, but It says that I have not purchased Affinity Designer... What do I do? My Affinity Designer application has recently updated to the newest update, version 1.7.1.

 

Image 6-22-19 at 1.14 AM.jpg

Link to comment
Share on other sites

I've found you must first load the new 1.7.1. Designer and Photo, then load Publisher before the linking is updated and live. It makes sense seeing as updated plist files in one's private library user path won't get updated with the new version of 1.7.1 of either Photo or Designer making them invisible to Publisher.

Link to comment
Share on other sites

14 hours ago, mdriftmeyer said:

I've found you must first load the new 1.7.1. Designer and Photo, then load Publisher before the linking is updated and live. It makes sense seeing as updated plist files in one's private library user path won't get updated with the new version of 1.7.1 of either Photo or Designer making them invisible to Publisher.

Can you elaborate on that? Which path and plist files are you referring to? In the Library I can only find Crash Reports...

thank you

Link to comment
Share on other sites

23 hours ago, Mattia Gentili said:

Can you elaborate on that? Which path and plist files are you referring to? In the Library I can only find Crash Reports...

You really should not have to deal with any plist files. Just launch Photo and Designer and close them again and then launch Publisher. Normally this should do the trick.

  • Main machine: iMac 2019 (21,5-inch 4k, 6core), 64GB RAM, 1TB nvme + 2TB ssd, running on MacOS 12;
  • Display setup: 28" 5k Display (primary) + 21,5" iMac4k-Display for studio panels (secondary);
  • Keyboard layout: german apple extended keyboard (aluminium);

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.