Jump to content
gyohng

StudioLink doesn't work (macOS)

Recommended Posts

22 hours ago, Patrick Connor said:

Are your Mac App Store Designer and Photo installed in the Applications folder? If not can you try moving them ther and running them again. 

That is exactly it! If you want custom folders with your favourite applications, don't move the apps but consider using aliases (drag with Command-Option pressed). Much safer and it avoids automation, linking and updating problems.


-- 
Mark Stoutjesdijk

CLKZ-logo-OB-32.png.98fafb7f7564b4dc900254fd73f18402.png CARELINKZ Healthcare Analytics 

Share this post


Link to post
Share on other sites

Remember, I am using Windows 10.  All three programs are located in the "Affinity" folder under "Program Files" on my C: drive.

Thanks,

Mike

Share this post


Link to post
Share on other sites
7 minutes ago, MMetzger said:

Remember, I am using Windows 10.

But ... you’ve posted to a macOS thread! Try here:

 


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.3.481 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.7.3.155 • Designer for iPad 1.7.3.1 • iOS 12.4.1 (iPad Air 2)

Share this post


Link to post
Share on other sites

Hi Everyone, I reported this problem first yesterday. I was also annoyed but there is a simple fix.  If you bought Designer or Photo from the Mac Store then you need to be aware that the store doesn't immediately update the apps.  There is a seven day update cycle (you can change this frequency with a Terminal command - but still you have to wait a day).  Best solution, and what I did, was to delete the apps and then reinstall from the Mac store. A tiny bit of a hassle but then all will work. 

Share this post


Link to post
Share on other sites

I am having this issue as well. I purchased Affinity Designer on the mac store and I have recently purchased Affinity Photo and Publisher on the Affinity Serif site (as this way I have the product keys so I can use future beta versions). Affinity photo shows up in the studio link pop-up menu, but It says that I have not purchased Affinity Designer... What do I do? My Affinity Designer application has recently updated to the newest update, version 1.7.1.

 

Image 6-22-19 at 1.14 AM.jpg

Share this post


Link to post
Share on other sites

I've found you must first load the new 1.7.1. Designer and Photo, then load Publisher before the linking is updated and live. It makes sense seeing as updated plist files in one's private library user path won't get updated with the new version of 1.7.1 of either Photo or Designer making them invisible to Publisher.

Share this post


Link to post
Share on other sites
14 hours ago, mdriftmeyer said:

I've found you must first load the new 1.7.1. Designer and Photo, then load Publisher before the linking is updated and live. It makes sense seeing as updated plist files in one's private library user path won't get updated with the new version of 1.7.1 of either Photo or Designer making them invisible to Publisher.

Can you elaborate on that? Which path and plist files are you referring to? In the Library I can only find Crash Reports...

thank you

Share this post


Link to post
Share on other sites
23 hours ago, Mattia Gentili said:

Can you elaborate on that? Which path and plist files are you referring to? In the Library I can only find Crash Reports...

You really should not have to deal with any plist files. Just launch Photo and Designer and close them again and then launch Publisher. Normally this should do the trick.


  • Production-System: iMac (21,5-inch, Late 2013), 16GB RAM, 2TB nvme-SSD, running on 10.14.5 Mojave;
  • Display Setup: 27" Thunderbolt Display primary + 21,5" iMac-Display secondary for palettes;
  • Keyboard-Layout: German apple extended keyboard (aluminum);

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.