Jump to content

Recommended Posts

After updating to 1.7.1 the using of this awesome program drives me crazy. Everything is so slowly now. Where is the announced speed improvement? The lagging of program is almost in seconds in every step :(

Share this post


Link to post
Share on other sites

CPU usage when in dragging around 50%, in the heavy scene I see a full load.

actually, I changed everything in the performance tab but doesn't work. I know I haven't a good spec but lagging with drag 1 rectangle?

in pixel persona i see a less lag.

Annotation 2019-06-20 212649.jpg

Annotation 2019-06-20 212649.jpg

Edited by sadeqi
better explain

Share this post


Link to post
Share on other sites

I just wanted to chime in that I have the same problem as shown in the video by sadeqi. When I run Pixel Persona, the problem disappears. 

I'm running Windows 10, Intel i7 8700k, Nidvia GTX 1070 (8gb memory), 32 gb system memory. All running on a SSD drive.

My settings are on Auto but it doesn't matter which settings I use, they all act the same. I even turned down my undo limit to 105 to see if that would help but it didn't.

Share this post


Link to post
Share on other sites

I have the same problem when moving different objects.

The problem does not occur with Affinity Photo and Affinity Publisher.

Retina-Rendering: Automatic

Share this post


Link to post
Share on other sites

I fixed my problem by going to the performance options and choosing my GPU.

Under "Renderer" it says "Default (Nividia GTX 1070 or whatever your GPU is)". Select your GPU, not the "Default". You might need to restart the program. I also lowered my undo options to 105. Retina options are set to "Automatic".

Hope this helps others!

Share this post


Link to post
Share on other sites

Hi. 

Problem: 

I have noticed that when the APPEARANCE panel is directly visible, operations like moving/resizing object or moving nodes become choppy. 

Solution that worked for me:

Hiding APPEARANCE panel completely or placing it "behind" another panel tab.  

 

My system: 

Affinity Designer 1.7.1.404

Windows 10

Changing GPU settings (from AMD Radeon to integrated Intel GPU) does not make any difference. 

 

BAD.png

OK.png

Share this post


Link to post
Share on other sites
7 hours ago, p.wojda said:

Hi. 

Problem: 

I have noticed that when the APPEARANCE panel is directly visible, operations like moving/resizing object or moving nodes become choppy. 

Solution that worked for me:

Hiding APPEARANCE panel completely or placing it "behind" another panel tab.  

 

My system: 

Affinity Designer 1.7.1.404

Windows 10

Changing GPU settings (from AMD Radeon to integrated Intel GPU) does not make any difference. 

 

BAD.png

OK.png

Can confirm this behaviour, also putting vectors inside groups (which makes appearences disappear) improves performance

Share this post


Link to post
Share on other sites

@Mark Ingram

In conclusion, it certainly seems that an active appearance studio slows the performance considerably. 

A fix will be a great candidate for the 1.7.2 or 1.7.3 update.

Share this post


Link to post
Share on other sites

I tested it and was surprised by the performance difference. In the GIF animation (24FPS), the difference is small but really noticeable.

Tested on:

- Microsoft Windows 7 Enteprise x64 (6.1.7601 Service Pack 1):
HP EliteBook 8760w / 32,0GB RAM | Intel(R) Core(TM) i7-2860QM | NVIDIA Quadro 3000M / 2GB DDR5

ap_windows_perf_test.thumb.gif.43d96a4ba1d7ff7a3f92b85a490033d0.gif

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.