Jump to content
WhiteX

1.7.1 Designer crashes when opening Brushes Panel (Solved)

Recommended Posts

Hello,

Great work on the new Designer / Photo release @affinity!

I have a bug in Designer stable and beta (1.7.1.404), when I try to open / activate the Brushes Panel the app crashes instantaneously. I had this problem earlier too, but was relieved when I saw it fixed in the previous release (1.7.0.367). Now it's back. I had the same problem with Photo too. Now Photo won't launch at all (since the Brush panel is open by default I think, so resetting the Studio does not help). Yes, I tried removing all third party brushes, and as I said previous release worked without any problems.

Any help is appreciated. (How do I roll back my active Designer / Photo instance to an earlier version? Simply uninstall and reinstall using the previous installer?)

Thanks!

Share this post


Link to post
Share on other sites

Unfortunately using outdated versions of Designer and Photo breaks Studio Link in Publisher... so any help would be appreciated. Does anyone experience the same problem as me? (Designer / Photo crashes when Brushes panel is activated). Thanks.

Share this post


Link to post
Share on other sites
17 minutes ago, Mark Ingram said:

What is that? 100%, 150%, etc?

 

10 hours ago, WhiteX said:

@Mark Ingram It is the default setting for a Full HD monitor (100%). I haven't upgraded on my other devices because of this crash.

 

Share this post


Link to post
Share on other sites

@Mark Ingram do you have any suggestions that I can try? Resetting the app and reinstalling does not help. Thanks.

Update:

On my macbook pro the brush panel works in every app (on Win 10 - scaling 200% - latest builds). I was able to save the file that stores the studio panel preferences and copy it to my other windows machine (100% display scale). I was able to open the apps without crash on start, since in the settings file the brush panel wasn't in opened state, but whenever I try to open it (the Brushes panel), the apps crashes. Even from publisher, it crashes if I try to use the studio link feature.

Share this post


Link to post
Share on other sites

@Sean P For some reason I did not get the notification about your message. Here's a zip, it happens on a clean install too. Designer and Photo crashes when I try to open brushes panel, also Photo crashes on clean install now, but that's for a different topic I guess. Brush tool works, I'm just not able to select brushes, which kind of renders the app useless when working with rasters (more of a Photo problem, again).

Thank you for your help.

Edit:

It's worth mentioning that I'm on a completely different PC system now, previously it was an intel based system with a GTX 650 Ti, now it's an AMD based system with a GTX 1080. The common thing is only the GPU manufacturer (nVidia), this might give a clue about the nature of the problem. Monitor scaling is 100%.

1.0.zip

Share this post


Link to post
Share on other sites

Thanks for that file. I'm also using a GTX 1080 here and still have not encountered the issues you are getting. 

With that said I can see in your crash report that you're using Stardock's Groupy. Could you try uninstalling that and seeing if that stops the crashing you're getting? Do you have any other applications installed that are running at start up, or any major customisation that you may have done to Windows?

Share this post


Link to post
Share on other sites

Good to see it works with nVidia cards.  I uninstalled Groupy, restarted the system, closed all the apps that run at system start, but it still makes the app crash if I select the Brushes panel.

 

1.0.zip

Share this post


Link to post
Share on other sites

Ahh that's a shame! Would you be able to try the following for me please so I can get a bit more information from your crash reports. 

Go to C:\Program Files\Affinity\Designer\ and open the Designer.exe.config file inside a text editor. Could you add the following line between the <runtime></runtime> section of the file:

<ZapDisable enabled="1" />

This should make your file look similar to this:DesignerConfig.jpg

Once that has done, could you run Designer up and make it crash. After crashing go back to %APPDATA%\Affinity\Designer\1.0\CrashReports\reports and attach the most recent crash report that corresponds to the time that you crash.

This will hopefully give a bit more information into the crash report!

What software have you installed on your new machine that you would have had on the other machine? I'm wondering if its happening due to some other software installed (hence the suggestion regarding Groupy).

Thanks

Share this post


Link to post
Share on other sites

Sure, I did that, thanks for your help. You can find the new report attached.

Actually the problem started way before I even tried Groupy - which is actually very handy btw -, I use Chrome, WhatsApp, VS Code, Adobe XD, Microsoft Office 365 apps, Suitcase Fusion, the nVidia Driver and Geforce Experience app, but some of these aren't installed on my laptop (Macbook Pro with Win 10) and I experience the same problem there too. 

e8db72e7-55fe-45fd-a3c9-1066ca9d390a.dmp

Share this post


Link to post
Share on other sites

Hi WhiteX,

Thanks for the DMP file, looking at it the crash is happening in Windows.NET, rather than our application. I would suggest you try running Microsoft's .NET Framework repair tool found here:

https://support.microsoft.com/en-gb/help/2698555/microsoft-net-framework-repair-tool-is-available

If that doesn't work, it would be worth installing/reinstalling the latest version of .NET from Microsoft to see if that helps.

Share this post


Link to post
Share on other sites

Thanks @Sean P, apparently the repair tool did the trick. I'll just run it if the problem will re-appear. Thanks for the other tips too. (If you could mark the topic as solved, that would be a big help to others, I'm unable to edit the title of the topic.)

Thanks again!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.