Jump to content

Recommended Posts

After doing the new update, I can't seem to open a new document with out the program freezing and crashing. Whether hitting 'new doc' on the opening screen or through File/New Doc it just stops working and I can't click on anything else. No error code or anything either. I have to force it to close.

Anyone else have this problem or know how to fix it?


Link to comment
Share on other sites

What OS do you use?

Does it work if you open an existing image file?


-- Walt

Desktop:  Windows 11 Home, version 22H2 (22621.1413) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 
Laptop:  Windows 10 Home, version 21H2 (19044.2728) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
        Affinity Photo 1.10.6 (.1665) and 2.1.0 and 2.1.0. beta/ Affinity Designer 1.10.6 (.1665)  and 2.1.0  and 2.1.0 beta / Affinity Publisher 1.10.6 (.1665)  and 2.1.0  and 2.1.0beta
iPad Pro M1, 12.9", iPadOS 16.4.1 (a), Apple Pencil 2, Magic Keyboard

      Affinity Photo 1.10.7 and 2.1.0 and 2.1.0 beta/ Affinity Designer 1.10.7 and 2.1.0 and 2.1.0 beta/ Affinity Publisher 2.1.0 and 2.1.0 beta

Link to comment
Share on other sites

It also happens if I click to go to document setup... In order to create a new document, I opened an existing one, deleted the layers and then tried to go to document setup to change the size, but this has led to freeze/crashing as well. Really frustrating!!!

Link to comment
Share on other sites

  • Staff

Try resetting the app, hold down the CTRL key and open, when the window appears, release the key and click Clear. If this doesn't have an affect, try uninstalling the app, restarting Windows and then installing the app again.

Link to comment
Share on other sites

  • 1 year later...

I'm not getting off to a good start changing from Xara Graphics Designer to Affinity Designer!

I can't start a new document and I can't open a file either, both situations end up in AD hanging and having to be closed.

I have tried starting it as administrator and I have cleared all preferences af suggested above, no luck. Strange thing is that sometimes (rarely) it does work but mostly not. I just installed the update, no changes. The laptop is a freshly installed Dell M4500 with a new Windows 10.

Strangely enough, my other laptop, a Dell 4700, works perfectly and has had no issues at all!


Link to comment
Share on other sites

  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.