Jump to content

Recommended Posts

Hello my Affinity Designer 1.7.0.367 runs very very slow. The reaction after every mouse click takes several seconds. I can not work with it anymore.

I use Windows 10 - 64 on a core i7 3770k with 16 GB ram and ssd / Radeon RX Vega 56 / UHD monitor with 115% scale.

After starting Designer, the splash-screen don't closes automaticly. The cpu-usage in the taskmanager goes up.

A reinstallation had no effect.

On the system I use Photo and Publisher (beta) - both on 1.7.x on HDD - Photo und Publisher .Both run at the usual speed - both very fast!

I notice that in %appdata%/.../Affinity/ are directorys for "Common", "Photo" and "Publilsher" - but  not for "Designer". 

Do you have any idea what I could do?

BG

ArWi

Share this post


Link to post
Share on other sites

I'm having the same issue.

I just bought Affinity Designer after watching all the improvements that came with version 1.7, never used it before.

I was very dissapointed with the performance even with small files.

My PC configuration is: Intel 4790K 4 cores 4Ghz. - 16GB of RAM - Nvidia Geforce GTX 1080 - 256GB SSD - Windows 10 64

 

Share this post


Link to post
Share on other sites

You may see an improvement if you switch off snapping, especially on large files that slow to a crawl


Mac Pro Cheese-grater (Early 2009)
2.93 GHz 6-Core Intel Xeon
48 GB 1333 MHz DDR3 ECC Ram
NVIDIA GeForce GT 630 - 2 GB
Ugee 19" Graphics Tablet Monitor
Mac OS 10.11.6 El Capitan

Affinity Designer, Photo and Publisher 1.7.1 + Betas when available

Binger.jpg.1f81574106cc2dea8ae65d0a572b9ef9.jpg
www.bingercreative.co.uk

Share this post


Link to post
Share on other sites

Hi ArWi,

Welcome to the forums :)

On 6/15/2019 at 8:07 AM, ArWi said:

After starting Designer, the splash-screen don't closes automaticly. The cpu-usage in the taskmanager goes up.

Are you referring to the Welcome screen (seen below)? This isn't designed to automatically close unless a document is opened or created.
image.png

On 6/15/2019 at 8:07 AM, ArWi said:

I notice that in %appdata%/.../Affinity/ are directorys for "Common", "Photo" and "Publilsher" - but  not for "Designer". 

Did you install Designer onto a different HDD/SSD than your other Affinity Applications? If you've installed all apps on your C drive then your app data for Designer should be here.

I recommend trying a clean uninstall, then re-downloading the latest EXE and installing this again to try and help your performance issues. Please use the following Microsoft uninstaller tool to remove Affinity Designer and let me know if this helps.

https://support.microsoft.com/help/17588/windows-fix-problems-that-block-programs-being-installed-or-removed

https://store.serif.com/update/windows/designer/1/
 

Hi @Jorge Domínguez,

Welcome to the Affinity forums also!

Please try following the reset procedure below and let me know if this helps with your system performance :)

You can reset your app back to its default settings by holding down the CTRL key while launching the app. When the Clear User Data window appears, click Select All and then Clear. The app will now open.

Be aware that resetting your app back to its default settings will lose any custom settings such as keyboard shortcuts and brushes etc. To backup such settings before resetting the app, please watch our Affinity - Exporting User Settings and Keyboard Shortcuts video. https://vimeo.com/189596577

Share this post


Link to post
Share on other sites

Hello Dan C,

thank you very much - but ist seems to bei complicated.
 

When I deinstall Designer with the MS-tool and reinstall from https://store.serif.com/update/windows/designer/1/ then Designer works with fast speed without any problems.

But I bought Designer form the Microsoft Store - so that I do not have licence-key for Designer (Photo and the supscriton of Publisher directly from Serif).

So in this way I could run Designer only for a try-periode. That's why I uninstalled Designer again and reinstalled it from Microsoft-Store. After that I have the same problems again. Designer is very very slow.

The problem seems to be connected to the installation of the MS-Store.

Can I somehow determine the license number of my designer bought in the MS-Store?

Incidentally,% AppData% was empty even though I had C installed. Maybe this is also related to the installation via the MS-Store.

I did not mean the welcome screen. I mean this splash-screnn which ist shown wenn Designer ist starting. This screen closes only after a few minutes automatically. Normaly it should close automatically when Designer has been started.

Designer1.png.23036fbb1ece06362b1b2b6546d0856f.png

@Dazmondo77 thank you too - but it not depends on snapping

BG

ArWi

 

Share this post


Link to post
Share on other sites

Hello @Dan C thanks for the answer.

Sadly, the procedure didn't work at all :( I've just updated my Affinity Designer to the 1.7.1ver but still it looks choppy and with some kind of lag.

By not having any kind of solution, I've downgrade it to 1.6.5ver and altough it runs better, it still looks and feel slow.

So I've decided to look my Task Manager and the CPU went to the roof everytime I move a object... This doesn't seem normal at all.

What's the problem?

Capture.JPG

Share this post


Link to post
Share on other sites

I'm sorry to hear this. We're working on improving Affinity version 1.7 for Windows users.

On 6/19/2019 at 12:44 AM, Jorge Domínguez said:

So I've decided to look my Task Manager and the CPU went to the roof everytime I move a object... This doesn't seem normal at all.

This is to be expected, as our devs have confirmed in the following thread, we have written Affinity to use whatever resources are available at the time.

 

 

Share this post


Link to post
Share on other sites

Hello Dan C,

Designer my use all ressources - that is o.k. but not my point. 

In the moment I can't use Designer in any way.

The reactiontime on each mouseklick takes 3-5 seconds. Even ehen no working-file is loades and I only make a klick on the menue this also takes 3-5 seconds to react on this klick.

What can I do? Deinstallation an reinstallation I tryed...

BG

ArWi

Share this post


Link to post
Share on other sites

How many fonts do you have installed?

@ArWi, waiting 3-5 seconds for a mouse click on a menu is not normal behaviour. Are you saying the version installed from the MS Store is slow, but the other products installed from our store are quick?

Share this post


Link to post
Share on other sites

Hello Mark,

yes, Designer installed from MS Store is very very slow. Designer installed form affinity-download ist fast. But I bought Designer from MS Store and so I coult user Designer from affinity-download only for a limited time as a try-version.

Other programs from the MS Store run normaly.

I don't know how many fonts in my windows-installation are. But there are the some fonts when running Designer from the MS Store (extremly slow) and form affinity-download (in fast speed). I also use Affinity Photo and Affinity Publisher - both directly from Affinity bought. The are both running fast.

So I think it has nothing to do with ithe fonts. Designer ist extremly slow also when I habe opened no document. 

BG

ArWi

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×