Jump to content

Recommended Posts

I saw that this was reported in the iPad section, but just wanted to report here that it is in Windows version as well.

 

s1.thumb.jpg.668e6b5bb423318d8a98ac5b9ac1058c.jpg

s2.thumb.jpg.c1974d367ddfa4e8f1d3a992415145da.jpg

Microsoft Windows 10 Home (Build 19041)
AMD Ryzen 5 3600 @ 3600Ghz; Mobo: Asus X470-PRO
32GB DDR4 (3000Mhz)
NVIDIA GeForce GTX 1060Ti 6GB
Monitor 1: 4K @ 150%
Monitor 2: 4K @ 200%

WACOM Intuos4 Large; X-rite i1Display Pro; NIKON D5600 DSLR

Link to post
Share on other sites
9 hours ago, raglet said:

Don't hold your breath for this fix @debraspicher. This issue was reported over 2 years ago and there's no sign of it being even considered let alone fixed. All I've heard since I reported it is a message like this from the moderators saying that it's a known issue and that it's been passed on to the dev team. 

 

Nice..

Microsoft Windows 10 Home (Build 19041)
AMD Ryzen 5 3600 @ 3600Ghz; Mobo: Asus X470-PRO
32GB DDR4 (3000Mhz)
NVIDIA GeForce GTX 1060Ti 6GB
Monitor 1: 4K @ 150%
Monitor 2: 4K @ 200%

WACOM Intuos4 Large; X-rite i1Display Pro; NIKON D5600 DSLR

Link to post
Share on other sites
On 6/13/2019 at 10:30 AM, raglet said:

Don't hold your breath for this fix @debraspicher. This issue was reported over 2 years ago and there's no sign of it being even considered let alone fixed. All I've heard since I reported it is a message like this from the moderators saying that it's a known issue and that it's been passed on to the dev team. 

 

I just got a similar thing I believe with  it being inaccurate. Some points are made correctly some are changed to points that don't match the shape. The tips of my paths aren't expanding and matching the shape with curves. What are you guys doing to work around this or should I refund my purchase? 2 years is quite a long time for a bug. 

 

2019-06-14 12_43_07-Affinity Designer.png

2019-06-14 12_35_46-Affinity Designer.png

Link to post
Share on other sites

Yeah it's unfortunate it has taken this long to correct the feature. I'm not usually keen to complain, but Expand Stroke is such a major feature for shape-building. It's part of my "typical" workflow. I tend to keep my simpler designs for Affinity Designer and anything super complex, I do in Illustrator because I tend to run into too many bugs or limitations. I still prefer Designer as Illustrator is getting rather slow & clunky.

Microsoft Windows 10 Home (Build 19041)
AMD Ryzen 5 3600 @ 3600Ghz; Mobo: Asus X470-PRO
32GB DDR4 (3000Mhz)
NVIDIA GeForce GTX 1060Ti 6GB
Monitor 1: 4K @ 150%
Monitor 2: 4K @ 200%

WACOM Intuos4 Large; X-rite i1Display Pro; NIKON D5600 DSLR

Link to post
Share on other sites
On 6/14/2019 at 11:24 PM, debraspicher said:

Yeah it's unfortunate it has taken this long to correct the feature. I'm not usually keen to complain, but Expand Stroke is such a major feature for shape-building. It's part of my "typical" workflow. I tend to keep my simpler designs for Affinity Designer and anything super complex, I do in Illustrator because I tend to run into too many bugs or limitations. I still prefer Designer as Illustrator is getting rather slow & clunky.

Yes, I agree. I hate complaining too and it's quite pissing off when people think they're entitled to new features from software companies. However, the reason I think this is different is the lack of any information, for over 2 years, about a critical feature that this company proudly claims on their sales page.

 

Screen Shot 2019-06-17 at 7.03.39 AM.png

Link to post
Share on other sites

Heya... I know many of you have heard this workaround a few times, but others haven't: the warped stroke expansion happens when you're working at a small scale (10s of pixels wide). If you do your initial drafting at a larger size and then export at your target size, you'll get the correct results.

As an example workflow, if you're designing a 64x64 icon, setup your artboard as 640x640px with grid lines every 10px. Draw as you normally would (but y'know large), and when your icon is ready to go, hop into the Export Persona, set the slice's output to 64w and voila! The exact small graphic you were trying to draw.

I know this bug is impacting a lot of your ability to use Affinity Designer, but as with a lot of techniques when we're coming from Illustrator, you have to work a slightly different way here. In this case, AD prefers to draft at larger scales. But like... that's why we work in vector, right? One of the big reasons, at least. It's scalable. We draw on an arbitrary artboard and spit out final graphics that are 10 pixels wide or 30 feet wide.

Hope this helps someone. I think this program is super rad. :)

Link to post
Share on other sites
On 6/18/2019 at 10:28 AM, CJ Randolph said:

Heya... I know many of you have heard this workaround a few times, but others haven't: the warped stroke expansion happens when you're working at a small scale (10s of pixels wide). If you do your initial drafting at a larger size and then export at your target size, you'll get the correct results.

As an example workflow, if you're designing a 64x64 icon, setup your artboard as 640x640px with grid lines every 10px. Draw as you normally would (but y'know large), and when your icon is ready to go, hop into the Export Persona, set the slice's output to 64w and voila! The exact small graphic you were trying to draw.

I know this bug is impacting a lot of your ability to use Affinity Designer, but as with a lot of techniques when we're coming from Illustrator, you have to work a slightly different way here. In this case, AD prefers to draft at larger scales. But like... that's why we work in vector, right? One of the big reasons, at least. It's scalable. We draw on an arbitrary artboard and spit out final graphics that are 10 pixels wide or 30 feet wide.

Hope this helps someone. I think this program is super rad. :)

Hi @CJ Randolph, while the scale does make things a little better it is still most certainly not pixel perfect. As you can see in the attached image, which is a 640px x 640px canvas, the red expanded stroke does not line up perfectly with the black original stroke below it. There's seems to be a fundamental issue with the way the software goes about converting strokes to fills.

Screen Shot 2019-06-21 at 10.51.31 AM.png

Link to post
Share on other sites

This bug has been reported in Designer 1.6 as far as November 3rd, 2017. Since then, nothing has changed. In this post I even compared different vector drawing software with Affinity Designer (Adobe Illustrator, Corel Draw, and the opensource Inkscape). All perform way better than Designer at expanding strokes... :(

Link to post
Share on other sites
5 hours ago, raglet said:

Hi @CJ Randolph, while the scale does make things a little better it is still most certainly not pixel perfect. As you can see in the attached image, which is a 640px x 640px canvas, the red expanded stroke does not line up perfectly with the black original stroke below it. There's seems to be a fundamental issue with the way the software goes about converting strokes to fills.

Screen Shot 2019-06-21 at 10.51.31 AM.png

I don't want to make icons that are blurry so pixel perfect accuracy is a must. They do market for icons and pixel perfect accuracy so this is still disappointing.

 

The suite is meant to work together from what I understand, and I don't want/need to depend another program to do this (Inkscape, etc).

Link to post
Share on other sites
On 6/17/2019 at 1:08 AM, raglet said:

Yes, I agree. I hate complaining too and it's quite pissing off when people think they're entitled to new features from software companies. However, the reason I think this is different is the lack of any information, for over 2 years, about a critical feature that this company proudly claims on their sales page.

  

Screen Shot 2019-06-17 at 7.03.39 AM.png

Yes! Pixel hinting is so important to achieve a professional look. Not achieving this, it's not a finished work in my opinion. To go this long without a fix is not good.

Microsoft Windows 10 Home (Build 19041)
AMD Ryzen 5 3600 @ 3600Ghz; Mobo: Asus X470-PRO
32GB DDR4 (3000Mhz)
NVIDIA GeForce GTX 1060Ti 6GB
Monitor 1: 4K @ 150%
Monitor 2: 4K @ 200%

WACOM Intuos4 Large; X-rite i1Display Pro; NIKON D5600 DSLR

Link to post
Share on other sites

Designer 1.7.1

I created a file that clearly shows the amount of inaccuracy after expanding strokes.

I took white icons and grouped them on a black background. I duplicated the group on top of the first one, painted it black, and expanded strokes. The white color of the original, non-expanded icons that is visible, shows the difference between expanded and non-expanded.

Each icon is about 40x40 pixels.

The original afdesign file is attached to this post.

icons.afdesign

icons.png

Link to post
Share on other sites
1 hour ago, Molumen said:

Designer 1.7.1

I created a file that clearly shows the amount of inaccuracy after expanding strokes.

I took white icons and grouped them on a black background. I duplicated the group on top of the first one, painted it black, and expanded strokes. The white color of the original, non-expanded icons that is visible, shows the difference between expanded and non-expanded.

Each icon is about 40x40 pixels.

The original afdesign file is attached to this post.

icons.afdesign

icons.png

Strangely enough I just tried to expand stroke on the original group in that file. It produced what appeared to be accurate results. I captured it on video and the result was within the first 12-18 seconds... the menu is hidden in the overlay, I am using Windows Game recorder... I tried a few more times

Microsoft Windows 10 Home (Build 19041)
AMD Ryzen 5 3600 @ 3600Ghz; Mobo: Asus X470-PRO
32GB DDR4 (3000Mhz)
NVIDIA GeForce GTX 1060Ti 6GB
Monitor 1: 4K @ 150%
Monitor 2: 4K @ 200%

WACOM Intuos4 Large; X-rite i1Display Pro; NIKON D5600 DSLR

Link to post
Share on other sites
17 minutes ago, debraspicher said:

Strangely enough I just tried to expand stroke on the original group in that file. It produced what appeared to be accurate results. I captured it on video and the result was within the first 12-18 seconds... the menu is hidden in the overlay, I am using Windows Game recorder... I tried a few more times

 

I tried on a simple circle on a document of 640 x 640 and can still see the inaccuracies. This is zoomed in to see the lower magenta layer peeking out from inaccuracies when you couldn't see it before expanding the stroke with Designer updated to 1.7.1.404. I didn't get a chance to try the file provided, but wanted to try the resolution trick myself.

Still great software.

 

2019-06-22 19_53_56-Affinity Designer.png

2019-06-22 19_53_17-Affinity Designer.png

Edited by Valerian
added version information
Link to post
Share on other sites
9 hours ago, debraspicher said:

Strangely enough I just tried to expand stroke on the original group in that file. It produced what appeared to be accurate results. I captured it on video and the result was within the first 12-18 seconds... the menu is hidden in the overlay, I am using Windows Game recorder... I tried a few more times

 

If you look closely, you'll notice that there is a clearly visible distortion appearing on circular objects when you expand their strokes. It may seem OK from afar, but if you use those icons in an app on a small screen with high pixel density, it'll look veeeeeery bad...

Link to post
Share on other sites
9 hours ago, Valerian said:

I tried on a simple circle on a document of 640 x 640 and can still see the inaccuracies. This is zoomed in to see the lower magenta layer peeking out from inaccuracies when you couldn't see it before expanding the stroke with Designer updated to 1.7.1.404. I didn't get a chance to try the file provided, but wanted to try the resolution trick myself.

Still great software.

 

2019-06-22 19_53_56-Affinity Designer.png

2019-06-22 19_53_17-Affinity Designer.png

Designer is indeed a great software, but it is still not suitable for pixel-perfect work

Link to post
Share on other sites
13 hours ago, Molumen said:

If you look closely, you'll notice that there is a clearly visible distortion appearing on circular objects when you expand their strokes. It may seem OK from afar, but if you use those icons in an app on a small screen with high pixel density, it'll look veeeeeery bad...

Yeah there's definitely a shift in the line when making the move to expansion. I was expecting a more dramatic result like your image which is why I was confused at first. It's slight, but there's enough that it changes the weight of the line that it appears accurate, but it's not acceptable for achieving any kind of pixel-hinted look. (i.e. professional) I noticed this when working in my own designs and manipulating your file. If it were just a padding issue, would be at least workable, but the paths themselves are being misinterpreted.

Microsoft Windows 10 Home (Build 19041)
AMD Ryzen 5 3600 @ 3600Ghz; Mobo: Asus X470-PRO
32GB DDR4 (3000Mhz)
NVIDIA GeForce GTX 1060Ti 6GB
Monitor 1: 4K @ 150%
Monitor 2: 4K @ 200%

WACOM Intuos4 Large; X-rite i1Display Pro; NIKON D5600 DSLR

Link to post
Share on other sites
  • 3 months later...
  • 4 months later...
  • 7 months later...
On 10/1/2020 at 6:09 PM, Artcraft said:

no its not accurate at all, DIN A4, 300 dpi, big image, strong deformation.

If you need a workaround to get the job done, temporarily reduce the document PPI from 300 to 30 so that objects' dimensions measured in pixels are reduced by a factor of 10, do the stroke expansion, and then restore the PPI to the required 300.

Affinity apps appear to use pixel as the unit of measure under the hood, so the workaround will provide an additional decimal place of precision in floating-point calculations.

Link to post
Share on other sites
  • 2 months later...

Hi, I am also here to add another extra vote to this issue because it just happend to me as well.
I am following the Affinity Designer Workbook project Lace Frame Galleries 1, and when preparing the Distressed Look version of the logo for export in SVG, the book says the following: 

Quote

If you wish to export the distressed version of the logo, you'll need to use Expand Stroke for all the objects set to Erase blend mode, then add them together before subtracting from the base logo.

When I select the distressed stroke shape and use Expand Stroke, all of the lines become disastrously damaged. 1st image is before expanding the stroke, 2nd image is after the stroke is expanded. Notice how the most damage happens where the stroke pressure varied the most in terms of weight, which was done using the Pressure pop-up panel in the Stroke Panel as the Workbook instructed to do.

image.png.591b757329f4fdfe49615f66f5260c8b.png

image.png.b52a51e2445f154599d35b0d4d1c5c15.png

Excuse me, but let this become first priority for the Development Team as this has been reported years ago. Absolutely disappointing!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.