Jump to content
ea0723

Crash when trying to save file with Index and TOC

Recommended Posts

I have a very long file with images, multiple page masters, embedded images, etc (best way to test! :) ) which crashes randomly (haven't yet been able to determine the exact cause). 

1) I had this happen once, went back to file from 2 days earlier, opened fine, made changes, saved 23 versions of the file without issue (file v23). Next day, opened file v23 (same Publisher version) and tried to do save-as to create v24 - it crashed. Then try to go back to 22, 21, 20... all crash... but didn't crash when I did save-as originally (obviously, because I got to v 23).

2) Can save many other files, no problem.

Save as creates a zero byte file when crashing.

original file still exists with data. Can open, can work on it, also can export (if I am fast enough :) ) but save / save as / autosave all cause crash. 

Tried updating Publisher to latest RC1 (384) but didn't fix the issue.

Can attach crash data as needed (please let me know what you need). Here is beginning of Mac OSX crash log:

Also happy to send you afpub file that is crashing so you can have a look!

Quote

Process:               Affinity Publisher Beta [2288]
Path:                  /Applications/Affinity Publisher Beta.app/Contents/MacOS/Affinity Publisher Beta
Identifier:            Affinity Publisher Beta
Version:               1.7.0 (1.7.0.384)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           Affinity Publisher Beta [2288]
User ID:               501

Date/Time:             2019-06-11 21:10:50.830 -0600
OS Version:            Mac OS X 10.14.4 (18E226)
Report Version:        12
Bridge OS Version:     3.0 (14Y677)
Anonymous UUID:        C5CEC00E-5482-7E46-00C7-9F17E862A471


Time Awake Since Boot: 1300 seconds

System Integrity Protection: enabled

Crashed Thread:        1  Dispatch queue: com.apple.root.default-qos

Exception Type:        EXC_BAD_ACCESS (SIGBUS)
Exception Codes:       KERN_PROTECTION_FAILURE at 0x0000600001849401
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Bus error: 10
Termination Reason:    Namespace SIGNAL, Code 0xa
Terminating Process:   exc handler [2288]

 

Share this post


Link to post
Share on other sites

Hi @ea0723,

Can you please attach the file? Do you remember what build number were you using when you initially started the file? 

Can you replicate the crash from scratch? I'm asking because Build 337 was the last one which converted 1.6 adjustments to 1.7 adjustments automatically. Build 371 introduced the legacy feature, where the adjustment layers from 1.6 and pre-371 are imported as "legacy", keeping their look. If one wants to modify them, they will automatically be converted to new 1.7 adjustments.

Thanks,

Gabe.

Share this post


Link to post
Share on other sites

Hi Gabe, Thanks for your quick reply!

Yes, attached the file (v23) I don't remember which build, but it was before 1.7 (a build of 1.6 I think).

I can't recreate it from scratch ... though I've also been adjusting files that I created around the same time without issue (a lot less complex, though).

 

TRM_for_Print_v23.afpub

Share this post


Link to post
Share on other sites

Just to add one thing - this file which is the one that I went back to before creating the 23 versions after does not crash when I do save as... maybe you can see the differences! 

TRM_Final_Print.afpub

Share this post


Link to post
Share on other sites

You guys are dev ninjas :ph34r: :) can you tell me what the issue had to do with? I do development and usually I can pinpoint what causes something, but this one had me stumped! 

Thanks a million!

PS Glad you liked the book!!! Look for a nod to you guys and  "Affinity Serif Publisher" in the final copyright page :) 

Share this post


Link to post
Share on other sites

I have a problem very similar to ea0723.  I don't know what build I was using before today, but when I updated today, the problem was still there.

I have a very complicated file with lots of embedded pictures.  The current issue is with saving.  It saves sometimes, but doesn't other times.  When it doesn't, most of the time the save bar stays blank while it eats up hard drive space (it's gotten me down from 17GB to 25mb when I didn't catch it fast enough).  (Once or twice, it's managed to finally save after making no progress for a few minutes, but I don't know what was different about those times.  Either way, it's not ideal..)

Would you call that crashing? It doesn't automatically quit (whereas it does when I tweak a table in ways it doesn't like—but I just gave up on tables a few days ago).

I'm new to this whole tech beta thing, so I don't know if I've given you sufficient information. I'm hoping you can help.

Anyway, "game char book simplified" is the one that crashes repeatedly, while "came char book front" is a much earlier version that does not crash at all. I know that may not be helpful, but it's the best I have.

game_char_book_simplified.afpub

game char book front.afpub

Share this post


Link to post
Share on other sites

So I just learned something today... When Affinity Publisher 1.7.1 is crashing because of a big file, you can open the file in Affinity Photo and tweak things. After replacing big images (some 16mb, some possibly 26mb) with smaller images (2-5mb), I could re-open the file in Affinity Publisher and it wouldn't crash in the first 10 seconds.  It's a miracle!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×