Jump to content
qendl

Additional unwanted lines when using shift+drag to draw straight lines with brush tool in both Designer and Photo, bug remains unchanged from previous version

Recommended Posts

Same happening here even when selecting the move tool in-between drawing new lines when using a pixel brush.


Affinity Photo 1.7.0, Affinity Designer 1.7.0, Affinity Publisher 1.7.0.384 Beta

MacBook Pro 16GB, macOS Mojave 10.14.5

Share this post


Link to post
Share on other sites

Hi qendl,

How exactly are you creating your lines? Are you clicking from point to point to create the straight line between them, or are you clicking and dragging to draw new straight lines? Could you do a screen recording demonstrating the behaviour you are seeing please (if possible enabling the on screen keyboard to show when you are pressing shift). I've just tried both methods myself and it is the same as the shift behaviour in Photoshop when painting.

Share this post


Link to post
Share on other sites

Hi Sean,

If you start by holding down the Shift key with the paintbrush tool selected and then click once on the page, AP (and AD in the Pixel Persona) draws a line from a random point on the page to the point where you mouse click. Subsequent mouse clicks with the Shift key held down draw straight lines as expected.

If you then click 'V' to select the Move tool and click off the current selection by clicking elsewhere on the screen then click 'B' to reselect the Brush tool, I would expect a new line to be created that isn't 'associated' with the first line but if you hold Shift on the keyboard and then click with a view to drawing a 'New' line, it continues from the last point of the previously drawn line despite AP creating a new layer in the Layers Panel.

Note: esc and cmd D still don't deselect selected objects in AP despite 'Deselect' being entered in the History Panel for both. In AD clicking esc, cmd D or clicking elsewhere on the screen shows 'Clear selection' in the History Panel. In AP esc and cmd D show 'Deselect' in the History panel, clicking elsewhere on the screen shows 'Clear Selection' so there is an inconsistency between AD and AP.

Surely if you deselect the current selection by selecting the Move tool and then re-select the Brush tool, you would expect to create a new line from the point where you click on the page, in a similar way to the Pen tool and for it not to 'link' to the last drawn point from the previous line. Note: This only happens when you have the Shift key selected 'before' your mouse click. If you mouse-click first, then select the Shift key to continue then all is fine.

This may be 'expected' behaviour though feels like slightly 'odd' behaviour, especially the random line drawn initially when you first click on the page with the brush tool selected and the Shift key held down. Obviously easy to avoid by simply by 'Not' pressing the Shift key before a mouse click.


Affinity Photo 1.7.0, Affinity Designer 1.7.0, Affinity Publisher 1.7.0.384 Beta

MacBook Pro 16GB, macOS Mojave 10.14.5

Share this post


Link to post
Share on other sites
On 8/2/2019 at 5:00 PM, Hangman said:

Hi Sean,

If you start by holding down the Shift key with the paintbrush tool selected and then click once on the page, AP (and AD in the Pixel Persona) draws a line from a random point on the page to the point where you mouse click. Subsequent mouse clicks with the Shift key held down draw straight lines as expected.

If you then click 'V' to select the Move tool and click off the current selection by clicking elsewhere on the screen then click 'B' to reselect the Brush tool, I would expect a new line to be created that isn't 'associated' with the first line but if you hold Shift on the keyboard and then click with a view to drawing a 'New' line, it continues from the last point of the previously drawn line despite AP creating a new layer in the Layers Panel.

Note: esc and cmd D still don't deselect selected objects in AP despite 'Deselect' being entered in the History Panel for both. In AD clicking esc, cmd D or clicking elsewhere on the screen shows 'Clear selection' in the History Panel. In AP esc and cmd D show 'Deselect' in the History panel, clicking elsewhere on the screen shows 'Clear Selection' so there is an inconsistency between AD and AP.

Ahhh right now I see what you mean! I'll get this passed on to development.

AP and AD have different Esc/Cmd+D behaviour due to the intended uses of the applications. With Photo (And the Pixel Persona in Designer) you are more than likely going to be manipulating pixel selections so the Esc/Cmd+D behaviour deselect pixel selections. However what Pixel Persona in Designer does, that Photo doesn't is to then clear object selection if no pixel selection exists. I'll put an improvement in for Photo to get this 'fall back' behaviour as it is definitely inconsistent and confusing, and I can't think why it would be intentional.

Share this post


Link to post
Share on other sites
1 hour ago, Sean P said:

AP and AD have different Esc/Cmd+D behaviour due to the intended uses of the applications. With Photo (And the Pixel Persona in Designer) you are more than likely going to be manipulating pixel selections so the Esc/Cmd+D behaviour deselect pixel selections. However what Pixel Persona in Designer does, that Photo doesn't is to then clear object selection if no pixel selection exists. I'll put an improvement in for Photo to get this 'fall back' behaviour as it is definitely inconsistent and confusing, and I can't think why it would be intentional. 

1

Thanks Sean...


Affinity Photo 1.7.0, Affinity Designer 1.7.0, Affinity Publisher 1.7.0.384 Beta

MacBook Pro 16GB, macOS Mojave 10.14.5

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×