Jump to content

Recommended Posts

I recently installed version 1.7.0.367 over an existing version of Affinity Photo and using the tool is causing me all sorts of problems:

  1.  All my existing custom presets have disappeared; this did not happen in previous updates.
  2.  The number of default presets has increased greatly, the vast majority of which are of no interest to me. The resulting long list in unwieldy in use.
  3. Attempts to delete default presets fail (nothing happens initially), followed by the program instance closing down without any warning or explanatory error message. That is, the options seem to be worse than non-functional.
  4. Having read the built-in help I discovered the Presets Manager, but the delete options there are not highlighted (ie, they cannot be selected) for category presets within the categories. So it appears that the long unwieldy default presets list is a permanent feature of v1.7!
  5. I can add a custom preset category using the Presets Manager.
  6. I can see no way of adding custom presets to my newly created category; There is an option to import presets to the category, but regrettably I did not have the foresight to export my existing crop presets before upgrading to v1.7.x.
  7. There is an option to Create Preset... after clicking the cog icon, but it is not highlighted (ie, it cannot be selected).
  8. During my attempts to create my own presets I have somehow created a new category without a name in the Presets Manager; I cannot now delete it or give it a name. I did manage to move it to the top of the category list, but cannot now move it anywhere else :-) Never mind, it does not appear main crop tool list of presets.
  9. My newly created (named) category does not appear in the main crop tool list of presets...possibly because it is empty (see above).
  10. Just clicking on the crop tool cog icon is often enough to terminate the program (no warning or error messages given).

Maybe all these problems will disappear if I reboot my PC, I will try that after submitting this report.

Share this post


Link to post
Share on other sites

Closed down & restarted my PC.

  1. I opened an image file, selected the crop tool & set the custom ratio to 7x5.
  2. Selected the cog icon & the option to Create Preset... was highlighted.
  3. I was able to create a custom preset in my custom preset category.
  4. My custom preset category now appears in the dropdown list & my custom preset can be selected & used as expected.
  5. Tried to add a second (5x7) custom ratio following the above procedure, but the Create Preset... option was not highlighted (ie, cannot be selected).
  6. Shutdown & restarted Affinity Photo.
  7. Tried to add a second (5x7) custom ratio following the above procedure, but the Create Preset... option was not highlighted (ie, cannot be selected).

I can of course start from scratch every time I want to apply a crop, but that is not really acceptable.

Can someone explain how to add custom presets? And is it intentionally not possible to remove unwanted default presets?

Share this post


Link to post
Share on other sites

Hi ciscrh,
Welcome to Affinity Forums :)
I'm afraid this is not currently possible. After setting (and saving) a crop preset to 7x5, if you need to switch the W and H field's values to 5x7 (portrait/landscape) select the original 7x5 preset then click the Rotate button in the Crop Tool context toolbar.

Currently it's not possible to delete the presets that come with the program by default, only custom presets you create.

Share this post


Link to post
Share on other sites
11 hours ago, ciscrh said:

And is it intentionally not possible to remove unwanted default presets?

You cant delete the default crop presets but you can create a new category and drag all the default presets into it.

You also cant delete the default categories but empty categories do not show in the crop preset list when you access it.

That's the only way I know to get rid of the "clutter"

Best to save (export) your custom presets after you add them

 

presets.png


Due to the fact that Boris Johnson is now our Prime Minister, punctuation, spelling and grammar will never be worried about ever again.  We now have far bigger problems to be concerned about.

Share this post


Link to post
Share on other sites
Posted (edited)

Thanks Carl for that useful bit of lateral thinking. I'm busy with other stuff at the moment, but I'll try it out later :-)

Later...it works, reducing the clutter by placing the unwanted default presets out of sight at the bottom of the list.

Edited by ciscrh
additional information

Share this post


Link to post
Share on other sites
 
 
 
2
19 hours ago, MEB said:

Hi ciscrh,
Welcome to Affinity Forums :)
I'm afraid this is not currently possible. After setting (and saving) a crop preset to 7x5, if you need to switch the W and H field's values to 5x7 (portrait/landscape) select the original 7x5 preset then click the Rotate button in the Crop Tool context toolbar.

OK, I can live with that, but previous to 1.7.x I had both 7x5 & 5x7 :-)

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.