Jump to content

Recommended Posts

Posted (edited)

Hello everyone,

I'm having an issue where both Affinity Designer and Photo stay at "Not Responding" for about 3 minutes when starting up the program and THEN it opens fully. Basically it is super slow to open.

This is a clean install as I just bought the software and there's nothing else running on the PC and the PC is still new and running well so it's clearly a problem with the software. I already tried changing the performance options (Renderer to the dedicated GPU instead of the iGPU which is the default for some reason. Also tried WARP). As for how well the program runs once it opens it's, meh, it runs jerky, zoom animations are slow and panning is super slow (This is NOT 60fps as advertised, more like 5fps) BUT if I use the touchscreen it works quite well, much better than the touchpad. I tried the software on a Mac and it was amazing but on Windows it kinda sucks so far.

My Specs are:

Windows 10 Home (1903 / 18362.145)

Intel i7-8550U

RAM 16GB

iGPU: Intel UHD Graphics 620

dGPU: Nvidia MX150

EDIT: It appears that panning and zoom have improved somewhat! But sadly it still takes super long to start and still says "Not responding".

 

Edited by betachromatic

Share this post


Link to post
Share on other sites

Good news! I found out why it was taking so long to load, it's very simple, I just had too many installed fonts (2000+ !!). Something about the way Affinity handles fonts at load makes it take a long time. Illustrator didn't do this with the same amount of fonts so there's probably a way around it.

Fix: Uninstalled all non-system fonts and installed a Font Manager which activates any of the previous fonts I had only when I want them to.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×