I think the Welcome screen uses some components of Internet Explorer and to fix this problem I once had to reset Internet Explorer back to its default values To try this... Run Internet Explorer Click the settings cog Select Internet Options Select the Advanced Tab Click Reset at the bottom of the dialogue