Jump to content
nicoppc

Affinity Photo 1.7.0 - Photographer lost

Recommended Posts

Hello,

First a disclaimer. I am using PS CS6 as a raster editing software in my workflow. It's working well.. Unfortunately, due to Adobe's policy it has to be replaced in a new feature. Moreover, it may not work on upcoming MacOs. I've been looking at Affinity Photo since version 1.0... it looked really great on paper. However, each version just massively disappointed me. It's missing the basics... Please remember, I'm speaking about my needs, which may not be yours.. I'm aware the software may work for some... However it does not for me. Many of my colleagues works the same way.

Let's list some issues:

  • Missing proper Tiff support. To get integrated in my work flow, the software needs to open and save tiff seamlessly. Affinity can not "Save as... (tiff)". Sure, it can export.. but this is not the same thing
  • Now.. if one open a Tiff, do the editing and "Save": After some warning requester it works. However, if I do the same but quit the app, Affinity will offer me to "Save" the file, but it will  actually want to save it as afphoto and not tiff..
  • The icon "New Group" does not work if no layers is selected. However, the same command, new Group, work from the menu. (Do you test your software ?)
  • Mask feather: About 50 times slower as PS and limited to 100 px. It's so slow that you can not get any preview..
  • Mask... Well. I tried yesterday about one hour. I could not understand how they works.
    • I could not create any Group mask.
    • Most of the time I do NOT see the mask in the layers panel. and if it does, it's very difficult to see
    • I created a curve layer with simple mask (with a selection). Then I painted using the brush in white to extend the mask -> this action actually removes part of the mask .. (????). Well, it's also bout 5 times slower as PS
  • Level tool still does not work. In order to get the clipping preview (press alt), pro channel one need to set the master level at least at 1%..
  • Changing the brush size and hardness is not practical (it only shows a few circles but not the gradient of the actual brush..) and it's super laggy

 

That's it... I did not tried yet path..

 

Affinity: I think this are basic features which photographers (imo) needs every day.. Without Affinity is jus useless..

 

Thanks for your understandings


--
Nicolas DET
Fotografie
Les gens sont la clef

Event, Porträt, People, Hochzeit, ... Live
http://www.nicolas-det.eu

https://www.instagram.com/nicolas_det_fotografie/

Share this post


Link to post
Share on other sites
24 minutes ago, nicoppc said:

The icon "New Group" does not work if no layers is selected. However, the same command, new Group, work from the menu. (Do you test your software ?)

Screen-Shot-2019-06-08-at-07-55-15.png

You could assign a keystroke for New Group
Screen-Shot-2019-06-08-at-08-01-20.png

 


iMac 27" Late 2015 Fully Loaded, iMac 27" Mid 2011 both running High Sierra 10.13.6 - Affinity Designer/Photo & Publisher - Illustrator CC, Inkscape, Blender, Sketchup, Pepakura Designer, MTC, Pixelmator & Pixelmator Pro + more... XP-Pen Artist-22E, - iPad Pro 12.9 B|  

Affinity Help - Affinity Desktop Tutorials - Feedback - FAQ - most asked questions

Share this post


Link to post
Share on other sites
55 minutes ago, nicoppc said:

The icon "New Group" does not work

Layer > New Group


Affinity Photo  1.8.0.585   -  Beta 1.8.0.555

Windows 10 Home  1909 (build 18363.657) - 64 bit processor - AMD A4-5000 APU with Radeon HD Graphics  1.50GHz - RAM 8,00 GB
Calibrated Monitor (Datacolor Spyder5 Pro)

 

Share this post


Link to post
Share on other sites

Make sure the Group Layer is selected then press the Mask Layer Icon


Affinity Photo 1.8.5.703 ; Affinity Photo Beta 1.9.0.733); Win10 Home Version:1903, Build: 18362.207: Intel Core i7-4770, 3.90GHz, 32GB Ram, Nvidia GTX 645, 3-Internal HDD (1 Crucial MX5000 1TB, 1-Crucial MX5000 500GB, 1-WD 1 TB), 4 External HDD

Share this post


Link to post
Share on other sites
3 hours ago, Ron P. said:

Make sure the Group Layer is selected then press the Mask Layer Icon

Thanks!

Ok. Indeed, the Mask is show inside the group and not on the side (like PS). Now, I have an empty mask with some adjustement layers insde. However, how do I feel the mask ?

I tried to paint white.. but it paints black (??). Also, it's very laggy..


--
Nicolas DET
Fotografie
Les gens sont la clef

Event, Porträt, People, Hochzeit, ... Live
http://www.nicolas-det.eu

https://www.instagram.com/nicolas_det_fotografie/

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.