Jump to content
thomasp

AP 1.7.0: Context help vanishes after app focus switch (applies to Designer as well)

Recommended Posts

In separated window mode the context help bar attached to the document window vanishes:

1. With AP and active document in focus and a tool active it displays as expected

2. Switching to another app (like Finder) and switching back to AP leads to the bar staying empty until another tool is chosen

(applies to Designer 1.7.0 as well)

 

 

Just to be clear: I'm talking about this window element (not sure what it's called):

ap_context_help.jpg.de351d95de28d40b49438cb3d33405db.jpg

Share this post


Link to post
Share on other sites

Just to add that after upgrading to AP 1.7.1 I have now lost this bar. I'm not aware that I have changed any settings to make it vanish - is this toggle-able somewhere? Not even sure what it is called in the software. :)

 

 

Share this post


Link to post
Share on other sites
7 hours ago, GabrielM said:

Hi @thomasp,

Sorry for the delayed reply. I've logged this with our developers as an improvement, as it's not a bug. 

Thanks,

Gabe. 

Thanks Gabe,

But is losing this bar due to the software update a bug by any chance? Attached below is what it looks like now. How do I make it reappear?

ap_windowelement.thumb.jpg.b1aa9f144cac04d0a8917909bba5b294.jpg

Share this post


Link to post
Share on other sites
8 hours ago, MEB said:

Hi thomasp,
That bar is not displayed in Separated Mode (bye design). Gabriel has logged it as an improvement/suggestion so it can be considered for an upcoming version/update. Meanwhile go to menu Window and untick Separated Mode to switch to Window mode and get it back again.

 

Riiight. Was already there in 1.7.0 though.

My initial 'bug report' was about the behaviour of said bar and that it came up empty when I switched focus back from something else to AP/AD. Would be worthwhile to include that when you bring the 'bar' back as a feature.

 

Share this post


Link to post
Share on other sites

Hi thomasp,
I'm not able to reproduce this here: with the app in Window mode (so Separated Mode is unticked in the Window menu), the status bar does appear for me with the relevant info for the tool selected even after switching form another app back to Affinity Photo (or Designer). What macOS are you running? Any chance you can record a small clip showing this behaviour - may be we are missing something here. Thanks.

Share this post


Link to post
Share on other sites

I'm well aware that the bar is there in the unified window mode - but I had it in the interface in 1.7.0 in separated (floating) mode which is what my first screenshot is showing - and really like that. It's gone after the update to 1.7.1 is what I'm saying.

 

Share this post


Link to post
Share on other sites

Hi thomasp,
As far as I know that only happens when you switch to Photo Persona inside Affinity Publisher which is the only application that displays the status bar in separated mode since it includes additional functionality there (page navigation). Maybe that's where the confusion comes from?

Share this post


Link to post
Share on other sites

I've never even looked at Publisher. :)

As said I lost it in the Photo update but still have it running on the same machine in Designer 1.7.0 - separated mode, status bar visible in every open document.

Proof (running on 10.13.6):

ad_windowelement.thumb.jpg.6159a54018b4c6b269c0638c1034bf08.jpg

 

 

So it appears this feature was already in but somehow got removed in the 1.7.1 update (which I have not done to Designer so far)?

Well, now that I see that - if you reintroduce the status bar for separate mode then you might as well consider having the help text only display for the active window and dim or hide it for the background ones.

Share this post


Link to post
Share on other sites

Hi thomasp,
Thanks for screenshot and for clearing this up. This was probably an oversight/glitch during the beta (probably limited to older macOS versions) that was corrected for the retail version. As far as I know both Photo and Designer are not supposed to show the status bar in Separated Mode. I'm adding those remarks to Gabriel's report/request along with your screenshot for reference. It's then up to the dev team to decide what to do. Thank you for your support and patience.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×