Jump to content
Kiryl

Exported images from newly created artboards are blank

Recommended Posts

Posted (edited)

Hello,

Context

  1. Version 1.7.0
  2. Existing project.
  3. New artboard.
  4. Exporting to png, jpeg.

Result

The exported file is blank.  When trying to export from artboards created before the version 1.7. it works perfectly.

Edited by Kiryl

Share this post


Link to post
Share on other sites
Just now, MEB said:

Hi Kiryl,
Welcome to Affinity Forums :)
Do you mind attaching the file that's giving you trouble please? We can provide an upload link if you wish to keep it private.

Sure, give me please the link.

Share this post


Link to post
Share on other sites

I've made a copy of the page (attached) with the issue, but it doesn't work there nither. The main artboard is exported well, but the one named HRJ provides a blank image on export (test.jpg).

sample-file.afdesign

test.jpg

Share this post


Link to post
Share on other sites

Hi Kiryl,
Thanks for the file. That artboard doesn't have any content - if you take a look at the Layers panel you will see it's a single locked artboard without any layers inside. It does look like it has content visually inside because it's fill colour is set to transparent and thus all that behind it is still visible inside its boundaries.

If you want to export parts of an artboard/document to files use Slices in Export Persona instead. That's their purpose. So delete that empty artboard, change to Export Persona (third icon on the top left of the interface), use the Slice Tool there (the first icon in the toolbar on the left) to draw a slice manually around the object/area you want to export (you can adjust the size precisely in the Transform panel in the bottom right of the interface), then in the Slices panel right above the Transform panel, select the slice you just created and click the Export Slice button on the bottom left of the panel. 

Here's a few video tutorials about the export Persona that may help:

11. Saving, exporting and sharing

•        Exporting
•        Exporting: Layers
•        Exporting: Slices
•        Exporting: Continuous
•        Exporting: Automatic Directory/Folder Creation (1.5)
•        Exporting: Multiple Outputs from a Single Slice (1.5)
•        Exporting: Transparent and Coloured Backgrounds (1.5)

Share this post


Link to post
Share on other sites
Posted (edited)

You are right about my bad practice (misuse) of artboards in this case. I was doing it all time and it was working (but was messy while exporting main pages of the doc), but now I will switch to slices instead. If there is no any troubles on your side then the case is closed. :)

UPD. Now I remebered why I resigned from using slices. I need the exported image having a bigger resolution than the one I have in affinity file. Any suggestions on that?

UPD 2. That's fine. Will export x2 images.

 

Edited by Kiryl

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×