Jump to content
dibat

Photo become desaturated when add new View Point using Advanced mode in Navigator

Recommended Posts

Without any modifications made, if you add a new View Point using Advanced mode in Navigator, photo become desaturated and unaffected by any tool parameter changes.

Affinity-not-ok.thumb.png.74d702d07d522594c144a4febd47be3d.png

Share this post


Link to post
Share on other sites

Try clicking on the restore down icon, twice. You may find the screen does not close down to a smaller screen as expected but your image may restore itself to the correct exposure. The icon for clarity is the one in the middle of the minimise icon and the close icon at the top right of the screen. My CR2 files come in dark (JPG are OK) and I found by accident that if I click on the restore down icon the image corrects itself, but the icon does not perform as it should. I have reported this to the developers. Will be interesting if this also solves your problem.

Share this post


Link to post
Share on other sites

@Mark Ingram: Visually that effect is quite similar to my report of issues adding Guides in the Develop Persona except that one could be recovered from simply by changing which Tool was selected. No HDR involved in mine, and I am set to develop to RGB/16 (but this happens before one actually develops the image).


-- Walt

Windows 10 Home, version 2004 (19041.388),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.8.5.703 and 1.9.0.911 Beta   / Affinity Designer 1.8.5.703 and 1.9.0.911 Beta  / Affinity Publisher 1.8.5.703 and 1.9.0.911 Beta.

Share this post


Link to post
Share on other sites
11 minutes ago, walt.farrell said:

@Mark Ingram: Visually that effect is quite similar to my report of issues adding Guides in the Develop Persona except that one could be recovered from simply by changing which Tool was selected. No HDR involved in mine, and I am set to develop to RGB/16 (but this happens before one actually develops the image).

Hi Walt, I don't think that issue is related, as it's 16-bit. The related issues above are all 32-bit (and the new HDR options only work with 32-bit content).

Share this post


Link to post
Share on other sites
1 minute ago, Mark Ingram said:

Hi Walt, I don't think that issue is related, as it's 16-bit. The related issues above are all 32-bit (and the new HDR options only work with 32-bit content).

Perhaps, but I can duplicate that on my system using View Points, without HDR or 32-bit. (Sorry, I should have been more clear in my post.)


-- Walt

Windows 10 Home, version 2004 (19041.388),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.8.5.703 and 1.9.0.911 Beta   / Affinity Designer 1.8.5.703 and 1.9.0.911 Beta  / Affinity Publisher 1.8.5.703 and 1.9.0.911 Beta.

Share this post


Link to post
Share on other sites
4 hours ago, walt.farrell said:

Perhaps, but I can duplicate that on my system using View Points, without HDR or 32-bit. (Sorry, I should have been more clear in my post.)

Samen for me


Affinity Photo  1.8.0.585   -  Beta 1.8.0.555

Windows 10 Home  1909 (build 18363.657) - 64 bit processor - AMD A4-5000 APU with Radeon HD Graphics  1.50GHz - RAM 8,00 GB
Calibrated Monitor (Datacolor Spyder5 Pro)

 

Share this post


Link to post
Share on other sites

My 32 bit preview on the 32 bit pre-view window is not enabled, in fact it is greyed out and I can't enable it. But as I have said before if you click the restore down icon then dark image goes to normal but the 32 bit pre-view is still not enabled so maybe the two things are not linked?

Share this post


Link to post
Share on other sites
13 hours ago, walt.farrell said:

@Mark Ingram: Visually that effect is quite similar to my report of issues adding Guides in the Develop Persona except that one could be recovered from simply by changing which Tool was selected. No HDR involved in mine, and I am set to develop to RGB/16 (but this happens before one actually develops the image).

 

14 hours ago, Mark Ingram said:

If you click on the 32-Bit Preview panel, is the "Enable HDR" checkbox enabled? @dibat and @andersp5.

If you develop to 16-Bit, I imagine this bug won't occur.

Just discovered that if I click on the restore down icon to get the image to display correctly, i.e not dark as before using CR2 file and then go to navigator and use the advanced function and add a new view point the image goes dark again and clicking on the restore down icon makes the programme stall with not responding showing and then eventually it restores the image but the image is now dark again. Clicking on the restore down icon again now has no effect. Hope this helps. 

Share this post


Link to post
Share on other sites

Similar problem when using the rotate button in the develop persona.  Saturation comes back when any adjustment is made (exposure, etc.).

Desaturation.jpg

Saturated.jpg

Share this post


Link to post
Share on other sites
On 6/7/2019 at 11:10 AM, walt.farrell said:

Perhaps, but I can duplicate that on my system using View Points, without HDR or 32-bit.

Yep, same here.  The only change between the attached pair of screen shots is the application of a view Point.

View Point.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.