Jump to content

Recommended Posts

I updated to 1.7 from app store on Mac and now the program is unusable. I open it and it won't open and just gives me a crash report. I uninstalled and reinstalled it....TWICE.... and it still does the same thing. This is on my MacBook Pro using Mojave. I have clients work to work on and now I can't even use it. Im worried to update on my iMac for fear that it'll ruin it as well and i'll have to go back to photoshop. WHO ELSE IS HAVING ISSUES OPENING AFTER UPDATE?! FIX THIS PLEASE SO THAT WE DONT HAVE TO USE PHOTOSHOP! This is why I switched a while ago to Affinity because it was amazing up until 6 hours ago..... 

Affinity Photo Log.pdf

Share this post


Link to post
Share on other sites

My MacBook Pro also has Mojave on it and the update went completely smoothly from the app store, for both Photo and Designer.

Share this post


Link to post
Share on other sites
4 hours ago, Michael Ray Photography said:

I updated to 1.7 from app store on Mac and now the program is unusable. I open it and it won't open and just gives me a crash report. I uninstalled and reinstalled it....TWICE.... and it still does the same thing. This is on my MacBook Pro using Mojave. I have clients work to work on and now I can't even use it. Im worried to update on my iMac for fear that it'll ruin it as well and i'll have to go back to photoshop. WHO ELSE IS HAVING ISSUES OPENING AFTER UPDATE?! FIX THIS PLEASE SO THAT WE DONT HAVE TO USE PHOTOSHOP! This is why I switched a while ago to Affinity because it was amazing up until 6 hours ago..... 

Affinity Photo Log.pdf

Could you please go to \Users\username\Library\Containers\ and rename the folder 'com.seriflabs.affinityphoto' to 'com.seriflabs.affinityphoto.old'

This will reset the app and hopefully you can run it up. If this is the case, please send me the folder you renamed so we can find out the cause. Here is a private Dropbox folder to upload the folder to.

 

Share this post


Link to post
Share on other sites

I updated to 1.7 yesterday immediately from the App Store and Photo and Designer running smoothly on my iMac with Mojave 10.14.5 installed

Regards, Puck


(iMac 2017, 16 GB RAM, Intel Iris Plus Graphics 640 1536 MB, MacOS 10.14.X)

Share this post


Link to post
Share on other sites
8 hours ago, Michael Ray Photography said:

FIX THIS PLEASE SO THAT WE DONT HAVE TO USE PHOTOSHOP!

no problems here ( both HS and mojave), have you tried deleting the preferences as suggested?

Share this post


Link to post
Share on other sites
12 hours ago, Michael Ray Photography said:

Chris B, I sent you a message sir and I also tried what you said and it worked so thank you!

You are very welcome :) 

Share this post


Link to post
Share on other sites

Chris B, thanks for this tip.  I'll try in the next week or so to upgrade again on my 2012 mini.  I figured it was something like a setting that would get ironed out.  Right now I'm still in the middle of a few trial-and-error efx projects in 1.6, so I'll wait until I'm done with that before I reinstall. However, as we go forward, I'll keep watch on this board to see how users with configs similar to mine are working out.  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×