Jump to content
Terkoz

Spell check not working.

Recommended Posts

It appears the spell check has a glitch. It is not working for me. A friend also has the same issue.

This is in 337.

Share this post


Link to post
Share on other sites

It could be a few things

For starters, check the Character Studio and in the Language section see what the spelling is set to

Also uploading a sample APub file where the spelling does not work may reveal the problem quicker


Due to the fact that Boris Johnson is now our Prime Minister, punctuation, spelling and grammar will never be worried about ever again.  We now have far bigger problems to be concerned about.

Share this post


Link to post
Share on other sites

As carl says, it could be no language is applied to the text to spellcheck against, or check while typing is turned off.

If it's neither of these things please attach your file if possible and we can look at why it might not be working.


Serif Europe Ltd. - www.serif.com

Share this post


Link to post
Share on other sites
Posted (edited)

I also have problems, the spell check is set to English the Characters are set to English UK, check while typing is turned on. but is not learning any words it just keeps showing the same words..

Also if i am checking a story in say page 10 it decides it wants to check page 2.and as above keeps checking the same words on that one page.

This is happening on Beta 337 on a W7 pc also in the latest Beta 371 on a W8 pc.

Edited by John T
extra info added

Share this post


Link to post
Share on other sites

John T, can you reproduce it on a new document? I've just started a new document and it seems to be performing as I would expect.

Any chance you can attach a video demonstrating the issue?


Serif Europe Ltd. - www.serif.com

Share this post


Link to post
Share on other sites

Having the same problem here. No problem in a new document though!

I have a master document for a newsletter; go in and add text, pictures etc. Save as a new document specific to that content. Then spellchecker is not working.

Creat a totally new document, import the same text and spellchecker now does work!

Share this post


Link to post
Share on other sites
1 minute ago, WildCottage said:

I have a master document for a newsletter

Uploading that, may help investigate the problem


Due to the fact that Boris Johnson is now our Prime Minister, punctuation, spelling and grammar will never be worried about ever again.  We now have far bigger problems to be concerned about.

Share this post


Link to post
Share on other sites

Hi Wild Cottage,

I typed some miss spelt text in to your newsletter with check while typing.

It underlined the wrong text but would not find an alternative. I also tried as suggested in the help page highliting the word and right clicking to bring up the spell check but nothing happened. It kept defaulting to Oystercatcher.

Share this post


Link to post
Share on other sites

I have just copied some of my text with unusual names into a new document and Publisher found them and added to the dictionary.

Will have to have a play about.

Share this post


Link to post
Share on other sites
11 hours ago, Jon P said:

John T, can you reproduce it on a new document? I've just started a new document and it seems to be performing as I would expect.

Any chance you can attach a video demonstrating the issue?

Hi still having problems, here are the files sorry about the video not used this before

thanks;

Vol 34 1 Aug 2019 spel check errors.afpub

Share this post


Link to post
Share on other sites

Sorry for the late reply. I was away.
This was not in a document I was working on. My friend told me his spell check wasn't working so I just created a new file and typed a single line in with an obviously wrong word. And nothing was found. The language is set to english united kingdom. I just tried with a second document created a blank page.. A text box and added a line with an incorrect word. I do have check while typing on and nothing happened. I ran spell check and again nothing. I tried changing the language to english US but it didn't fix it.

Is there another setting I may be forgetting?

Share this post


Link to post
Share on other sites
35 minutes ago, Terkoz said:

Sorry for the late reply. I was away.
This was not in a document I was working on. My friend told me his spell check wasn't working so I just created a new file and typed a single line in with an obviously wrong word. And nothing was found. The language is set to english united kingdom. I just tried with a second document created a blank page.. A text box and added a line with an incorrect word. I do have check while typing on and nothing happened. I ran spell check and again nothing. I tried changing the language to english US but it didn't fix it.

Is there another setting I may be forgetting?

Just to be sure: When you say "the language is set to ..." are you referring to the Language/Spelling setting in the Character Panel?

And, if so, are you sure that it's assigned to the text. If you put the cursor in the middle of that text, is the language setting correct?

Other than that, I'm not sure what else you can do.


-- Walt

Windows 10 Home, version 1909 (183623.476),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.7.3.481 and 1.8.0.514 Beta   / Affinity Designer 1.7.3.481 and 1.8.0.514 Beta  / Affinity Publisher 1.7.3.481 and 1.8.0.523 Beta

Share this post


Link to post
Share on other sites
23 minutes ago, walt.farrell said:

Just to be sure: When you say "the language is set to ..." are you referring to the Language/Spelling setting in the Character Panel?

And, if so, are you sure that it's assigned to the text. If you put the cursor in the middle of that text, is the language setting correct?

Other than that, I'm not sure what else you can do.

Okay that was it. Thanks Walt. I was going by the language setting in the general preferences tab. After what you said I spent a few minutes going over every inch of the screen before noticing the closed language section on the right display column. In it the spelling setting was set to unknown. Once I set that properly the auto spell check kicked in.

I have to say though this is a bit unintuitive. I'm not a heavy publisher user but I have never before had to set a language for every new document. I just created a new one and it defaulted to unknown. Surely it makes sense to default to the language in the general settings? 99% of people will never use more than the one language so this is really and unnecessary step for each new document. Or if it must be set each time make it part of the new document window.

I'll pass the info to my friend. Thanks again sir for the help. Much appreciated.

Share this post


Link to post
Share on other sites

You're welcome. I'm not sure why it's defaulting to None for the Spelling Language. Mine currently defaults to English (US), but my UI language is set to English (UK).

It may simply be remembering the last setting that you used, or possibly you have used the Save Defaults function some time while the language was set to None. Sorry, but I'm not willing right now to reset Publisher completely to see what the true default is for a new installation :)


-- Walt

Windows 10 Home, version 1909 (183623.476),
   Desktop: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970
   Laptop:  8GB memory, Intel Core i7-3625QM @ 2.30GHz, Intel HD Graphics 4000 or NVIDIA GeForce GT 630M
Affinity Photo 1.7.3.481 and 1.8.0.514 Beta   / Affinity Designer 1.7.3.481 and 1.8.0.514 Beta  / Affinity Publisher 1.7.3.481 and 1.8.0.523 Beta

Share this post


Link to post
Share on other sites

Thank you the fix in 384 has resolved my spell check error where it was checking a page of text and dive off somewhere else.

Also without changing any settings the spell check is now learning and saving new words.

Quote

Selecting text with keyboard would switch between pages at the wrong point

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.