Jump to content
Arun Sarkar

[By Design] Issue with "Auto Correct Option : Change Straight Quotes to Typographic Quotes

Recommended Posts

"Change Straight Quotes to Typographic Quotes" feature in "Auto Correct Option" under preference being always active even when I un-tick (deactivate) it.

Can someone please confirm it?

Thanks a lot in advance.

Kind regards

Arun

 

Share this post


Link to post
Share on other sites
2 hours ago, Arun Sarkar said:

"Change Straight Quotes to Typographic Quotes" feature in "Auto Correct Option" under preference being always active even when I un-tick (deactivate) it.

Seems to work OK for me

My "quotes" change depending on if it is ticked or not

Windows 8.1

 

Share this post


Link to post
Share on other sites
36 minutes ago, carl123 said:

Seems to work OK for me

My "quotes" change depending on if it is ticked or not

Windows 8.1

 

Me too on Win 8.1

But it always comes like this [ ‘ ’ ] not like this [ ' '  ] when feature is not activated or un-ticked. (May be it is not a big issue for others but for me my ANSI Bengali fonts does not work properly as due to this feature character change when typed.) 

Share this post


Link to post
Share on other sites

I'll revise my "Confirmed" above :)

Double quotes are processed correctly; depending on that autocorrect option they either come out as " or as  and . Single quotes and apostrophes are always typographic/curled, regardless of the autocorrect setting.

Share this post


Link to post
Share on other sites
13 minutes ago, walt.farrell said:

I'll revise my "Confirmed" above :)

................... Single quotes and apostrophes are always typographic/curled, regardless of the autocorrect setting.

Thanks a lot Walt for confirmation twice.

Share this post


Link to post
Share on other sites
On 5/27/2019 at 5:36 PM, walt.farrell said:

Single quotes and apostrophes are always typographic/curled, regardless of the autocorrect setting.

Dear Serif

Is it "By Design" feature?

If yes, please let me know so that I can ask my Indic Language ANSI font vendor if they like to change their font (At least those ANSI fonts works but now two character makes problem in my script and Affinity does not support basis Indic language Open Type font (LR) )

Share this post


Link to post
Share on other sites

I've just had an update:

Quote

Single quotes are intentionally different. There's a separate option "Support language dependent single typographic quotes" which changes their behaviour from the default (where straight quotes are replaced with typographic in order to allow apostrophes) to language dependent, where they may be replaced with guillemets, low quotes and so on. We don't currently have a third option for keeping straight single quotes (not sure of the use case) but you can always Ctrl-Z to cancel an individual auto-correct if needed.

Closed as By Design

Share this post


Link to post
Share on other sites
3 hours ago, GabrielM said:

Closed as By Design

I think auto correct options should be like PP when you don't support basic LTR Indic language open type fonts. At least we can use ANSI Indic fonts if straight single quote behave like PP. 

Disappointed. 

 

Share this post


Link to post
Share on other sites

I don't want correct quote, type in " ' ".

Single quotes and apostrophes are always typographic/curled, don't check in preference in auto correct tab, it show.

how to solve it?

I type first sentence in 'Mon'. show curled quote.

second sentence in 'Mon' . quote type . undo it. show it. " ' ".

Please.

Screen Shot 2019-06-23 at 12.48.16 PM.png

Share this post


Link to post
Share on other sites

Apparently the only way to get straight single quotes right now is to type the quote mark, then immediately type Ctrl+Z to undo the autocorrection that makes it a typographic quote. Or to use copy/paste.

Or, when you're all done, you could use Find/Replace to change them. Do a regular expression Find for [‘’] and replace with '

Share this post


Link to post
Share on other sites
On 6/23/2019 at 6:30 PM, walt.farrell said:

Apparently the only way to get straight single quotes right now is to type the quote mark, then immediately type Ctrl+Z to undo the autocorrection that makes it a typographic quote. Or to use copy/paste.

Or, when you're all done, you could use Find/Replace to change them. Do a regular expression Find for [‘’] and replace with '

Hello Walt,

Your suggestion is perfect when you only need this " ' ". But when you worked with other language font in ANSI mode then it become painful, specially your other language font contain conjunct character with " ' " glyph. At that time Affinity's auto correct + (IME) immediately change that conjunct charter with a different one.

I wish at least auto correct should worked like PP with " ' " or Serif should support basic GPOS of open type feature.

Share this post


Link to post
Share on other sites
On 6/23/2019 at 3:00 PM, walt.farrell said:

Apparently the only way to get straight single quotes right now is to type the quote mark, then immediately type Ctrl+Z to undo

This is a pro feature, not for amateurs. :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.