Jump to content

AfPub Beta 337 - Hyperlinks not being added as expected

Recommended Posts

I have today, 25 May 2019, updated to 337.

I opened an already well used Document that I use as a Template. This is similar to the attached Afbub File, the Links within this document all function as expected. When I attempted to add additional Hyperlinks:

View > Studio > Hyperlinks

Selected the Link [Text in this case]

In the Pop Up this was assigned a Page Number

The Selected Link displayed in Blue and was Underlined

The Hyperlinks Panel did not display this addition.

After many attempts a fresh start was made via:

Text > Interactive > Insert Hyperlink

Then the actions were performed as above with the same outcome, again tried many times.

Then a similar New Document was created, using 337, and all the Hyperlinks performed satisfactorily. However after:

Saving this Document

Closing and reopening it

Saving As - Giving it a New FileName

As before the actions were performed as above with the same outcome, and again tried many times.

The outcome still fails to accept New Hyperlinks.

Due to 'brain fade' spirits were temporarily lifted when a Nw Link was added, unfortunately the said link was inadvertently added to the Master Page and not a solution.

Thanks for all the great work you guys and gals are doing.

Geez - Hyperlink Problem I.afpub

Share this post

Link to post
Share on other sites

There does seem to be some hassle adding to a text frame from a Master Page. Your links don't show up in the Hyperlinks Studio but they work in an exported PDF. I added a text frame and put a link in there and it works as well as shows up in the Hyperlinks Studio.

To sum up: Links in text in a Text frame from a Master Page won't show up in the Hyperlinks Studio.

MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.7.0 | Affinity Photo 1.7.0 | Affinity Publisher beta | Affinity Photo beta | Affinity Designer Beta

Share this post

Link to post
Share on other sites

Thanks for your reply.

Your workaround is useful.

Prior to the update to 337 the arrangement in place worked satisfactorily, and I hope the situation can be corrected.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now