Jump to content
Sign in to follow this  
A_B_C

[SOLVED] Character Style “Hyperlink” Added Even If Not Present In Document

Recommended Posts

Another slight oddity. When you create a new document, and remove all text styles, the character style “Hyperlink” is nonetheless still available in the Add Hyperlink popup. I believe the popup should default to “No Style” in such an instance, and the style “Hyperlink” should not be available. Personally, I don’t want styles to be added accidentally to my document. o.O

 

Share this post


Link to post
Share on other sites

Just choose [No Style] from the popup instead of Hyperlink. I personally like the fact that I can then search and replace my links using the Find Studio and search for Character Style: Hyperlink as well as using the Hyperlink Studio to find them.


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.7.1 | Affinity Photo 1.7.1 | Affinity Publisher 1.7.1

Share this post


Link to post
Share on other sites

As long as there is a default hyperlink style in the document, I have nothing against this idea. But as soon as I deliberately remove all predefined text styles from a document, I don’t want to be bothered with one of these styles in another place. I will usually know what I am doing … usually … ;)

Share this post


Link to post
Share on other sites

Watch your video (15 to 16 second mark), you choose Hyperlink for the style of the hyperlink. That is why the style was added to your document. If you had chosen [No Style] then the Hyperlink style would not be added to your document.

56 minutes ago, A_B_C said:

I don’t want to be bothered with one of these styles in another place.

Extra styles drive me up the proverbial wall. 


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.7.1 | Affinity Photo 1.7.1 | Affinity Publisher 1.7.1

Share this post


Link to post
Share on other sites

Yes! But that is just what I am complaining about! Why on earth am I presented with the option of selecting this style, when it is not even present in my document? (Remember I removed all default styles.) Where does it come from? Is that a remnant from the past? It is some otherworldly creature? How can this guy just walk straight into my front yard and knock at my door? o.O

Hyperlink-Style.png.ffb8f4c8a5fa7bec33a28518b6c1a85c.png

 

Share this post


Link to post
Share on other sites

That style is not among those that exist by default in a new document.  I believe this is intentional: it is created automatically the first time it is used in defining a hyperlink.

Share this post


Link to post
Share on other sites
12 minutes ago, fde101 said:

That style is not among those that exist by default in a new document.  I believe this is intentional: it is created automatically the first time it is used in defining a hyperlink.

I believe that is correct.

I just noticed, though, that the only choices available in the dialog for adding the hyperlink are [No Style], Hyperlink, Emphasis, Strong, and Strong Emphasis. You cannot use your own text style of another name. (At least, I cannot see a way to do so.)


-- Walt

Windows 10 Home, version 1903 (18362.145), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.1.404 and 1.7.1.404 Beta   / Affinity Designer 1.7.1.404 and 1.7.1.404 Beta  / Affinity Publisher 1.7.1.404

Share this post


Link to post
Share on other sites
2 minutes ago, walt.farrell said:

You cannot use your own text style of another name.

I'm seeing my other character styles, both for creating a hyperlink and for editing one.  Note that only character styles are there - not paragraph styles...

Share this post


Link to post
Share on other sites
2 minutes ago, fde101 said:

I'm seeing my other character styles, both for creating a hyperlink and for editing one.  Note that only character styles are there - not paragraph styles...

Thanks. That's it; I wasn't looking at character styles.


-- Walt

Windows 10 Home, version 1903 (18362.145), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.1.404 and 1.7.1.404 Beta   / Affinity Designer 1.7.1.404 and 1.7.1.404 Beta  / Affinity Publisher 1.7.1.404

Share this post


Link to post
Share on other sites
13 minutes ago, fde101 said:

Note that only character styles are there - not paragraph styles...

Paragraph styles wouldn't work well for a link in the middle of a paragraph. Character styles on the other hand are just what we want for formatting the text.


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.7.1 | Affinity Photo 1.7.1 | Affinity Publisher 1.7.1

Share this post


Link to post
Share on other sites
6 minutes ago, Old Bruce said:

Paragraph styles wouldn't work well for a link in the middle of a paragraph. Character styles on the other hand are just what we want for formatting the text.

Bingo.

Share this post


Link to post
Share on other sites
9 hours ago, fde101 said:

That style is not among those that exist by default in a new document.

Ha. That’s the solution. :)

Hadn’t noticed. Sorry for bothering everyone.

Share this post


Link to post
Share on other sites

Then I would suggest that the Add Hyperlink popup should remember my last choice for the menus whenever I create a new link. It always presents me with the default options preselected. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×