Jump to content

Recommended Posts

The Grays, Colors and Gradients swatches palette are empty.
By choosing to Export one of these palettes, Publisher crashes.
With or without an open document in the editing window, the problem is the same.
All other color Palettes work well.

Affinity Publisher version 1.7.0.312

macOSMojave version 10.14.5

screenshot-publisher-swatches.png

Share this post


Link to post
Share on other sites
14 minutes ago, franco said:

Affinity Publisher version 1.7.0.312

Try the newer version .337 

I can't speak for the .312 version but the latest has the palettes. 


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.7.0 | Affinity Photo 1.7.0 | Affinity Publisher beta 1.7.0.384 | Affinity Photo beta 1.7.1.138 | Affinity Designer Beta 1.7.0.14

Share this post


Link to post
Share on other sites

In version .317 the Gradients swatches palette is displayed and I can export it.
On the other hand, Grays and Colors are still empty and Publisher crashes if I try to export them.

Share this post


Link to post
Share on other sites

That is kind of a reported issue, related to the app language.
[... and in v337 still occurring to me, not only for "Farben" (Colors) but also for "Verläufe" (Gradients) and "Unnamed".]

 


macOS 10.12.6,  Macbook Pro 15" + Eizo 24"

Share this post


Link to post
Share on other sites

Thomaso, you are right, Swatches are normally displayed when Publisher is in English.
If I set the application in English (United States) or French, the Swatches are missing.

Share this post


Link to post
Share on other sites
1 hour ago, franco said:

If I set the application in English (United States) or French, the Swatches are missing.

Neat, I tried that and lost the Swatches and had Unknown for a language choice in Auto correct and filler text instead of my system's previous preference for English (Canada).

Should point out that the language choice is from the General section of the application's Preferences.


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.7.0 | Affinity Photo 1.7.0 | Affinity Publisher beta 1.7.0.384 | Affinity Photo beta 1.7.1.138 | Affinity Designer Beta 1.7.0.14

Share this post


Link to post
Share on other sites
1 hour ago, Old Bruce said:

and had Unknown for a language choice in Auto correct

"Unknown", indeed? – To me it's "None" in English app language on German OS.
Do you remember whether it has shown any language before your app language pref switch? (mine was "None", too.)

Also in English app language on German OS:

– I am not allowed to alter the spelling language in Character Style panel from "Deutsch" to "None" or "English", as long there is no object selected: regardless what I select in the pull-down menu, it always jumps back to "Deutsch".

– Whereas I have free choice with a text frame selected any new text frame is set to "None", regardless what language I used in the recently selected frame. It seems to force me to assign a language for every text frame – instead of keeping the last choice.

Quote

English swatches empty in ... US/Canada

British humor :2_grimacing:


macOS 10.12.6,  Macbook Pro 15" + Eizo 24"

Share this post


Link to post
Share on other sites
9 minutes ago, thomaso said:

"Unknown", indeed? – To me it's "None" in English app language on German OS.
Do you remember whether it has shown any language before your app language pref switch? (mine was "None", too.)

1320076049_ScreenShot2019-05-25at12_11_56PM.png.9b6c3c5396d63e5220e61983a61191ff.png

There is no Unknown (en-US) in the menu list though. The only language I have chosen in my OS is English with the region being Canada so I get English (Canada) as my Primary (and only) choice.


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.7.0 | Affinity Photo 1.7.0 | Affinity Publisher beta 1.7.0.384 | Affinity Photo beta 1.7.1.138 | Affinity Designer Beta 1.7.0.14

Share this post


Link to post
Share on other sites

Ah, good point, I forgot about the OS keyboard setting. There I have German and English (with british flag icon;) The menu results in:

487199310_auto-corrctpreflanguages.jpg.076c9f9ba7e7d1c176584113ecb786bb.jpg

(2x English - no US, no Canada)


macOS 10.12.6,  Macbook Pro 15" + Eizo 24"

Share this post


Link to post
Share on other sites
2 minutes ago, thomaso said:

Ah, good point, I forgot about the OS keyboard setting. There I have German and English (with british flag icon;) The menu results in:

487199310_auto-corrctpreflanguages.jpg.076c9f9ba7e7d1c176584113ecb786bb.jpg

(2x English - no US, no Canada)

The first English must be some sort of Platonic Ideal. You know the one that nobody uses or understands but spelling correctly is easier in it.


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.7.0 | Affinity Photo 1.7.0 | Affinity Publisher beta 1.7.0.384 | Affinity Photo beta 1.7.1.138 | Affinity Designer Beta 1.7.0.14

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×