Jump to content
Fabooh

Cropping and Selecting not working properly

Recommended Posts

Hello there,

I am using Affinity Photo 1.6.7 on Mac OS Mojave 10.14.4 (18E226).
For the past few months, I am facing the following issue:

1) I crop an image. (screenshot 1)

2) I select something with the selection brush (screenshot 2)

3) I press CMD + C to copy the selection and CMD + V to paste the selection as a new layer

4) I 'hide' the background layer so that only the new layer is visible -> instead of my selection, only a part of it is visible (screenshot 3)

As a workaround, I figured out that I do not run into this problem when I save the image after cropping it, closing it and opening it again. 
When I do that, I can continue editing the picture without any issue. It happened to me with several jpg files before and can be easily reproduced.

Please help :)

screenshot 1.png

screenshot 2.png

screenshot 3.png

Share this post


Link to post
Share on other sites

Hi @Fabooh,

Welcome to the forums. 

I could not replicate this. Can you please attach a screen recording of this in action? If it's file specific, compress the file and attach it here. 

Thanks,

Gabe. 

Share this post


Link to post
Share on other sites

Unable to reproduce that here either, for what it may be worth here are the preferences for my set-up with Photo 1.6.7

304834826_ScreenShot2019-05-08at2_51_20PM.thumb.png.f43b56c53e18a57f8c801ccbc20417db.png

I have to say that there is a similarity in the offset of what gets copied and pasted and the offset of the crop.


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.7.3 | Affinity Photo 1.7.3 | Affinity Publisher 1.7.3 | Affinity Designer Beta 1.7.x.x | Affinity Photo Beta 1.7.x.x | Affinity Publisher Beta 1.7.x.x

Share this post


Link to post
Share on other sites

Your video shows the image was taken with an iPhone X.

If all the problem images were taken with this phone then you need to upload one of those faulty images for testing (preferably as a zipped file as uploading directly may change the format on the forum)

Alternatively, try using the CTRL key (or Mac equivalent) when starting the program to select then reset all settings back to default.

Note: you will lose any customisations you may have made (shortcuts etc) when doing this.

 

 

 

 


Due to the fact that Boris Johnson is now our Prime Minister, punctuation, spelling and grammar will never be worried about ever again.  We now have far bigger problems to be concerned about.

Share this post


Link to post
Share on other sites

Hi there,

Due to @carl123 's comment I figured out that it might be related to the iPhone. I tried it with pictures taken from iPhone X and iPhone XR and faced the same issue. However, when I tried to download a random picture from Wikimedia Commons it worked fine.

One other thing I figured out: The pictures were originally saved as HEIC on my phone and got converted to JPG when transferring them to the Mac.
As I already wrote, I can edit the pictures properly when I save and re-open them after cropping.  So it might be that, due to the additional 'saving', some attributes are getting saved into the picture which were missing when the pictures were converted from HEIC to JPG. Does that make sense?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.