Jump to content
Copper Star Media

PDF export turns text into code? ver 305

Recommended Posts

I import PDFs from other's sometimes and modify them to fit my needs. I have Publisher on both PC Win10 and iMac. On the PC, when I'd import a certain PDF,  it would crash. So I decided to try it on the mac. This error is regarding the mac ONLY.

Opened the file fine, did a mod, then went to export to pdf for print. 

I've attached what it should look like and the second shot after I exported to pdf for print. It's like the text is in some other language.

Please forgive me for not being as knowledgeable as others on this item. Thank you.

Screenshot 2019-05-01 21.07.25.png

Screenshot 2019-05-01 21.06.56.png

Share this post


Link to post
Share on other sites

Yes, see attached.

These are files I have purchased and I modify to use as book interiors. Doing this was fine until I updated yesterday. I will say I had not tried to open THIS particular pdf previously. So it might just have to do with this particular one.

Is there something I need to do to the PDF before trying to open? Thank you for your assistance.

Wedding-Planner-red.pdf

Share this post


Link to post
Share on other sites

Nope.  I have the fonts that is required by the existing PDF. 

One thing I haven't tried is putting it through an online PDF creator. I might see if that will make it work. Maybe something in the original construction of the PDF is causing this? I'll see if this helps and report back.

Share this post


Link to post
Share on other sites

That PDF file crashes the app immediately when you try to open it with the enabled PDF setting:  "If text is to remain more editable at the expense of accurate design reproduction." When this option is disabled the PDF file opens without crashing the app.

When it crashes with above enabled option the crash report indicates ...

Quote

Crashed Thread:        3  Dispatch queue: com.apple.root.utility-qos

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

...

Thread 3 Crashed:: Dispatch queue: com.apple.root.utility-qos
0   libpdfimport.dylib                0x0000000106351537 Story::MutableDeltaVisitor<Story::RemoveAttFromDeltaVisitor<Story::GlyphAtt::Double> >::Visit(Kernel::Counted<Story::Delta>) + 23
1   libpdfimport.dylib                0x000000010634ffbe PdfImport::ListAtt::ParseDelta(std::__1::__wrap_iter<PdfImport::Char const*>, std::__1::__wrap_iter<PdfImport::Char const*>) + 286
2   libpdfimport.dylib                0x000000010634d9bc PdfImport::TextLineObject::GetListCandidate() const + 316
3   libpdfimport.dylib                0x0000000106515fa5 PdfImport::Paragraph::GetListCandidate() const + 21
4   libpdfimport.dylib                0x000000010635eb0c PdfImport::ColumnObject::GetCompatibleLists(std::__1::vector<Kernel::Counted<PdfImport::Paragraph>, std::__1::allocator<Kernel::Counted<PdfImport::Paragraph> > >&) + 60
5   libpdfimport.dylib                0x000000010635e52d PdfImport::ColumnObject::SetListCandidates(std::__1::vector<Kernel::Counted<PdfImport::Paragraph>, std::__1::allocator<Kernel::Counted<PdfImport::Paragraph> > >&) + 45
6   libpdfimport.dylib                0x000000010635df71 PdfImport::ColumnObject::SetParagraphs() + 481
7   libpdfimport.dylib                0x0000000105cdaa42 std::__1::__function::__func<PdfImport::GroupObject::Reduce(Kernel::RectT<double> const&)::$_13, std::__1::allocator<PdfImport::GroupObject::Reduce(Kernel::RectT<double> const&)::$_13>, void (PdfImport::GroupObject*)>::operator()(PdfImport::GroupObject*&&) + 98
8   libpdfimport.dylib                0x0000000105cd02f9 PdfImport::GroupObject::VisitSubGroups(std::__1::function<void (PdfImport::GroupObject*)> const&) + 137
9   libpdfimport.dylib                0x0000000105cd06e3 PdfImport::GroupObject::Reduce(Kernel::RectT<double> const&) + 979
10  liblibpersona.dylib               0x000000011c17d9b3 PdfLoader::LoadPage(Kernel::Counted<PdfImport::GroupObject>&, Kernel::SizeT<double>&, Kernel::RectT<double>&, Kernel::Counted<PdfImport::PdfDocument>, int, Kernel::Counted<PageBoundingBoxRects>&) + 1603
11  liblibpersona.dylib               0x000000011c17bd24 PdfLoader::LoadMultipleSpreads(Kernel::Counted<PdfImport::PdfDocument>, std::__1::vector<int, std::__1::allocator<int> > const&) + 212
12  liblibpersona.dylib               0x000000011c17bb38 PdfLoader::Load(Kernel::Counted<PdfImport::PdfDocument>, Kernel::Counted<LoadDocumentOptions const>) + 808
13  liblibpersona.dylib               0x00000001154972f7 DocumentController::LoadDocumentI(Kernel::StringT<Kernel::TEncUtf8> const&, bool, LoadDocumentMode, bool, bool, bool, Kernel::Counted<LoadDocumentOptions const>, OpenDocumentFailedNotification&) + 13143
14  liblibpersona.dylib               0x00000001154938ce DocumentController::LoadDocument(Kernel::StringT<Kernel::TEncUtf8> const&, bool, bool, LoadDocumentMode, Kernel::Counted<LoadDocumentOptions const>, OpenDocumentFailedNotification&, bool) + 126
15  liblibpersona.dylib               0x000000010902e420 LoadDocumentCommand::Do() + 272
16  liblibpersona.dylib               0x000000011551b5b1 PersonaController::StaticDoCommand(void*) + 49
17  liblibkernel.dylib                0x000000010713ed1c ___ZN6Kernel8Dispatch17DispatchAndForgetEPFvPvES1_NS0_16DispatchPriorityE_block_invoke + 92
18  libdispatch.dylib                 0x00007fff90eef93d _dispatch_call_block_and_release + 12
19  libdispatch.dylib                 0x00007fff90ee440b _dispatch_client_callout + 8
20  libdispatch.dylib                 0x00007fff90ee829b _dispatch_root_queue_drain + 1890
21  libdispatch.dylib                 0x00007fff90ee7b00 _dispatch_worker_thread3 + 91
22  libsystem_pthread.dylib           0x00007fff9b5ed4de _pthread_wqthread + 1129
23  libsystem_pthread.dylib           0x00007fff9b5eb341 start_wqthread + 13

 


☛ Affinity Designer 1.7.1 ◆ Affinity Photo 1.7.1 ◆ OSX El Capitan

Share this post


Link to post
Share on other sites

Thank you v_kyr. When I go on the mac to open the file up, I do not get the option to change enabled settings. I checked the preferences and could not locate it there. Where do I need to go to change the settings? 

Thanks for your help.

Share this post


Link to post
Share on other sites

When I open (File > Open ...) that PDF file I get the following PDF options panel shown up ...

open_pdf.jpg.8e7b6d838cb128e9015f324e239ea5b7.jpg

 

BTW when I alter some of the PDF contents and export as PDF, where in my case "Lucida Grande" is used as a replacement font for "Montserrat", the generated/exported PDF looks Ok, there is no bytes mismatch generated. - Thus it might have to do with the used fonts here on export in your case.

Though the app has problems with above said open PDF option when enabled and crashes with that.


☛ Affinity Designer 1.7.1 ◆ Affinity Photo 1.7.1 ◆ OSX El Capitan

Share this post


Link to post
Share on other sites

v_kyr I can't thank you enough for helping me test this. You were right. On the PC, I removed that and was able to load without issue and export as well. Thank you!!

Also, regarding the issue with the output on the iMac, it was the FONT! For some reason, just that one font was exporting weird. I changed it to several others and had NO issues.

Problems solved! Thank you folks for helping an old lady out. 

(making mental note to try changing up a few things before posting in the future. )

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×