Jump to content
macmacmac

Crash when pasting text

Recommended Posts

The newest Affinity Publisher Public Beta - 1.7.0.305 crashes when I paste text from the clipboard.

Steps:

Select some plain text in a text editor( Cmd-C).

Open a new publisher document (Cmd-N)

Paste the text (Cmd-V)

C R A S H

Previous betas worked just fine.

My OS is macOS Mojave 10.14.4

Anyone else?

Share this post


Link to post
Share on other sites
51 minutes ago, macmacmac said:

Paste the text (Cmd-V)

Are you really pasting text without first creating a Text Frame?

If so, it shouldn't crash; it should just ignore your attempt to paste.

Your workaround, which would be needed even if it didn't crash, would be to create a Text Frame first :)

 


-- Walt

Windows 10 Home, version 1903 (18362.356), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.3.481 and 1.8.0.486 Beta   / Affinity Designer 1.7.3.481 and 1.8.0.486 Beta  / Affinity Publisher 1.7.3.481 and 1.7.3.475 Beta

Share this post


Link to post
Share on other sites

Crashes here too, once with the move tool selected,

Affinity Publisher Beta_2019-04-29-113222_Mac-Pro.crash

-----------------------------------------------

and once with the frame text tool selected.

Affinity Publisher Beta_2019-04-29-113314_Mac-Pro.crash


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.7.3 | Affinity Photo 1.7.3 | Affinity Publisher 1.7.3 | Affinity Designer Beta 1.7.x.x | Affinity Photo Beta 1.7.x.x | Affinity Publisher Beta 1.7.x.x

Share this post


Link to post
Share on other sites
34 minutes ago, walt.farrell said:

Are you really pasting text without first creating a Text Frame?

If so, it shouldn't crash; it should just ignore your attempt to paste.

Your workaround, which would be needed even if it didn't crash, would be to create a Text Frame first :)

 

I used to paste the text and the text frame was created automatically (at a random size). Now it crashes.

Well I'm willing to learn the correct approach and will start to create text frames first. Thank you.

Share this post


Link to post
Share on other sites
3 hours ago, macmacmac said:

I used to paste the text and the text frame was created automatically (at a random size). Now it crashes.

As far as I know that's not supposed to work, but I suppose there's some hidden function I didn't know about :)

I can confirm that trying to paste without first having a Text Frame also crashes on Windows.


-- Walt

Windows 10 Home, version 1903 (18362.356), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.3.481 and 1.8.0.486 Beta   / Affinity Designer 1.7.3.481 and 1.8.0.486 Beta  / Affinity Publisher 1.7.3.481 and 1.7.3.475 Beta

Share this post


Link to post
Share on other sites

It seems to crash only if the text has been copied outside of Publisher.
Then it crashes both with move tool and with text tool.
 

1 hour ago, walt.farrell said:

As far as I know that's not supposed to work, but I suppose there's some hidden function I didn't know about

To me it's no hidden feature, I'd expect to paste anything from the paste board, either text or image. Mac typical only?

When I copy text from a Publisher text frame and paste it does not crash but creates a text frame with the copied text. Both with text tool and with move tool an no object selected. The cursor position does not matter, the frame gets created in the middle of the page and has the ratio of the page.

When I copy an area of an image in Macs "Preview.app" I can paste it without object selection in Publisher, both with text tool or move tool.

[ by the way, "Flycut" is a free smart app for MacOS which creates a menu icon where you can select-paste from a pulldown list any of your recent pasteboard text content. It also saves its list after reboot. https://itunes.apple.com/de/app/flycut-clipboard-manager/id442160987?mt=12 ]


macOS 10.12.6,  Macbook Pro 15" + Eizo 24"

Share this post


Link to post
Share on other sites

I'm getting a crash when pasting in any text with the move tool active, which is most definitely a bug. As Walt highlighted you can workaround it by just pasting directly into a text frame.

I've logged this, thanks for reporting.


Serif Europe Ltd. - www.serif.com

Share this post


Link to post
Share on other sites
15 hours ago, macmacmac said:

used to paste the text and the text frame was created automatically (at a random size). Now it crashes.

 

11 hours ago, walt.farrell said:

As far as I know that's not supposed to work, but I suppose there's some hidden function I didn't know about

If you paste from Word a text frame is automatically created but not from text editors like Notepad etc, they just crash Publisher v305


Due to the fact that Boris Johnson is now our Prime Minister, punctuation, spelling and grammar will never be worried about ever again.  We now have far bigger problems to be concerned about.

Share this post


Link to post
Share on other sites

This is also the case on windows 
Copied a text from a pdf and tried to paste it into Afpub,instant crash.
Whether in a textframe or without
By pasting normal or without format.
 


-------------------------------------------------------------------------------------------------------------------------------
Win10(1903)Home / Photo / Designer / Publisher & latest (beta) versions

Share this post


Link to post
Share on other sites

Same here on El Capitan: Crashes when pasting a text (from TextEdit) without creating a textframe. Works when inserting same text into a textframe.

Share this post


Link to post
Share on other sites

I had been selecting text frames via move tool and pasting text without problem.

Then.... suddenly..... when selecting move tool via keyboard shortcut "v"

..... the moment I touched the letter "v" ....  110V high electricity raced through my body... just kidding...... but Publisher crashed... 

 

on High Sierra... no crashes (knock on wood) when pasting text without formatting  command + option + Shift + V from text edit  (couldn't copy/paste from Scrivener, got strange white backgrounds behind the letters)

Share this post


Link to post
Share on other sites

I shouldn't have made fun of it...

Just five minutes later: crash of Publisher v .305  when trying to paste text into a text frame.

That thing learns fast!

 

Edit: and a while later, the paste process worked without problems... which proves my case that Affinity Publisher is listening in, and if you make a bad joke (which it considers a bad joke, then you are it, and it will crash you :)  )

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.