Jump to content

Recommended Posts

Hi, 

I downloaded the AD form the Mac App Store yesterday and started working.  Everything I export is coming out blurry.  I have the document setup at 300dpi and when I export it, it just comes out pixelated.  Even just text that looks perfect in AD is pixelated at the edges when I export.  I am exporting as png or jpg for web.  I have done it just as an export as well as a slice and nothing is coming out clear.  Pretty frustrating.  Is there something that I am doing wrong or is this just a glitch?  Any help would be appreciated.  I have attached a screen shot of the text in AD and then the exported PNG so you can see what I am talking about.

Thanks

 

Brody

post-10697-0-42040000-1430230081_thumb.png

post-10697-0-73325400-1430230164_thumb.png

Share this post


Link to post
Share on other sites

What are the pixel dimensions of the image you're exporting and how big are you placing it? You may be designing at 300dpi, but if it's only got enough pixels for 1 inch and you're using it at 5 inches then it will look blurry :)

Share this post


Link to post
Share on other sites

I am building the file at 640 x 142 @ 300dpi and then placing it at that size in the file I am using.  Even when I just open the file in say preview it is soft on the edges.  I just did a 4000 x 2000 @ 300 dpi and placed it on on the same 640 x 142 spot and its clear, but I shouldn't really need to export that large.

Share this post


Link to post
Share on other sites

I downloaded the app on another computer and opened it up and tested it out with the same settings and its clear.  So I am guessing that I just have a glitch or something it the software.  I plan on deleting the app and then downloading it again, restarting the computer and testing it out.  I will post back and let you know if I have the same issues.

Thanks!

 

Brody

Share this post


Link to post
Share on other sites

Hi Brody,

 

The image you've attached to the forum here has 640x100 pixels. In order for it to be used at 300dpi, it must occupy a space of 2.133x0.333 inches. As long as it's actually used at that physical size then it will be 300dpi and it will look good. An easy test is this: If you open your .afdesign file and just hit Cmd+8 (View->Actual Size) then this is the actual physical size at which your design should appear. Is this the size you intended to use it at? :)

 

Thanks,

Matt

Share this post


Link to post
Share on other sites

Hi Brody,

Welcome to Affinity Forums :)

I'm not sure i understood your post correctly.

What's the intended use of this image? From your first post i believe you are creating it for web use only (not for print). 

 

You can't compare the sharpness of vector objects (your text inside Affinity) with pixel objects (your exported image) because vector objects are defined mathematically - they never lose quality, while a raster image will only look good (its best) at the size it was created for (or taken - in the case of a photography).

 

In this case, since the number of pixels available (640 x 142) is relatively small for the amount of detail that the text requires, the conversion from vector to pixels makes the text blurry because the complexity of the letters (their shape) doesn't fit exactly on whole pixels.

 

When you exported from a bigger document (your 4000 x 2000 pixels example) the text looked a bit better (but still blurry) because the conversion process had more data to work with and smoothed the contours of the letters a little more. This doesn't mean it's sharper (it isn't), it's just more smoother (the pixelization was just "toned down" becoming less perceptible).

Share this post


Link to post
Share on other sites

Hello the problem still there i tried to export in affinity and photoshop the same file with the same font the difference is your text blurry in affinity and not in photoshop can you fix that ?

 

I tried exactly the same exporte the result is not the same

 

I put my exported files into self serve ( at my work ) to create web site and file with text from affinty still blurry

 

Can you provide any solution i really enjoying your product

 

Banner 250 from afifinity

 

post-16153-0-89602000-1438344507_thumb.jpg

post-16153-0-41786300-1438344960_thumb.jpg

Share this post


Link to post
Share on other sites

You've got a completely different font and size in that sample - is there any chance you could just send us a .afdesign file and the same thing as .psd and we can see if there is actually an error? Thanks :)

Matt

Share this post


Link to post
Share on other sites

Hi Helidesign,

 

This is a very old thread (last reply is 18 months ago).

 

I think you'd be better off to post your own topic, and please give as much information as possible so that people stand a good chance of helping you...

 

Are you using Mac or PC?

Affinity Designer or Photo?

Which version?

Can you attach the exported JPG / PNG?

Screenshots of the same thing in Affinity?

The afdesigner / afphoto file itself?

The equivalent PSD file for comparison?


Win10 Home x64   |   AMD Ryzen 7 2700X @ 3.7GHz   |   16 GB RAM   |   1TB SSD   |   nVidia GTX 1660   |   Huion 1060 Plus

How I make GIFs >>> ScreenToGIF (Windows only, Open Source, Portable, ~600kB)

Share this post


Link to post
Share on other sites

Hi, I just got the same problem. I've been using AD for a couple of months now, and everything was working fine. The only thing I did different this time is that I used the export persona for exporting a layered document. After this, I every image I resize gets blurry.

I tried different formats, resampling with bicubic, bilinear and all the others when resizing and when exporting. The weirdest part is that even when I try to export as SVG, it comes out blurry.

I attached an example with the original png at 2560 × 1600 and then the resized one at 500 x 312.

Any other things I should try?

 

 

Screen Shot 2018-05-26 at 8.22.24 AM.png

Screen Shot 2018-05-26 at 8.22.24 AM.jpg

Share this post


Link to post
Share on other sites
1 hour ago, ioserg said:

Hi, I just got the same problem. I've been using AD for a couple of months now, and everything was working fine. The only thing I did different this time is that I used the export persona for exporting a layered document. After this, I every image I resize gets blurry.

I tried different formats, resampling with bicubic, bilinear and all the others when resizing and when exporting. The weirdest part is that even when I try to export as SVG, it comes out blurry.

I attached an example with the original png at 2560 × 1600 and then the resized one at 500 x 312.

Any other things I should try?

 

 

 

500 pixels is far too small for that sort of image. The text ends up as two or three pixels

Assuming your monitor is 1920 x 1080 the optimum size to view it as is one quarter the size of the monitor.

If you apply a bit of unsharp mask and resize using Bicubic or Bileanar it helps, but you need more pixels. I also exported to PNG to avoid JPEG loss.

usm.png.ed1410f62558293949f2eacfb54e426d.png


Windows PCs. Photo and Designer, latest non-beta versions.

Share this post


Link to post
Share on other sites
1 hour ago, ioserg said:

I attached an example with the original png at 2560 × 1600 and then the resized one at 500 x 312.

It would be better to use a whole number scaling factor (e.g. dividing by 4 to give 640 × 400) but if that’s too big you should at least go for round numbers (e.g. 512 × 320).


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.3.481 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.8.2.174 • Designer for iPad 1.8.2.4 • iPadOS 13.3.1 (iPad Air 2)

Share this post


Link to post
Share on other sites

Thanks for your reply tlotec and alfred, but I've been using AD for 2 months and I didn't have to resize in scaling factors,  I've also been scaling large images to small ones with no issues. This is why I think I may have messed up some settings.

I've been building websites, apps, and digital design related graphics and I know it shouldn't look like this, it's way too blurry.

Another strange thing is that the same thing happens with SVG files. When I export the complete document in slices, the file gets exported in svg format, but it gets pixelated.

I already reinstalled AD to see if this fixed the problem, but it's still the same. 

Here's another example of the same image at 1000px, I'm sure it shouldn't look like this.

Screen Shot 2018-05-26 at 8.22.24 AM.jpg

Share this post


Link to post
Share on other sites

The original pictures you are showing us are PNG files the resized ones you say are wrong are JPGs

Are you sure you did not previously export these as PNG files as well (which in theory should be better quality)


Due to the fact that Boris Johnson is now our Prime Minister, punctuation, spelling and grammar will never be worried about ever again.  We now have far bigger problems to be worried about.

Share this post


Link to post
Share on other sites
9 minutes ago, carl123 said:

The original pictures you are showing us are PNG files the resized ones you say are wrong are JPGs

Are you sure you did not previously export these as PNG files as well (which in theory should be better quality)

Here's one exported in the same PNG format.

I've been saving images from JPEG to PNG and PNG to JPEG with no issues.

Screen Shot 2018-05-26 at 8.22.24 AM.png

Share this post


Link to post
Share on other sites

Hi ioserg,
Welcome to Affinity Forums :)
You said you are exporting a layered document. I also don't know if you are using artboards. In both cases please check if you have objects (this includes the artboards)/images with non-integer X,Y coordinates and or width/height dimensions in the Transform panel. If so remove the decimal part from them. Make sure you also have Force Pixel Alignment enabled in the main toolbar (also disable Move By Whole Pixels otherwise if you move scale objects the decimal part will be kept). Without seeing the affinity document i don't know what else to suggest for now.

Share this post


Link to post
Share on other sites
1 hour ago, MEB said:

Hi ioserg,
Welcome to Affinity Forums :)
You said you are exporting a layered document. I also don't know if you are using artboards. In both cases please check if you have objects (this includes the artboards)/images with non-integer X,Y coordinates and or width/height dimensions in the Transform panel. If so remove the decimal part from them. Make sure you also have Force Pixel Alignment enabled in the main toolbar (also disable Move By Whole Pixels otherwise if you move scale objects the decimal part will be kept). Without seeing the affinity document i don't know what else to suggest for now.

Thanks, I think I'm going to export it twice the size so it looks better.

Share this post


Link to post
Share on other sites

Hello guys, i'm having the same issue too ! I just don't know what caused that.

I'm mostly doing Social Network content with Affinity Designer (and picture work with Affinity Photo); i use to make things in their normal size (actual FB Banner is 820x312px) and just export it as PNG (in my old Ai days). Just put it on internet as banner and it works very well.

The with Affinity Designer, i design and everything looks good in the workspace but when i export then things gets blurry and even worst when i upload it on internet ... more strange, the same file exported for print (PNG or PDF) is sharp and nice (and peoples like it).

So i though maybe i should not design my banners using the official size but make it 4 times bigger than it should be and export it in recommanded format with recommanded size but using the export function (not the persona) and see if it works well ... but it's still strange to me as i never do complicated work and most of the time o work with vector and make small use of image/pixel content.

 

Someone to help me get it better before i do something that may kill my workflow ?

FB Banner ENG.png


Never be the Same Again !
MacBook Pro (13-inch, Mid 2010) - 2.4 GHz Intel Core 2 Duo - 8 GB 1067 MHz DDR3 - VIDIA GeForce 320M 256 MB

MacOS High Sierra 10.13.6  - Affinity Designer + Affinity Photo + Affinity Publisher + Snagit 2019 + Camtasia 2018 + Movavi Video Editor Business 15

Share this post


Link to post
Share on other sites

Just coming back into this.
I don't know but i've tested with already existing FB Banner and it's only get sharper online when the output size is doubled or tripled but the issue is: Triple size is 11meg big.

When i upload it here, compression is less than FB so you may not see what i see.

Any advice for this issue? I mean not being able to post sharper stuff on FB is an issue, right?


Never be the Same Again !
MacBook Pro (13-inch, Mid 2010) - 2.4 GHz Intel Core 2 Duo - 8 GB 1067 MHz DDR3 - VIDIA GeForce 320M 256 MB

MacOS High Sierra 10.13.6  - Affinity Designer + Affinity Photo + Affinity Publisher + Snagit 2019 + Camtasia 2018 + Movavi Video Editor Business 15

Share this post


Link to post
Share on other sites
8 hours ago, Arnaud Mez said:

(actual FB Banner is 820x312px)

A Facebook banner image should be 851 × 315 pixels. Resizing a 820 × 312 image to the standard dimensions is unlikely to keep it sharp.


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.3.481 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.8.2.174 • Designer for iPad 1.8.2.4 • iPadOS 13.3.1 (iPad Air 2)

Share this post


Link to post
Share on other sites

I'm having the same problem. 

 

Trying to make google ads and when exporting text looks blurry. Have tried different settings and changed Bilinear to Bicubic and no difference. 

Has anyone made google banner ads using text? 

Here's below image.

 

 

 

83661010_GoogleAd320x100.png.4ec75365a7aec55a5f84fab396614c76.png 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.